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Customer support

You can obtain technical support by using the BMC Software Customer Support website or by contacting Customer 
Support by telephone or e-mail. To expedite your inquiry, see “Before contacting BMC.”

Support website

You can obtain technical support from BMC 24 hours a day, 7 days a week at http://www.bmc.com/support_home. 
From this website, you can

■ read overviews about support services and programs that BMC offers
■ find the most current information about BMC products
■ search a database for issues similar to yours and possible solutions
■ order or download product documentation
■ download products and maintenance
■ report an issue or ask a question
■ subscribe to receive proactive e-mail alerts when new product notices are released
■ find worldwide BMC support center locations and contact information, including e-mail addresses, fax numbers, and 

telephone numbers 

Support by telephone or e-mail

In the United States and Canada, if you need technical support and do not have access to the web, call 800 537 1813 or 
send an e-mail message to customer_support@bmc.com. (In the subject line, enter SupID:<yourSupportContractID>, 
such as SupID:12345). Outside the United States and Canada, contact your local support center for assistance.

Before contacting BMC

Have the following information available so that Customer Support can begin working on your issue immediately:

■ product information

— product name
— product version (release number)
— license number and password (trial or permanent)

■ operating system and environment information

— machine type
— operating system type, version, and service pack or other maintenance level such as PUT or PTF
— system hardware configuration
— serial numbers
— related software (database, application, and communication) including type, version, and service pack or 

maintenance level

■ sequence of events leading to the issue

■ commands and options that you used

■ messages received (and the time and date that you received them)

— product error messages
— messages from the operating system, such as file system full
— messages from related software 

http://www.bmc.com/support_home
mailto:customer_support@bmc.com
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License key and password information

If you have questions about your license key or password, contact BMC as follows:

■ (USA or Canada) Contact the Order Services Password Team at 800 841 2031, or send an e-mail message to 
ContractsPasswordAdministration@bmc.com.

■ (Europe, the Middle East, and Africa) Fax your questions to EMEA Contracts Administration at +31 20 354 8702, or send 
an e-mail message to password@bmc.com.

■ (Asia-Pacific) Contact your BMC sales representative or your local BMC office.

mailto:ContractsPasswordAdministration@bmc.com
mailto:password@bmc.com
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About this book
This book contains procedures that you perform with the CONTROL-M/Enterprise 
Manager product, to automate, monitor, and intervene in your production 
environment. This book is intended for all users of CONTROL-M/Enterprise 
Manager (CONTROL-M/EM).

The book is organized into parts that reflect the logical progression of high-level 
tasks. Each part contains the chapters that organize the individual implementation 
tasks into related chapters. To use the information in this book most effectively, read 
the chapters in the order in which they are presented.

Like most BMC Software documentation, this book is available in printed and online 
formats. Visit the BMC Software Customer Support page at 
http://www.bmc.com/support_home to request additional printed books or to view 
online books and notices (such as release notes and technical bulletins). Some product 
shipments also include the online books on a documentation CD. 

The software also offers online Help. To access Help, press F1 within any product, or 
click the Help button in graphical user interfaces (GUIs).

NOTE  
■ BMC Software recommends that before you use this book, you become familiar with the 

concepts presented in the CONTROL-M Concepts Guide.

■ This book assumes that CONTROL-M is already installed and initially configured. The 
installation and configuration tasks are described in the CONTROL-M Installation Guide. 

■ This book does not discuss administrative tasks (for example, daily maintenance). Those 
tasks are described in the CONTROL-M Administrator Guide.

NOTE  
Online books are formatted as Portable Document Format (PDF) or HTML files. To view, 
print, or copy PDF books, use the free Adobe Reader from Adobe Systems. If your product 
installation does not install the reader, you can obtain the reader at http://www.adobe.com.

http://www.bmc.com/support_home
http://www.adobe.com
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Conventions
This book uses the following special conventions:

■ All syntax, operating system terms, and literal examples are 
presented in this typeface.

■ Variable text in path names, system messages, or syntax is displayed in italic text:

testsys/instance/fileName

■ The symbol => connects items in a menu sequence. For example, 
Actions => Confirm instructs you to choose the Confirm command from the Actions 
menu.

Syntax statements
The following example shows a sample syntax statement:

The following table explains conventions for syntax statements and provides 
examples:

COMMAND KEYWORD1 [KEYWORD2 | KEYWORD3] KEYWORD4={YES | NO} fileName...

Item Example

Items in italic type represent variables that 
you must replace with a name or value. If a 
variable is represented by two or more 
words, initial capitals distinguish the second 
and subsequent words.

alias

databaseDirectory

serverHostName

Brackets indicate a group of optional items. 
Do not type the brackets when you enter the 
option. A comma means that you can choose 
one or more of the listed options. You must 
use a comma to separate the options if you 
choose more than one option.

[tableName, columnName, field]

[-full, -incremental, -level] 
(Unix)

Braces indicate that at least one of the 
enclosed items is required. Do not type the 
braces when you enter the item.

{DBDName | tableName}

UNLOAD device={disk | tape, 
fileName | deviceName}

{-a | -c} (Unix)
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Syntax statements

A vertical bar means that you can choose 
only one of the listed items. In the example, 
you would choose either commit or cancel.

{commit | cancel}

{-commit | -cancel} (Unix)

An ellipsis indicates that you can repeat the 
previous item or items as many times as 
necessary.

columnName . . .

Item Example
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1Part

Part 1Getting started
This part presents the following topics:

Chapter 1
Introduction to CONTROL-M/Enterprise Manager . . . . . . . . . . . . . . . . . . . . . . . . . 23

Chapter 2
Working with CONTROL-M/Desktop and CONTROL-M/EM . . . . . . . . . . . . . . . 25
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C h a p t e r 1
1  Introduction to 
CONTROL-M/Enterprise Manager

This chapter presents the following topics:

Automating your production jobs with CONTROL-M/EM. . . . . . . . . . . . . . . . . . . . .  23
Where to go from here. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24

Automating your production jobs with 
CONTROL-M/EM

With CONTROL-M/Enterprise Manager, you can automate the scheduling and 
processing of your production jobs. Its main GUIs are CONTROL-M/Desktop and 
the CONTROL-M/Enterprise Manager window (simply called CONTROL-M/EM).

To automate your production environment, perform the following tasks:

■ Model your production job flow by using job processing definitions 

Job processing definitions provide CONTROL-M with the instructions for 
scheduling, submitting, and performing post-processing tasks of the jobs in your 
production environment. This book describes how to use CONTROL-M/Desktop 
to create job processing definitions and other needed entities.

■ Automate job ordering

After job processing definitions have been defined for your production jobs, you 
perform several tasks to transition your definitions to production. As part of this 
transition, you can use a feature called New Day processing to automate the 
ordering of jobs each day.
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■ Monitor (and where necessary, intervene in) the processing of your production 
jobs 

To ensure that everything is running smoothly, you can monitor job processing, 
and if problems arise you can intervene effectively. Generally, monitoring by 
exception (that is, checking problems or potential problems rather than viewing 
the entire system) is the most effective way to monitor your production jobs.

■ Analyze (and optimizing) job processing in your production jobs 

After your production jobs have been automated, you can ensure that processing is 
maximized by using analysis tools to identify areas that can be improved, such as 
resource allocation, work balancing, and so on.

This book describes how to use the GUIs of CONTROL-M/EM to automate the 
scheduling and processing of your production jobs.

Where to go from here
■ Continue with Chapter 2, “Working with CONTROL-M/Desktop and 

CONTROL-M/EM,” which explains how to start CONTROL-M/Desktop and 
CONTROL/EM, and provides the details that you need to navigate, understand, 
and effectively use these interfaces.

■ For details about defining the entities needed for automating the production 
environment, especially job processing definitions, see Part 2, “Defining the 
production environment.”

■ For details about how to transition your definitions into production and 
automating your production environment, see Part 3, “Moving to production.”

■ For details about monitoring, and when necessary, intervening in, your production 
environment after it is automated, see Part 4, “Monitoring and intervening in 
production.”

■ For details about helpful tools (including reports) for analyzing and optimizing 
your production environment, see Part 5, “Analyzing and optimizing the 
production environment.”
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This chapter provides basic information you need to start, understand, navigate, and 
manipulate CONTROL-M/Desktop and CONTROL-M/EM features. 

■ CONTROL-M/Desktop enables you to create and edit job processing definitions, 
one of the first tasks that you are likely to perform. CONTROL-M/Desktop also 
enables you to define other entities such as scheduling tables, job templates and 
calendars. After defining these entities, you can use CONTROL-M/Desktop to 
move entities that you have defined into production.
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■ CONTROL-M/EM enables you to monitor and intervene in job processing in the 
production environment. The selection of jobs you view is called a ViewPoint. 
ViewPoints are discussed in Chapter 19, “Selecting jobs to monitor.”

You should become familiar with the information in this chapter before using 
CONTROL-M/Desktop to define job processing definitions (and other entities), and 
before using CONTROL-M/EM to monitor and intervene in your production 
environment.

Starting CONTROL-M/Desktop 
1 Choose Start => Programs => CONTROL-M Enterprise Manager => 

CONTROL-M/Desktop. 

2 Enter your user name and password, select the CONTROL-M/EM GUI Server to 
which you want to connect, and click Login.

If change password fields are displayed, your password is soon due to expire. Fill 
in your new password, and then confirm it.

The CONTROL-M/Desktop window is displayed.

3 If the Load Jobs dialog box is displayed (which depends on configuration options), 
to load jobs from CONTROL-M/EM into CONTROL-M/Desktop:

A Select the jobs and tables to be loaded, and click Load, and confirm if necessary.

The Load Scheduling Table Results dialog box displays the results of the load 
operation. 

B Close the Load Scheduling Table Results dialog box. 

TIP  
If the GUI Server to be selected is not listed, contact your CONTROL-M administrator. 

NOTE  
If tables you select are locked, notify the user named in the Locked by column, or wait until 
the tables are unlocked.
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Connecting to a different GUI Server

CONTROL-M/Desktop enables you to connect to a different GUI Server at any time. 
(To check to which GUI Server you are currently connected, choose
Tools => Connection => Connection Properties.)

To change connection to a different GUI Server

1 In CONTROL-M/Desktop, choose Tools => Connection => Connect with Different 
Properties.

2 Enter your user name and password, and select the GUI Server to which you want 
to connect.

3 To specify values other than the defaults for host name, port number and Secured 
Socket Layer usage, click Advanced, and fill in the details.

4 Click Login.

Starting CONTROL-M/EM
1 Choose Start => Programs => CONTROL-M Enterprise Manager => 

CONTROL-M/Enterprise Manager GUI.

2 Enter your user name and password, select the CONTROL-M/EM GUI Server to 
which you want to connect, and click Login.

If change password fields are displayed, your password is soon due to expire. Fill 
in your new password, and then confirm it.

3 To display jobs that are in the production environment

A Choose File => Open ViewPoint.

B In the Open ViewPoint dialog box, select the ViewPoint to be used for 
displaying jobs.

C To filter jobs that will be displayed in the selected ViewPoint, click Dynamic 
Filter in the Open ViewPoint dialog box. 

TIP  
If the GUI Server to be selected is not listed, contact your CONTROL-M administrator. 
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Then do the following actions in the Dynamic Filter dialog box:

■ Optionally, select your previously defined Filter Preset.

■ Fill in the fields for filtering. For details, see “Defining dynamic filters” on 
page 206.

■ Click OK in the Dynamic Filter dialog box. 

D Click OK in the Open ViewPoints dialog box to open the ViewPoint in the 
CONTROL-M/EM window and display the selected jobs.

Troubleshooting connectivity problems
This section provides information on how to troubleshoot problems connecting the 
CONTROL-M/EM server to CONTROL-M/EM and CONTROL-M/Desktop.

The CONTROL-M/EM GUI and CONTROL-M/Desktop use a callback connection 
method for several actions such as Upload Table and Open ViewPoint.

CONTROL-M/EM uses a single XML CORBA configuration file, called config.xml 
that defines CORBA configuration data for all CORBA components (clients and 
servers included). During installation, the file is configured with default values for 
the components. Sometimes, when the client machine has more than one IP address, 
the default configuration does not provide optimum performance, resulting in a 
failure.

If the callback connection fails during login, the Connectivity Failure window is 
displayed, warning the user about the connectivity failure. Ignoring this warning 
message may result in a failure to open a ViewPoint or upload or order a table from 
the CONTROL-M/EM server.

The Connectivity Failure window indicates that the CONTROL-M/EM server is not 
connected to CONTROL-M/EM GUI client and CONTROL-M/Desktop. The 
Connectivity Failure window enables the user to resolve the problem either 
automatically or manually.

During the automatic resolution, all available IP addresses are scanned, the best IP 
address (with the shortest response time) is identified, and the CORBA configuration 
file is modified accordingly. 

Alternately, the user can manually resolve the connectivity problem, by specifying 
connection configurations and testing them.
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To automatically resolve a connectivity problem

1 Click Repair to allow for automatic identification of available IP addresses. 

The connectivity problem is automatically resolved by using the IP address 
displayed in the window.

2 Click Close.

To manually resolve a connectivity problem

1 Click Advanced to open the Troubleshoot Connectivity window.

2 In the Troubleshoot Connectivity window, temporarily clear the Use bidirectional 
communication check box for this procedure.

3 Select one of the following:

NOTE  
If the automatic resolution failed, use the manual resolution procedure described below, 
ensuring that the Use bidirectional communication check box is selected.

NOTE  
The configuration changes affect the entire installation, including client and server processes 
that were running while the changes were made. You should restart every running 
CONTROL-M/EM application, such as the CONTROL-M/EM GUI client, CONTROL-M/EM 
GUI server, CONTROL-M/Desktop, GAS server, CONTROL-M/Forecast server, BMC Batch 
Impact Manager server, and CMS server.

NOTE  
The Use bidirectional communication check box at the bottom of the window reflects the 
value of the -BiDirPolicy parameter in the CORBA configuration file. By default, all 
CONTROL-M/EM processes use bidirectional communication. 

When testing the accessibility of the hostname or IP address of the client, it is important 
that you clear the Use bidirectional communication check box. This would force the server 
to resolve the client’s address and initiate a connection back to it. After the correct 
hostname or IP address is identified, reselect the Use bidirectional communication check 
box.

If the CONTROL-M/EM GUI server cannot initiate a connection to client computers (for 
example, because of a firewall rule blocking ports for outgoing connections on the server 
side, or blocking ports for incoming connections on the client side) – all configuration 
options will fail when the bidirectional check box is cleared. In this situation, ensure that 
the Use bidirectional communication check box is selected.
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■ Use Specific IP Address - select an IP address from the list of all enabled 
network interfaces on the computer.

■ Use IP Address matching Specific mask - specify an IP mask. 

This option is recommended when using VPN connections, since the IP 
addresses may change dynamically. By using an IP mask, you avoid the need of 
reconfiguring CORBA each time you reconnect. (For example, at runtime the 
subnet mask “137.72.114.0” will prefer the IP address “137.72.114.142” to 
“192.168.241.3”.) In the configuration file, the mask is set in the –PreferIPMask 
parameter, and the hostname_in_ior value is $IP (which is evaluated at 
runtime). If this option is selected, the “$IP” characters are displayed in the 
Troubleshoot Connectivity window; accidently deleting them prevents the 
mask from being evaluated at runtime.

■ Use Virtual Hostname or IP Address - set a virtual hostname (for example, on a 
cluster machine), a known hostname, or a fixed IP address.

■ Default - the current default hostname or IP address is specified in brackets.

In the CORBA configuration file, the value of the 
–ORBDottedDecimalAddresses parameter determines whether the default is an 
IP address (value = 1) or a hostname address (value = 0).

4 Click Test. The configuration specified for the client is tested for its connectivity 
with the CONTROL-M/EM server. A check mark indicates connectivity.

5 Select the Use bidirectional communication check box. 

6 Click OK to change the CORBA configuration file according to the specified 
configuration. (Note: The configuration file is changed even if the configuration 
failed the connectivity test.)

NOTE  
■ The configuration changes affect the entire installation, including client and server 

processes that were running while the changes were made. You should restart every 
running CONTROL-M/EM application, such as the CONTROL-M/EM GUI client, 
CONTROL-M/EM GUI server, CONTROL-M/Desktop, GAS server, 
CONTROL-M/Forecast server, BMC Batch Impact Manager server, and CMS server.

■ Accessing Troubleshoot Connectivity window using 
Tools=>Connection=>Troubleshoot Connectivity and changing the configuration 
requires restarting the CONTROL-M/EM GUI client or reconnecting to the 
CONTROL-M/EM GUI server.
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Understanding the CONTROL-M/Desktop and 
CONTROL-M/EM layout 

CONTROL-M/Desktop (Figure 1) and CONTROL-M/EM (Figure 2) have very 
similar layouts.

Figure 1 CONTROL-M/Desktop displaying a draft
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Figure 2 CONTROL-M/Enterprise Manager displaying a ViewPoint

The CONTROL-M/Desktop and CONTROL-M/EM windows contain the following 
sections:

■ navigation tree pane — lists entities according to the selected hierarchy

■ main pane (work area) — displays entities in a flow diagram format, a job list 
format, or a Gantt chart format (available only if CONTROL-M/Forecast is 
installed)

You can also use the main pane to display a job editing form or a table. 

■ Net Overview pane — displayed only when a flow diagram is displayed, this pane 
displays a “thumbnail” version of the flow diagram and highlights the part of the 
flow diagram currently displayed in the main pane.

Use this display for quick navigation in the flow diagram. 

In addition, if CONTROL-M/Forecast is installed, you can display the What-If 
Scenario and Forecast Summary panes. For more details, see Chapter 26, “Planning 
production with CONTROL-M/Forecast.”
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In CONTROL-M/Desktop, the title bar identifies the type of workspace in which you 
are working (and in the local workspace, the name of the draft). The background 
color (customizable) of the panes also indicates the type of workspace.

Understanding the flow diagram

The flow diagram shows you at a glance information, such as entity type, 
relationships, and statuses.

In the flow diagram, components of the environment (definition environment or 
active environment) are represented by node boxes. The information that is displayed 
in a node varies depending on the type of node and on customization options.

NOTE  
You can customize the display for both CONTROL-M/Desktop and CONTROL-M/EM. For 
details, see Appendix A, “Customizing the interfaces.”

NOTE  

CONTROL-M/EM displays a refresh needed icon  in the toolbar if the flow 
diagram needs a refresh due to production changes. Click the icon to perform the refresh

Table 1 Node and tree icons

Symbol Information Symbol Information

Desktop (root) node Job under a BMC Batch Impact 
Manager service

CONTROL-M CONTROL-M is disconnected

Application Condition node

Group Scheduling group

Scheduling table (regular) Group scheduling table

Job (in a regular table) Job in a group scheduling table

Locked scheduling table Locked group scheduling table

Cyclic job (Note: Cyclic 
indicators are also displayed in 
forecasts generated by 
CONTROL-M/Forecast.)
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Understanding CONTROL-M/EM job node colors

Table 3 indicates the meaning of default colors that are used in the title bar in job 
nodes in CONTROL-M/EM.

Table 2 Additional icons in CONTROL-M/EM only 

Symbol Information Symbol Information

Job is executing Job is held

Job ended OK Job is waiting for a condition, 
resource or other execution 
requirement to be satisfied

Job ended NOT OK Job is waiting for a manual 
confirmation

Deleted job Job state changed to unknown

NOTE  
Free, Late, and On Request jobs do not show a visible change in the node appearance.

Nodes for Started Tasks and Emergency jobs are relevant for z/OS jobs only. For more 
information about these job types, see the CONTROL-M for z/OS User Manual.

Table 3 Job status indicated color (part 1 of 2)

Color Status Meaning

Gray Wait Condition ■ Job is waiting for the specified date, time, or In 
prerequisite condition.

■ Note: Jobs with this status might have any of the 
following statuses in CONTROL-M/Server:

— CYCLIC
— WAITTIME
— WAIT_ODAT
— POST_ODAT

Green Ended OK Job processing finished successfully.

Yellow Executing Job is executing.

Blue Wait Resource Job is waiting for Control or Quantitative resources, or 
waiting for a CONTROL-M/Agent to be available.

Pink Wait User Job is waiting for user confirmation.

Note: Jobs with this status are assigned 
WAITCONFIRM status in CONTROL-M/Server.
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Understanding colors used in nodes above the job node

The color of a high-level node (that is, any node above the job node) is determined by 
the status of its descendant nodes:

■ If all descendant nodes have the same status, the title bar of the high-level node is 
the same color as its descendants. 

■ If the descendant nodes have different statuses, the color of the high-level node is 
as described in Table 4. In this case, vertical color bars at the bottom of the node 
indicate the proportional status distributions of descendant nodes. 

Red Ended Not OK Job processing finished unsuccessfully.

Example: Agent platform on which the job was 
running was changed to disabled by a user.

White Unknown Communication with the Agent platform was 
interrupted.

Purple Not in AJF Job is not in the Active Jobs file. This status is 
displayed only in archived ViewPoints. 

EXAMPLE  
The following application node has some jobs that have Ended OK and some that have Ended 
Not OK.  

Table 4 High-level node status colors - Defaults

Color Description

White At least one job has a status of Unknown.

Red At least one job has a status of Ended Not OK.

Pink At least one job has a status of Wait User.

Blue At least one job has a status of Wait Resource.

Yellow At least one job currently has a status of Executing.

Gray All the jobs have the status Wait Condition.

Green At least one job has a status of Ended OK.

Table 3 Job status indicated color (part 2 of 2)

Color Status Meaning
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Examples

Table 5 presents examples of nodes.

Recognizing job dependencies

Job dependencies are established through prerequisite conditions (In prerequisite 
conditions and Out prerequisite conditions) in job processing definitions (see the 
CONTROL-M Concepts Guide).

Job dependencies in the flow diagram are represented by lines and arrows connecting 
job nodes, for example . (These lines can even indicate dependencies between jobs 
in different CONTROL-Ms.) The direction of arrows at the ends of the lines indicates 
the flow direction (predecessor and successor relationship) of the connected nodes.

Dotted lines between two jobs indicates a conditional link between the two jobs (for 
example, optional In conditions defined using OR logic).

NOTE  
Emergency jobs are not considered when determining the basic color of a node.

The node color of a table containing a scheduling group is determined by both the status of 
the jobs in the table and the status of the scheduling group itself. The title bar display color is 
the color representing the greatest degree of urgency.

Table 5 Sample node types

Node type Sample node

Application

Regular job 

Cyclic job (currently executing)

(Note: Cyclic indicators are also displayed in 
forecasts generated by CONTROL-M/Forecast.)
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An arrow without a connecting line at the top or bottom of a node indicates one of the 
following condition types:

■ Arrow at the top — a manual In prerequisite condition. This condition does not get 
added automatically by another job, but rather must be added manually (see 
“Manually indicating satisfied conditions” on page 234).

■ Arrow at the bottom — The Out prerequisite condition has no corresponding In 
condition or job dependent upon the condition.

In CONTROL-M/EM, the connecting lines between conditions are

■ green —condition exists (active)
■ black — condition does not exist yet (inactive)

Adjusting the display 
You can adjust the CONTROL-M/Desktop and CONTROL-M/EM display. 

Returning panes to their original positions

You can adjust and move panes in the window by clicking and dragging.

To return panes to their original positions

Choose View => Dockable Windows => Reset to Default Layout.

Changing the data display format 

You can choose from the following the data display formats:

■ flow diagram 
■ list
■ Gantt chart (available only if CONTROL-M/Forecast is installed)

To change the data display formats

Choose View => Flowdiagram, View => Job List, or View => Gantt.
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For more details about the Gantt chart, see Chapter 26, “Planning production with 
CONTROL-M/Forecast.”

Displaying dependency names in a node 

By default prerequisite conditions are not displayed in the flow diagram; only the 
dependencies they define are indicated, by the lines and arrows running between 
nodes. However, you can customize the defaults so that the flow diagram also 
displays prerequisite conditions as condition nodes. This view is most useful when 
viewing a small number of jobs.

Figure 3 Condition node in the flow diagram

To display (or hide) job dependency nodes

1 With the flow diagram displayed, choose Tools => Options.

2 Select the Links pane in the Flowdiagram Options dialog box, and then select (or 
clear) the Display condition nodes check-box.

Focusing on different level nodes (stepping in and stepping 
out) 

You can choose to view only one particular hierarchy node level in the definition 
environment — for example, you might want to view only CONTROL-M nodes.

TIP  
To see dependency names for a particular node, you do not need to display dependency name 
nodes in the flow diagram. Instead, click a top or bottom arrow of the connecting line between 
nodes to flash the dependency names.
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Changing to a higher level (for example, from Job level to Group level), is called 
stepping out; changing to a lower level (for example, from Group level to Job level), is 
called stepping in.

To change the display to different node level in the flow diagram

In the pop-up menu for the entity, choose

■  Step In — to display a lower node level
■  Step Out — to display a higher node level

Performing other display adjustments

Table 6 describes a number of other display adjustments you can perform:

 

Table 6 Additional display adjustments  (part 1 of 2)

Adjustment Step

to display or hide sub-nodes 
(expand or collapse the 
display) 

Choose Collapse or Expand from the selected node’s pop-up 
menu. (You can select multiple nodes and then perform a 
single Expand or Collapse operation.)

Tip: This operation is not available when condition nodes are 
displayed. In this case, use the Step In (or Step Out) operation 
to display different hierarchy levels.

to display a node’s job 
processing definition (or 
scheduling group) 

Double-click the node in the navigation tree or the flow 
diagram.
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Filtering the jobs displayed in a CONTROL-M/Desktop draft 

By default, all the jobs in the current draft are displayed, but CONTROL-M/Desktop 
enables you to filter which job are displayed.

To filter jobs displayed in the draft

1 In CONTROL-M/Desktop, choose View => Filter.

2 In the Filter dialog box, define selection criteria for the filter. An AND relationship 
applies to multiple criteria; a job must satisfy all specified criteria to match. 

 When defining criteria, consider the following points:

■ Most fields correspond to fields in the job editing form. For a description of the 
fields, see the CONTROL-M Parameter Guide.

■ Certain fields correspond to values for CONTROL-M parameters (for example, 
August is a value for parameter MONTHS). To specify such criteria, set the value 
to true (for example, August = true).

■ The LIKE operator treats ∗  and ? characters in the value as wildcards; the = 
operator treats ∗  and ? characters in the value as literals.

(CONTROL-M/Desktop 
only) to change the 
hierarchical arrangement of 
displayed data, between 
application hierarchy and 
scheduling table hierarchy 

In CONTROL-M/Desktop, choose View => Hierarchy and 
then choose either the Application/Group/Job hierarchy or 
the Data Center/Scheduling Table/Job hierarchy.

Note: If you change the hierarchy when displaying data in list 
format, the components that are displayed depend on the 
node you select in the navigation tree

(In the List format in 
CONTROL-M/Desktop 
only) to alternate views 
between a hierarchy view 
and a job list view 

1. With the List format displayed in CONTROL-M/Desktop, 
select Job List or Hierarchy List in the selection field in the 
CONTROL-M/Desktop toolbar.

2. To display different components in the hierarchy list or 
the job list, select appropriate node in the navigation tree.

Note: For an item selected in the tree view, the

■ hierarchy view shows all CONTROL-Ms, applications, 
groups and jobs, in hierarchical order 

■ job list view shows all related jobs, in no hierarchical order

Table 6 Additional display adjustments  (part 2 of 2)

Adjustment Step
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3 In the Action area, select how the criteria should be applied to the draft: 

■ Only jobs matching the specified criteria should currently be included in the 
filter (Set Matching jobs to be the current filter). This option is especially useful 
when no other criteria are currently applied or you want to override previously 
applied criteria.

■ Jobs matching the new criteria should be added to or removed from the current 
filter. These options are especially useful for adjustments when other criteria are 
currently applied criteria. The Remove matching jobs from the current filter option 
is also useful for defining criteria for exclusion rather than inclusion. 

■ The full draft should be displayed (that is, the filter should be nullified).

4 Click OK to filter the draft according to the specified criteria. 

Draft filters are not saved for future use. When you close the draft, the filter definition 
is lost.

Arranging the CONTROL-M/Desktop flow diagram display 

In CONTROL-M/Desktop, after you have performed many changes to the flow 
diagram, (for example, adding or modifying job dependencies), you might want to 
have CONTROL-M/Desktop rearrange the flow diagram to more neatly display the 
job flow.

To arrange the display

In CONTROL-M/Desktop, right-click anywhere in flow diagram (except on a job 
node), and select Arrange All from the menu.

TIP  
Because the relationship between multiple criteria specified in the dialog box is AND, to 
create criteria using an implied OR relationship, do the following steps:

1. Define the first criterion or first set of AND criteria, and select Set Matching jobs to be the 
current filter.

2. Then, define an OR criterion (or set of criteria, if they have an AND relationship between 
them), and select Add matching jobs to the current filter. This set is added to the filter 
(implying an OR relationship between it and the previous set). Repeat this step as needed.
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Changing click and drag in CONTROL-M/Desktop to define 
dependencies 

Normally, you click and drag the mouse to select items. In CONTROL-M/Desktop, 
however, you can also click and drag between nodes in the flow diagram to establish 
dependencies (for details, see “Defining job dependencies by using the flow diagram” 
on page 109). Therefore, before performing a click and drag, you must let 
CONTROL-M/Desktop know your purpose, by selecting the appropriate node.

To set the mode of click and drag so that it performs node selection or 
dependency definition

Do one of the following actions:

■ To set the flow diagram to Selection mode (so you can select multiple nodes), click 
. 

■ To set the flow diagram to Definition mode (so you can create dependencies), click 
. 

Creating workspaces and loading jobs into 
CONTROL-M/Desktop 

In CONTROL-M/Desktop, you need to create a workspace or draft in order to load 
jobs and scheduling tables. You can create and open multiple workspaces on the 
CONTROL-M/Desktop in online, local, or forecast modes. For more information, see 
“Understanding workspaces” on page 50.

To create workspaces or drafts

Do one of the following:

■ To create an Online workspace, choose File => New => Online Workspace.

■ To create a local workspace, choose File => New => Local Workspace.

■ To open an existing draft in the local workspace, choose File => Open.

NOTE  
Definition mode is the default mode when CONTROL-M/Desktop is started.
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To load jobs into your workspace

1 Choose File => Load jobs from CONTROL-M/EM. 

2 In the Load Jobs dialog box, select the tables and jobs, and click Load. Confirm the 
load if necessary.

3 When the list of loaded job is displayed, close it.

Navigating in the flow diagram 
You can select multiple nodes, but only one of them can be your current (focused) 
node. You can navigate among the multiple selected nodes to make a different one 
your focused node.

To navigate to, and display, a node in the flow diagram

Click the corresponding node in the navigation tree or net overview.

To navigate to a predecessor or successor node

1 In the flow diagram or navigation tree, display the pop-up menu for the node and 
select Branch Menus. Then select Predecessor or Successor.

2 In the submenu, select the target node (job, group, or condition), which is then 
selected and displayed as the current node.

To find jobs in the flow diagram that conform to specific criteria 

1 In CONTROL-M/Desktop or CONTROL-M/EM, select Edit => Find Jobs.

2 In the Find Jobs dialog box, fill in the criteria (you can specify pattern-matching 
strings in certain fields). An AND relationship applies to multiple criteria; a job 
must satisfy all specified criteria to match.

3 To save the specified Find criteria for future use, choose Presets => Save and assign 
a name in the Save Preset dialog box, and click OK.

4 In CONTROL-M/Desktop, click Select All to select all nodes matching the criteria, 
or click Find Next to select the first node that matches the criteria, and click Find 
Next again to select the next node that matches the criteria. In CONTROL-M/EM, 
click Find to select all nodes matching the criteria.
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To change the focus (navigate among multiple selected nodes)

Click the appropriate navigation button  (First),  (Previous),  (Next), or 
(Last), or use the View => Toggle Selection menu.

Identifying predecessor and successor jobs 
Using the Network Neighborhood feature, you can identify predecessor and 
successor jobs of a selected job. In CONTROL-M/EM, this feature also generates a list 
of jobs and displays their details, and you can perform other operations on the list.

To list predecessor or successor jobs and their details

1 In the flow diagram, expand all relevant group nodes so all jobs to be included are 
visible. Ensure that Condition nodes are not displayed.

2 In the flow diagram or the navigation tree, select the relevant job or scheduling 
group node.

3 In the View menu, choose Neighborhood.

4 In the Network Neighborhood dialog box, specify the following information:

■ In the Direction field, select the node relationship:

— To identify nodes branching in all directions from the selected node, select 
Radial.

— To identify the predecessor nodes of the selected node, select Predecessor.
— To identify the nodes dependent on the selected node, select Dependent.
— To identify the predecessor and dependent nodes above and below the 

selected node, select Direct Relationship.

■ In the Radius field, specify the number of nested node levels (not number of 
nodes) to branch out from the selected node. Valid values: 1-99999.

5 Click Find to select the applicable job nodes in the flow diagram. (The number of 
applicable job nodes is listed in the dialog box.)

NOTE  
To navigate directly to a predecessor or successor node without generating detail lists, use the 
branch menus options. For details, see “To navigate to a predecessor or successor node” on 
page 43.
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In CONTROL-M/EM, a display area opens at the bottom of the dialog box and 
displays the list of those jobs and their details. 

6 Either close the dialog box or do one of the following:

■ In CONTROL-M/Desktop, to save the data in a report, click Save Report and fill 
in the details.

■ While the Network Neighborhood details list is displayed in 
CONTROL-M/EM, you can perform the following tasks on that list.

Printing the flow diagram 
BMC Software recommends that you perform a Print Preview before printing the 
flow diagram. When previewing a printout, the following hints might be useful:

■ Marks on the rulers at the left and top areas of the Print Preview window, which 
are designed to help you locate nodes, indicate relative distance (not inches or 
centimeters).

■ Columns are labeled alphabetically from left to right, beginning with A. Rows are 
labeled numerically from top to bottom, beginning with 0.

TIP  
If the details display area does not open in CONTROL-M/EM, click Details (which 
alternately displays and hides this display area).

Task How to

display or hide an item count at the 
bottom of the Details list

Click Item Count in the pop-up menu for any job 
listing.

locate a listed job in the flow diagram Click Find in the pop-up menu for the job listing.

open the Job Editing form for a listed job Double-click the job listing.

export the details of the listed jobs to a 
comma-delimited (CSV) file

Click Export to File in the pop-up menu for the 
job listing.

create (and view) a text report containing 
the details about the listed jobs

Click Create Report to save this information as a 
file. (To open the saved report in your default 
text editor, click Show Report.)

display the listed jobs in their own 
ViewPoint

Click Open ViewPoint. For information on 
these ViewPoints, see “Properties of ViewPoints 
based on dependent jobs” on page 227.
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■ Pages are labeled as follows:

— Alphabetic labels indicate the horizontal sequencing.
— Numeric labels indicate the vertical sequencing,

■ You can include the rulers in the printout.

■ You can include an index of displayed nodes (only when rulers are also printed).

■ You can print the entire flow diagram or a selected page range. 

Changing your password
When your password is soon due to expire, the login dialog box of the CONTROL-M 
windows (CONTROL-M/Desktop, CONTROL-M/EM, CONTROL-M Reporting 
Facility, and CONTROL-M Configuration Manager) will display fields that enable 
you to change your password.

To change your password at any other time, you must issue the request through the 
CONTROL-M/EM or CONTROL-M/Desktop windows.

Password changes made in one application window (for example 
CONTROL-M/EM) automatically apply to the other application windows.

To change your password

1 If the change password fields are not already displayed, in the CONTROL-M/EM 
or CONTROL-M/Desktop window, choose Tools => Change Password.

2 Fill in your current and new passwords, and then confirm the new password.

3 Click OK.

EXAMPLE  
■ B.A corresponds to the first column on the second page horizontally.
■ 3.2 corresponds to the second row on the third page vertically.

NOTE  
Alternatively, you can change passwords using the User Authorizations window, but this is 
generally not recommended unless you are changing other password criteria, or changing the 
passwords for other users. For more information, see the CONTROL-M Administrator Guide.



Part 2    47

2Part

Part 2Defining the production 
environment

This part presents the following topics:

Chapter 3
Introduction to defining the production environment  . . . . . . . . . . . . . . . . . . . . . . . 49

Chapter 4
Defining how jobs should run. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Chapter 5
Organizing and managing jobs in scheduling tables . . . . . . . . . . . . . . . . . . . . . . . . 113

Chapter 8
Using predefined calendars to schedule jobs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

Chapter 9
Setting up templates for standardized job definition  . . . . . . . . . . . . . . . . . . . . . . . 141

Chapter 10
Creating and updating many jobs at once. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147

Chapter 11
Setting up definitions for periodic statistics collection  . . . . . . . . . . . . . . . . . . . . . . 155

Chapter 11
Setting up definitions for periodic statistics collection  . . . . . . . . . . . . . . . . . . . . . . 155

Chapter 15
Identifying data center resources available for CONTROL-M use . . . . . . . . . . . . 175
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C h a p t e r 3
3  Introduction to defining the 
production environment

This chapter presents the following topics:

Defining the production environment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49
Understanding workspaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

Where to go from here. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

Defining the production environment
Your largest and most fundamental task when you define the production 
environment is defining appropriate job processing definitions, which CONTROL-M 
uses to control job processing and handling. This book describes how to define job 
processing definitions by using CONTROL-M/Desktop (you can also define job 
processing definitions by using batch job creation utilities).

To define job processing definitions, you should be familiar with the concept of 
workspaces.
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Understanding workspaces

When you define job processing definitions in CONTROL-M/Desktop, you can work 
in one of the following workspaces:

■ Local workspace —enables you to work locally. You can load jobs from the 
CONTROL-M/EM database into your local workspace, in which case you are 
granted exclusive access over the jobs. When you save your work, the definitions 
are saved in a draft file that you can later reopen in the local workspace. 

For changes to be used in production, they must be written to the 
CONTROL-M/EM database and uploaded to the CONTROL-M database.

■ Online workspace — enables you to work on the CONTROL-M/EM database. 
When you load jobs from CONTROL-M/EM into an online workspace, you are 
granted shared access over the jobs. When you perform a save, the work is saved 
directly in the CONTROL-M/EM database. To be used in production, changes 
must be uploaded to the CONTROL-M database.

Regardless of which workspace you are working in when you start 
CONTROL-M/Desktop, you can change workspaces (or activate the Scheduling 
Table Manager) at any time.

Where to go from here

Review the following list, and proceed to the appropriate chapters. 

■ To define or update jobs, and place them into the appropriate databases, proceed 
to Chapter 4, “Defining how jobs should run.”

NOTE  
■ In CONTROL-M/Desktop, you can also use an interface called the Scheduling Table 

Manager to directly access and modify jobs in the CONTROL-M/EM database. In this 
case, you are not working in a workspace.

■ If the Forecast add-on is installed, you can work in a special purpose workspace called the 
Forecast workspace. 

NOTE  
These guidelines assume that you are already familiar with the information in Part 1 of this 
book. If you are not, review the instructions for starting and navigating in 
CONTROL-M/Desktop in Chapter 2 before continuing with this part of the book.
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Chapter 4, “Defining how jobs should run” is the most important chapter in this 
part of the book. It provides the instructions and examples for defining job 
processing definitions online in the job editing form and for defining scheduling 
groups online in the group editing form. Regardless of whether you are defining 
jobs online or in batch, or defining individual jobs or large numbers of jobs at once, 
this chapter is very useful.

— Decide whether the job or jobs belong to a service (BMC Batch Impact Manager) 
and make the necessary definitions. (See Chapter 22, “Monitoring 
business-critical batch services using BMC Batch Impact Manager.”)

— When you define schedules in job processing definitions, you can reference a 
calendar to simplify scheduling definition. For information on defining 
calendars, refer to Chapter 8, “Using predefined calendars to schedule jobs.”

— When you create a job processing definition, you can assign to it an existing 
template containing predefined values. To define a new template, see Chapter 9, 
“Setting up templates for standardized job definition.”

— You do not need to create and update job processing definitions individually. 
For instructions on how to automatically create or update large numbers of job 
processing definitions, refer to Chapter 10, “Creating and updating many jobs at 
once.”

■ To manage your jobs and scheduling tables (copy, delete, and so on), refer to 
Chapter 5, “Organizing and managing jobs in scheduling tables.”

When you have finished defining job processing definitions, remember that you still 
must do the following steps to automate the production environment:

■ To define security requirements as needed, see the CONTROL-M Administrator 
Guide.

■ To move to production (move jobs to production, automate job scheduling, and 
define resources and global conditions to the data center), see Part 3, “Moving to 
production.”

■ To check that the jobs work as intended, see Part 4, “Monitoring and intervening 
in production.” 

■ To analyze and optimize production, see Part 5, “Analyzing and optimizing the 
production environment.”
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C h a p t e r 4
4  Defining how jobs should run

This chapter presents the following topics: 

Defining job processing definitions and scheduling groups—basic procedure . . . . .  54
Creating and editing jobs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57

Assigning a name to the job . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  58
Identifying the task type and related information . . . . . . . . . . . . . . . . . . . . . . . . . .  58
Defining a job to run a CONTROL-M/Server utility. . . . . . . . . . . . . . . . . . . . . . . .  61
Defining the job hierarchy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63
Defining the job’s owner and author  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63
Defining job documentation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63
Defining scheduling criteria for a job—basics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  64
Defining scheduling criteria using calendars . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65
Defining complex scheduling criteria using rules  . . . . . . . . . . . . . . . . . . . . . . . . . .  66
Limiting scheduling to a particular date range. . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Permitting scheduling even after the scheduling date passed . . . . . . . . . . . . . . . .  73
Defining cyclic jobs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73
Defining automatic rerun for a job that ends NOT OK . . . . . . . . . . . . . . . . . . . . . .  75
Defining jobs that should run on specific nodes. . . . . . . . . . . . . . . . . . . . . . . . . . . .  76
Defining jobs that should run on nodes where load balancing has been 

implemented . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  77
Defining a time frame during which jobs can be submitted. . . . . . . . . . . . . . . . . .  77
Defining that manual confirmation is required before job submission. . . . . . . . .  78
Assigning priorities to jobs and defining and critical jobs  . . . . . . . . . . . . . . . . . . .  79
Defining how many days a job can await submission. . . . . . . . . . . . . . . . . . . . . . .  80
Defining dependencies for the current job  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  81
Allocating resources for a job  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83
Defining and using variables that are dynamically resolved at runtime . . . . . . .  84
Defining postprocessing actions that depend on job processing results. . . . . . . .  87
Defining conditional processing under z/OS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  94
Defining messages to be shouted at the end of job processing. . . . . . . . . . . . . . . .  96
Defining how to handle the job’s sysout when the job ends OK . . . . . . . . . . . . . .  98
Archiving sysdata (z/OS only) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  99

Creating and editing scheduling groups  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  99
Defining general scheduling group information  . . . . . . . . . . . . . . . . . . . . . . . . . .  100
Defining scheduling criteria for a scheduling group . . . . . . . . . . . . . . . . . . . . . . .  101
Defining dependencies, variables, and notifications in the scheduling group  .  103
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Defining actions to be performed after all scheduled jobs in the table have ended   
104

Creating and editing jobs in a group scheduling table . . . . . . . . . . . . . . . . . . . . . . . . . 106
Defining scheduling criteria for a job in a group scheduling table  . . . . . . . . . . . 106

Copying scheduling tags from one scheduling group to another. . . . . . . . . . . . . . . . 109
Defining job dependencies by using the flow diagram  . . . . . . . . . . . . . . . . . . . . . . . . 109

Defining a condition format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

This chapter provides tips, and examples, on how to define individual job processing 
definitions and scheduling groups. 

A scheduling group is different than a job processing definition in that a scheduling 
group is really an extended set of table definition parameters for a group scheduling 
table. The scheduling group defines how the group scheduling table should process 
its jobs as a unified group.

Nevertheless, the procedure for defining job processing definitions and the procedure 
for defining scheduling groups are quite similar, and they are described together.

Defining job processing definitions and 
scheduling groups—basic procedure

In CONTROL-M/Desktop, you create and modify 

■ jobs processing definitions using the job editing form 
■ scheduling groups using the group editing form

To define a job or scheduling group

1 In CONTROL-M/Desktop, do one of the following actions:

■ To modify an existing job or scheduling group, double-click the job or 
scheduling group in the flow diagram, navigation tree or list display. 

■ To create a new job processing definition, choose Edit => New Job.

■ To create a new scheduling group, choose Edit => New Scheduling Group.

TIP  
An easy way to find a job is to choose Edit => Find Jobs.
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The job editing form (or group editing form) opens.

Figure 4 Job editing form 

2 If you are creating a new job (or scheduling group), do the following steps:

A In the Apply Template field in the toolbar, select the template to be applied. 
(Optional. You can select the value <No Template>.)

The product is supplied with a default job and default scheduling group 
template for each platform. Icons indicate whether templates are job templates 
or scheduling group templates.You can modify the templates or define others. 
For details, see Chapter 9, “Setting up templates for standardized job 
definition.”

NOTE  
You must be working in a local workspace to create a scheduling group, and you must 
create the scheduling group before you create any job processing definitions in the 
group scheduling table.

TIP  
You can use a scheduling group template not only for defining scheduling groups, but 
for defining jobs in a group scheduling table.
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B In the CONTROL-M field, select the CONTROL-M that will control the job.

C In the Job type field, select the type of job. 

The default value is OS. Select this value except in the following situations:

■ For mission critical jobs, if the BMC Batch Impact Manager product is 
installed, select BIM.

■ For external application jobs, such as SAP or Oracle E-Business Suite, select 
the appropriate job type, but first ensure that the relevant Control Module is 
installed, and the appropriate application form has been imported. 

To import Application forms, choose Tools => Import Application Form and 
browse to and select the form. For details, see the relevant Control Module 
administrator guide.

3 Edit the definition as described in one of the following (as appropriate):

■ “Creating and editing jobs” on page 57
■ “Creating and editing scheduling groups” on page 99
■ “Creating and editing jobs in a group scheduling table” on page 106

NOTE  
Which templates types are displayed in the template list can be customized. For details, 
see the customization option “List all templates” on page 290 in Appendix A, 
“Customizing the interfaces.”

NOTE  
Starting with CONTROL-M/EM 6.3.01, Job Type replaces the following parameters: 
Application Node Group (but not Node Group or Node ID/Group), Form Name, 
Application type, Application version and CM version.

NOTE  
If you selected a Job Type value other than OS, a tab related to the particular job type is 
automatically added as the second tab in the job editing form. For instructions on filling in 
this additional tab, see the following:

■ For a BIM tab, see the CONTROL-M Business Service Management Solution User Guide.
■ For an external application tab, see the appropriate Control Module administrator 

guide.

TIP  
To be able to use this job definition as a basis for creating other jobs, click Save as Template 
before proceeding.
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4 Save the definition by clicking Save, Save & Close or Save & Order at the top of the 
editing form. When saving the definition, consider the following:

■ If you save the job while working in an Online workspace or working through 
the Scheduling Table manager, the new or modified job processing definition is 
saved directly in the CONTROL-M/EM database. To use the job in production, 
you must perform an upload to the CONTROL-M/Server database. 

■ If you save the job while working in a Local workspace, the new or modified job 
processing definition is saved in a draft. To use the job in production, you must 
write the job (actually, its table) to the CONTROL-M/EM database and upload 
the table to the CONTROL-M/Server database. 

■ If you order or force the job, a dialog box is displayed that enables you to upload 
(and write) the job as part of the order/force request. Fill in the dialog box as 
described in “Manually scheduling jobs and tables” on page 168.

For details about writing and loading tables and jobs, see Chapter 13, “Putting jobs 
into production.”

This product comes with a draft containing sample job processing definitions. For 
an explanation of how and why these job processing definitions were defined the 
way they were, see Appendix B, “Examples for defining jobs.”

Creating and editing jobs
This section describes the following topics:

Assigning a name to the job
Identifying the task type and related information
Defining a job to run a CONTROL-M/Server utility
Defining the job hierarchy
Defining the job’s owner and author
Defining job documentation
Defining scheduling criteria for a job—basics
Defining scheduling criteria using calendars
Defining complex scheduling criteria using rules
Limiting scheduling to a particular date range
Permitting scheduling even after the scheduling date passed
Defining cyclic jobs
Defining automatic rerun for a job that ends NOT OK
Defining jobs that should run on specific nodes
Defining jobs that should run on nodes where load balancing has been 
implemented
Defining a time frame during which jobs can be submitted
Defining that manual confirmation is required before job submission
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Assigning priorities to jobs and defining and critical jobs
Defining how many days a job can await submission
Defining dependencies for the current job
Allocating resources for a job
Defining and using variables that are dynamically resolved at runtime
Defining postprocessing actions that depend on job processing results
Defining messages to be shouted at the end of job processing
Defining how to handle the job’s sysout when the job ends OK

The job editing form consists of a series of tabs, each providing a set of parameters for 
defining job processing definitions.

Assigning a name to the job

In the General tab, in the Job Name field, you must assign a name to each job 
processing definition. This name (along with the file name parameter) appears in 
various job definition and job tracking displays, enabling you to identify the job. You 
also use this name when ordering or forcing jobs.

Identifying the task type and related information

You must identify the type of task this job processing definition performs. Different 
task types require different accompanying information, so depending on the task 
type select, certain fields displayed in the tab might change to accommodate the 
information required. (Task types and their accompanying fields might also vary 
somewhat according to platform.) This section describes how to fill in task type and 
related information for UNIX and Windows platforms. For more details, or for 
information relating to other platforms, see the CONTROL-M Parameter Guide.

NOTE  
■ A red asterisk indicates required fields.

■ The fields displayed in the job editing form might vary according to the type of job (z/OS, 
group, and so on). 

■ To sequentially undo entries, click Ctrl+z. To sequentially redo undone entries, click 
Ctrl+y. This feature works even when the page with the entry is not currently displayed.

■ Most fields are self-explanatory and not explained here. For a detailed description of the 
job editing form fields, see the CONTROL-M Parameter Guide. 
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To identify the type of task the job performs, and related information

1 In the General tab, select the task type appropriate to the job, in the Task Type field:

■  If the job processing definition provides CONTROL-M with information for 
submitting a job for execution as a background process, and instructions for 
performing postprocessing following job execution, select Job. This applies to 
most production batch jobs submitted under CONTROL-M.

■ If the job processing definition provides CONTROL-M with instructions for 
running an executable (.exe) file, select Detached.

■ If the job processing definition provides CONTROL-M with an operating 
system command to be executed as a job (that is, so that CONTROL-M will track 
and analyze the results and perform postprocessing), select Command. You can 
also use Command-type jobs to run certain CONTROL-M/Server utilities. For 
details, see “Defining a job to run a CONTROL-M/Server utility” on page 61.

■ If the job processing definition instructs CONTROL-M to analyze the results of 
jobs not submitted under CONTROL-M (for example the job is submitted under 
an external application such as SAP), select External.

■ If the job processing definitions is not responsible for execution of a job or 
operating system command, but merely instructs CONTROL-M to perform 
postprocessing actions such Shout or adding Out conditions, select Dummy. 
This task type is useful if you want these postprocessing instructions to be 
performed as a result of the outcome of other jobs, or as a result of a change of 
status in the system. 

2 Fill in the accompanying fields that are specific to the task type:

■ If the task type is Job or Detached, do one of the following:

■ specify a job script or executable file by doing the following:

— in the File Name field, specify the job script or executable file
— in the Path field, specify the full path to the job script or executable file

■ embed a job script by doing the following:

— select Embedded Script, click Edit, and type in a script or load it from a file
— in the File Name field, specify the job script’s logical name

■ If the task type is Command

— in the Command field, specify the operating system command

■ For task type Dummy, no accompanying fields in this section are required.
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TIP  
By default, the File Name value is displayed in the flow diagram job node. For Command 
and Dummy jobs, to display the job name in the job node, copy the job name to the File 
Name field. (Alternatively, you can change the job node display defaults.) 

EXAMPLE  
The CalcExpenses.bat batch job, which calculates the expenses incurred by the company on 
the current day, should be scheduled, submitted, and monitored by CONTROL-M, which 
should also perform any required postprocessing.

Fill in the task type and related information, as follows:

1. In the Job Name field, specify CalcExpenses.

2. In the Task Type field, select Job.

3. In the File Name field, specify CalcExpenses.bat.

4. In the Path field, specify C:\Prod\Acct\Calc.

EXAMPLE  
CONTROL-M should be responsible for the scheduling, submission, and postprocessing for 
the SystemStatus.exe executable job, which determines those external applications that are up 
and those that are down.

Fill in the task type and related information, as follows:

1. In the Job Name field, specify SystemStatus.

2. In the Task Type field, select Detached.

3. In the File Name field, specify SystemStatus.exe.

4. In the Path field, specify C:\System\Maint\.
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Defining a job to run a CONTROL-M/Server utility

CONTROL-M/EM comes with a draft file, Control-M Server Utilities.drf, containing 
sample job processing definitions for running several CONTROL-M/Server utilities. 
The file is located in the BMC Software\CONTROL-M EM <version>\<instance_ 
name>\Samples directory. 

You can use these sample jobs as a starting point for defining Command-type jobs to 
invoke these utilities. Table 7 identifies the jobs and their utility functions. For more 
information about CONTROL-M/Server utilities, see the CONTROL-M Utility Guide.

EXAMPLE  
CONTROL-M should use an operating system command to backup daily transactions; it 
should also monitor the results and perform post-processing if needed:

 Fill in the task type and related information for the BkpDailyTrans job, as follows:

1. In the Job Name field, specify BkpDailyTrans.

2. In the Task Type field, select Command.

3. In the Command field, specify Copy D:\Data\Transactions\Daily%%ODATE.txt E:\.

4. (Optionally, in the File Name field, specify BkpDailyTrans so the name appears in the 
flow diagram job node.)

EXAMPLE  
In the event of an emergency that requires evacuation of the site, the site manager submits the 
Evacuation Alert emergency job, which shouts a message to all personnel to shut down their 
machines and leave the building.

Fill in the task type and related information, as follows:

1. In the Job Name field, specify EvacuationAlert.

2. In the Task Type field, select Dummy.

3. (Optionally, in the File Name field, specify EvacuationAlert so the name appears in the 
flow diagram job node.)

Table 7 CONTROL-M/Server utility jobs  (part 1 of 2)

Job name Utility

ctmcontb Performs operations on the Prerequisite Conditions table.

ctmcreate Creates a job in the Active Jobs file.
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To define a Command-type job that runs a CONTROL-M/Server utility

1 In CONTROL-M/Desktop, choose File => Open, browse to the 
BMC Software\CONTROL-M EM <version>\Default\Samples directory, and open 
the Control-M Server Utilities.drf draft file.

2 Using Table 7 as a guide, edit the appropriate job processing definition, as follows:

A In the General tab, be sure to specify values for the following fields:

■ Author (if enabled)
■ CONTROL-M
■ Node ID/Group
■ Owner

B If you are working in the ctmcreate or ctmdefine job, be sure to update the 
command line in the General tab. You can modify the command line for any job 
according to need.

C Modify the other parameters in the job editing form as needed.

ctmdefine Defines a job in the CONTROL-M/Server database.

ctmkilljob Terminates a CONTROL-M job and its associated processes.

ctmloadset Updates a resource in the Quantitative Resources table with 
regard to usage on an Agent platform.

ctmorder Orders one or more jobs from a scheduling table contained in 
the CONTROL-M/Server database.

ctmudly Orders jobs for a specific User Daily.

ctmvar_set Sets a variable. Manipulates Global AutoEdit variables for 
data centers, group scheduling tables, or jobs in group 
scheduling tables.

ctmvar_delete Deletes a variable specification. 

ecactltb Lists the status of each resource in the Control Resources 
table.

ecaqrtab Performs operations on the Quantitative Resources table.

ecaqrtab_add Adds a resource

ecaqrtab_list Deletes a resource.

Table 7 CONTROL-M/Server utility jobs  (part 2 of 2)

Job name Utility
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Defining the job hierarchy

In the General tab, you must select the following hierarchy information for each job 
processing definition: scheduling table, application and group. (For information 
regarding this hierarchy information, see the CONTROL-M Concepts Guide.) 

Defining the job’s owner and author

For security and authorization reasons, you must specify in the General tab an owner 
and author for each job processing definition:

■ The author is the person who defines the job.
■ The owner is the User ID associated with the job—that is, for whom the job is 

executed.

Defining job documentation

BMC Software recommends that you provide a brief description of the job processing 
definition in the Description field in the General tab. This information often appears in 
displays, such as job nodes, enabling you to know at a glance what the job does.

You can also create a documentation .txt file to provide much greater detail about the 
job. For example, you might want to document the purpose of the job, under what 
conditions it should run, necessary prerequisites, whom to notify if there are 
problems, and so on.

If you define such a documentation file, specify the file name and path in the Doc File 
and Doc Path fields in the General tab.

NOTE  
If the table, application or group does not yet exist, type the information in and 
CONTROL-M/Desktop will automatically create the items.



Defining scheduling criteria for a job—basics

64 CONTROL-M User Guide

Defining scheduling criteria for a job—basics

Define the job’s schedule in the Scheduling tab. You can use any number of 
approaches and parameters to define the jobs schedule:

Figure 5 Scheduling tab in the job editing form

TIP  
If CONTROL-M/Forecast is installed, you can graphically display when and how often jobs 
will be scheduled by clicking Forecast. 
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To schedule the job on specific days, week days, and months

Most commonly, you will want to specify some combination of months, days of the 
month, and days of the week. You do this by performing the following as needed:

■ Click the days of month in the Month Days area
■ Click the days of the week in the Week Days area
■ Set the relationship between the selected Month days and Week days by clicking 

And or Or.
■ Click the months in the Month area.
■ Additionally or alternatively, you can specify specific dates (months and days, for 

example, 08/09) in the date area.
 

 

Defining scheduling criteria using calendars

When the same schedule is used by a lot of jobs, you can define the schedule in a 
calendar. For details about defining calendars, see Chapter 8, “Using predefined 
calendars to schedule jobs.”

To use a calendar in the jobs schedule, select the calendar in the Month Days area or 
the Week Days area. Unless you are applying rules (“Defining complex scheduling 
criteria using rules” on page 66), there is no difference between those selection fields 
or their impact. 

EXAMPLE  
The job should be scheduled every day.

1. Click All in the Month Days area. 

2. Click All in the Months area.

EXAMPLE  
The job should be scheduled on the first day following the end of each quarter.

1. Click 1 in the calendar in the Month Days area.

2. Click Apr, Jul, Oct, and Jan in the Month area.

EXAMPLE  
The job should be scheduled every Monday through Friday.

1. Click All in the Months area.

2. Click Mon, Tue, Wed, Thu, Fri in the Week Days area.
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To limit the calendar to specific days, weekdays or months, click those values. The 
relationship between them and the calendar is And (that is, the job will be scheduled 
only if the calendar and the months, days and weekdays values are satisfied). 

 

 

 

Defining complex scheduling criteria using rules

Sometimes required values cannot simply be specified as absolute values, as the 
following situations illustrate:

■ To schedule a job on the last day of the month, clicking 31 in the Month Days area 
will not work because there are months with 30 days or less. 

NOTE  
More complex relationships can be specified for various dates and calendars. For details, see 
“Defining complex scheduling criteria using rules” on page 66.

EXAMPLE  
Schedule the job on all working days of the year. (The Workdays calendar schedules jobs on 
all working days of the year.)

In the Calendar field, select Workdays.

EXAMPLE  
Schedule the job on all working days in July and August. (The Workdays calendar schedules 
jobs on all working days of the year.)

1. In the Calendar field, select Workdays.

2. In the Months area, click July and August.

EXAMPLE  
Schedule the job on all working Mondays in July and August. (The Workdays calendar 
schedules jobs on all working days of the year.)

1. In the Calendar field, select Workdays.

2. In the Months area, click July and August.

3. Click And.

4. In the Week Days area, click Mon.
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■ You are using a defined calendar, but want to exclude certain days that appear in 
the calendar.

In such cases, using Rules can be helpful. You can specify Rules by clicking Rules in 
the appropriate (Month Days and or or Week Days) area.

To define complex scheduling criteria using rules

1 To apply rules, click Rules in the appropriate area.

2 In the displayed dialog box, click the appropriate tab.

3 Select or fill in the values, as follows:

■ In the Month Day and or or Week Days tab, click the days (you can select 
multiple values), and then click the rule format button.

■ In the Regular Rules tab, fill in the numeric values only (for example, specify 3, 
not L3 or +3) in the rule’s entry field. Separate multiple values by commas.

■ In the Periodic Rules tab, fill in the numeric value and period only (for example, 
3b) in the rule’s entry field. Separate multiple values by commas.

4 Fill in other regular scheduling data.

5 If you specified Month Day rules that are relative to a calendar, fill in the calendar 
name in the Month Day area; If you specified Week Day rules that are relative to a 
calendar, fill in the calendar name in the Week Day area.

 

EXAMPLE  
Schedule the job on the last day of the month.

1. Click Rules in the Month Days area.

2. In the Regular Rules tab, in the field under the label Order the job on the n-th calendar 
days counting from the end of the month (Ln), enter 1. 

3. Click OK.

The results will be as follows:

■ In a month with 31 days, the job will be ordered on the 31st day of the month.
■ In a month with 30 days, the job will be ordered on the 30th day of the month.
■ In a month with 28 days, the job will be ordered on the 28th day of the month.
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EXAMPLE  
Schedule the job on the last day of the month if that day falls on a workday (Monday - Friday). 
If the last day is a weekend, shift the scheduling to closest preceding workday.

1. Click Rules in the Month Days area.

2. In the Regular Rules tab, in the field under the label Order the job on the n-th calendar 
days counting from the end of the month (Ln), enter 1. 

3. Click OK.

4. Between the Month Days area and the Week Days area, click And.

5. In the Week Days area, select Mon, Tue, Wed, Thu, and Fri.

6. Click Rules in the Week Days area, and in the Week Days tab of the Special Week Rules 
dialog box, select Saturday and Sunday and click <n.

7. Click OK.

EXAMPLE  
Schedule the job on the 5th and 10th days from the end of the month.

1. Click Rules in the Month Days area.

2. In the Regular Rules tab, in the field under the label Order the job on the n-th calendar 
days counting from the end of the month (Ln), enter 10,5. 

3. Click OK.

The results will be as follows:

■ In a month with 31 days, the job will be ordered on the 22nd and 27th day of the months.
■ In a month with 30 days, the job will be ordered on the 21st and the 26th day of the month.
■ In a month with 28 days, the job will be ordered on the 19th and 24th day of the month.
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EXAMPLE  
Schedule the job on the 1st and 15th day of the month even when they do not appear in the 
calendar, and to ensure that the job will not be scheduled on the 10th and 25th day of the 
month even when they appear in the calendar, do the following in the Special Month Days 
tab.

1. Click Rules in the Month Days area. 

2. In the Month Days tab

A.  Click 1 and Ctrl 15 in the tab’s calendar.

B. Click +n.

C. Click 10 and Ctrl 25 in the tab’s calendar.

D. Click -n.

E. Click OK.

3. In the Month Days area, specify the calendar name.

The job will be ordered on every day marked as a working day in the calendar, except on the 
10th and 25th; it will also be ordered on the 1st and 15th of the month even if they are not 
working days in the calendar.

EXAMPLE  
Schedule the job on the all days in the calendar except those that fall on Wednesday.

1. Click Rules in the Week Days area.

2. In the Week Days tab, click Wednesday, and then click -n.

3. Click OK.

The job will be scheduled on all dates in the calendar unless the date falls on a Wednesday.
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EXAMPLE  
Schedule the job on the 5th and 10th days of period A, and ensure that the job will not run on 
the 5th and 10th days of period B.

1. Click Rules in the Month Days area. 

2. In the Periodic Rules tab

A.  In the field under the label Order the job on the n-th day of period i from the 
beginning of the period, enter 5A, 10A.

B. In the field under the label Don’t order the job on the n-th day of period i from the 
beginning of the period, enter 5B, 10B. 

C. Click OK.
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Limiting scheduling to a particular date range

You can specify a date range during which a job or group scheduling table is eligible 
to be scheduled if other scheduling criteria are satisfied.

This range can be expressed in either of two formats:

■ An active period during which a job can be scheduled, sandwiched between two 
inactive periods:
(inactive-period1 > active-period > inactive-period2)

■ An inactive period during which a job cannot be scheduled, sandwiched between 
two active periods:
(active-period1 > inactive-period > active-period2)

To define an active date range during which the job can be scheduled

1 In the Active field, select From.

2 In the field immediately after From, select the earliest date the job can be scheduled.

3 In the To field, select the latest date the job can be scheduled.

 

NOTE  
The Active parameter appears as a single parameter with several subparameters in the job 
editing form and the group editing form. In all other CONTROL-M components, the Active 
parameter appears as two separate parameters that function together — the Active From Date 
parameter, and the Active To Date parameter. Despite this difference in appearance, which is 
only a user interface issue, the processing functionality remains the same in all CONTROL-M 
components. 

NOTE  
Optionally, you can leave either the From value blank (for no lower limit), or the To value 
blank (for no upper limit).

EXAMPLE  
Limit the dates that the job can be scheduled to: August 6th, 7th, 8th, 9th, 10th, and 11th.

1. In the Active field, select From.

2. For the From value, select August 6 on the calendar.

3. For the To value, select August 11 on the calendar.
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To define an inactive date range during which the job cannot be scheduled

1 In the Active field, select Until.

2 For the Until value, select the last date of the first active period (active-period1) 
during which the job can be scheduled. The inactive period begins the day after 
this date.

3 For the And From value, select the first date of the second active period 
(active-period2). The inactive period ends the day before this date. This date must be 
later than the Until value.

NOTE  
When specifying a date range using the Until – And From format, you must specify both 
values.

EXAMPLE  
Do not allow the job to be ordered on: August 6th, 7th, 8th, 9th, 10th, and 11th.

1. In the Active field, select Until.

2. For the Until value, select August 5 on the calendar.

3. For the And From value, select August 12 on the calendar.
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Permitting scheduling even after the scheduling date passed

You can ensure that if a job did not get ordered on its original scheduling date (for 
example, if the computer is out of service for a day or more), it is ordered after its 
original scheduling data has passed.

To enable a job to be scheduled even after its scheduling date passed

In the Scheduling tab, click Retro.

The Retro parameter indicates to the New Day procedure or User Daily if the job 
should be retroactively scheduled for days the computer (or CONTROL-M) was 
inactive. CONTROL-M/Server places job orders in the Active Jobs file for all days 
that the job should have been scheduled, from the day following the last running date 
of the New Day procedure (or User Daily) to the current working date. Each job order 
placed in the Active Jobs file uses one of the passed scheduling dates.

Defining cyclic jobs

A cyclic job can be defined using one of the following methods:

■ fixed interval - job runs are separated by the specified interval

■ variable interval sequence - job runs are separated according to the specified 
sequence of intervals

NOTE  
There is no reason to click Retro in a User Daily job. Only the most recent User Daily job order 
can orders jobs, and User Daily job order performs Retro ordering for all indicated jobs

EXAMPLE  
To schedule the job for every workday, regardless of whether the computer is active, click 
Retro.

Assume the following:
■ The WorkDays calendar contains the dates 15, 16, 18, and 19.
■ The computer was down from the 16th through the 18th.
■ The 15th was the last date that the job was scheduled for execution.
■ Today is the 19th.

The job is scheduled three times with the original scheduling dates 16, 18 and 19 (that is, three 
job orders are added to the Active Jobs file).
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■ specific job rerun times - job runs are according to the specified job start times

To define a cyclic job

1 In the Rerun Information area of the Execution tab, select Cyclic Job and click Set.

2 In the Cyclic Job Run Times dialog box, do one of the following:

■ Specify the rerun intervals between job runs, either

— by selecting the rerun interval and the measurement unit

— or by entering an interval sequence 

and then select whether the cycle should be measured from the start, end or 
target (scheduling) time of the current instance. 

■ Enter specific times for the job runs and select a lateness tolerance.

3 Select the maximum number of reruns.

NOTE  
■ If Cyclic Job is not selected, the job is not affected by the values and rerun descriptions 

that are displayed in the Rerun Information area.

■ CONTROL-M/Server sorts the times entered in Specific Times and runs the job starting 
from NewDay time (or Order time) according to chronological order, until the next New 
Day time. 

TIP  
■ To provide logic to stop a cyclic job (for example, if the job ends not OK), create the 

relevant On statement followed by a Do Stop-cyclic statement in the Steps tab.

■ You can use the Maxwait parameter in the Execution tab for cyclic jobs as well as 
non-cyclic jobs, to determine the maximum number of days the job can remain in the 
Active Jobs file after its ODAT has passed, if the job has not yet been submitted.
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Defining automatic rerun for a job that ends NOT OK

Defining automatic rerun for a job that ends not OK requires that you specify the 
necessary rerun parameters in the Execution tab, and the On-Do conditional logic to 
trigger the automatic rerun in the Steps tab.

To automatically rerun a job that ends notok

1 In the Rerun area of the Execution tab, select

■ the rerun interval, the measurement unit, and whether the rerun should be 
measured from the start, end or target (scheduling) time of the current instance

■ the maximum number of reruns (0 -99)

2 In the Steps pane, select/specify

■ On Statement stmt=* code=Notok
■ Do Rerun

 

EXAMPLE  
A job that updates flight times for an airline should cycle through every 3 minutes from the 
end of the previous run. If for some reason it fails, it should trigger an alternative flight update 
program, shout a message to the administrator, and stop running.

1. In the Execution panel

■ Click Cyclic Job and Set.
■ Select the following rerun cycle: Rerun every 3 minutes from job’s end.
■ Select 99 as the maximum reruns value.

2. In the Steps panel, do the following:

A. Define the following On Statement: stmt=* code=notok.

B. Define the following Do statements:

■ Do Force Job Table=flight Job Name=AltUpdate Date=ODAT 
■ Do Shout To=Admin Urgn= Very Urgent Msg = Failure in flight update job
■ Do Stop cyclic 

NOTE  
 The maximum reruns value applies only to automatic reruns triggered by the On-Do 
statements. Reruns that you manually request from CONTROL-M/EM are not counted 
toward this total.
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Defining jobs that should run on specific nodes

Normally, CONTROL-M/Server can submit a job on any computer having a 
CONTROL-M/Agent or designated as a remote host for that server. 

To have a job submitted on a specific computer

In the Node ID/Group field in the Execution tab, select the node ID of that computer.

 

EXAMPLE  
A job that ends not OK should be rerun once. If it still fails, it should trigger an alternative job 
and shout a message to the administrator.

1. In the Execution panel, do the following:

A. Select the following rerun cycle: Rerun every 1 minutes from job’s end.

B. Select 1 as the maximum reruns value.

2. In the Steps panel, do the following:

A. Define On Statement: stmt=* code=notok.

B. Define Do statement: Rerun.

C. Define On Statement: stmt=rerun code=*rerun*error*. 

D. Define the following Do statements:

■ Do Force Job Table=table1 Job=AltJob Date=ODAT 
■ Do Shout To=Admin Urgn= Urgent Msg = Rerun JobX failed. Alternate job forced 

NOTE  
For application type jobs only: If the Node IDs do not appear in the selection list, click Load; 
then select the node ID. 

EXAMPLE  
A job should only be submitted by the CONTROL-M/Agent resident on the pqrs3693 host 
machine.

In the Node ID/Group field in the Execution tab, select the pqrs3693 node ID.
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Defining jobs that should run on nodes where load balancing 
has been implemented

If your site has implemented load balancing, you can define the job to run on a node 
in a specified load balancing group. CONTROL-M/Server will then select the node in 
that group according to the load balancing algorithm. 

To have a job submitted on a node in a load balancing group

In the Node ID/Group field in the Execution tab, select the group. (If the groups do not 
appear in the selection list, click Load; then select the group.)

 

Defining a time frame during which jobs can be submitted

To limit the time frame during which CONTROL-M can submit a job, define the time 
frame in the Activity Period area of the Execution tab. 

To define a time frame during which jobs can be submitted

1 To define the earliest time that a job can be submitted, specify the time (in hhmm 
format) in the Submit between field in the Execution tab.

2 To define the latest time that a job can be submitted, specify the time (in hhmm 
format) in the (time) to field. 

3 To link the time frame to a time zone other than the CONTROL-M/Server’s time 
zone (for example, to the CONTROL-M/Agent’s time zone), select the time zone in 
the Time Zone field. The time zone selection list provides both geographic name 
abbreviations and Greenwich Mean Time (GMT) offsets.

EXAMPLE  
A job must only be submitted on a node belonging to the UNIX_Group load balancing group.

In the Node ID/Group field in the Execution tab, select group UNIX_Group.

NOTE  
To ensure that if CONTROL-M did not submit the job before New Day processing for the 
next day began, it submits the job as soon as possible afterward, specify > instead of a time 
value in the (time) to field.
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Defining that manual confirmation is required before job 
submission

Submission of a job might depend on a “non-automated” condition be satisfied. For 
example

■ a backup job might require that you load a storage medium into a drive
■ a job might require that you first activate an particular external application
■ a scheduled job should not be submitted until you have loaded a data file from an 

external source

To define that a job requires manual confirmation before submission

Check the Wait for confirmation check box in the Execution tab. (To actually confirm 
the job after it has been ordered, right-click the job node in CONTROL-M/EM, and 
select Confirm.)

EXAMPLE  
The job should be submitted after 6:00 PM.

In the Execution tab, specify 1800 in the Submit between field.

EXAMPLE  
The job should be submitted before 10:00 PM in Sydney, Australia.

In the Execution tab, specify 2200 in the (time) to field, and select SYD (GMT + 10:00) in the 
Time Zone field.

EXAMPLE  
The job should be submitted between 6:00 PM and 10:00 PM.

In the Execution tab, specify 1800 in the Submit between field, and specify 2200 in the (time) 
to field.

EXAMPLE  
The job should be submitted after 6:00 PM. If it is not submitted before New Day processing 
the next day, is should be submitted as soon as possible after that New Day processing.

In the Execution tab, specify 1800 in the Submit between field, and specify > in the (time) to 
field.
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Assigning priorities to jobs and defining and critical jobs

You can assign priorities to jobs by specifying 2-character alphabetic or numeric 
values as follows (where AA is the lowest priority and 99 is the highest priority):

AA-A9 ... ZA-Z9, 0A-0Z, 01-09, 1A-19 ... 9A-99

You can indicate that a job is a critical job by specifying an ∗  symbol in the Priority 
field and clicking the Critical field.

Priority and critical logic works as follows:

■ If available resources are sufficient to submit a lower priority job or higher priority 
job but not both, they will be used for the higher priority job.

■ If available resources are sufficient to submit a lower priority job but not a higher 
priority job, the lower priority job will be submitted.

■ If available resources are sufficient to submit a lower priority job but not a critical 
job, the resources will be held until all resources required by the critical job are 
available, and then the critical job will be submitted.

TIP  
In the job’s documentation file, or the Description field in the General tab, you might mention 
the condition that should be satisfied before someone confirms the job.

EXAMPLE  
The BkpDailyTrans backup job requires that an empty CD be mounted as the backup 
medium.

1. In the Execution tab, check Wait for confirmation.

2. (Optionally, write in the Description field in the General tab: Mount empty CD before 
confirming backup.)
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Defining how many days a job can await submission

It can happen that a scheduled job does not get submitted on the day it is scheduled, 
for example if its submission criteria have not been satisfied. Using the Maxwait 
parameter in the Execution tab, you can define the maximum number of days that 
such a job can remain in the Active Jobs file awaiting submission.

EXAMPLE  
The TransUpd01 and TransSumm01 jobs each require 35% of the CPU, but TransUpd01 is a 
much higher priority job.

1. In the Priority field in the Execution tab of TransUpd01, define a priority of 06.

2. In the Priority field in the Execution tab of TransSumm01, define a priority of X4.

If there are only enough resources for one of the jobs to run, TransUpd01 will run first.

EXAMPLE  
The TransUpd01 job requires 35% of the CPU, the TransSumm01 job requires only 15% of the 
CPU, but TransUpd01 is a much higher priority job than TransSumm01.

1. In the Priority field in the Execution tab of TransUpd01, define a priority of 06.

2. In the Priority field in the Execution tab of TransSumm01, define a priority of X4.

If only 20% of the CPU is available, TransSumm01 will be submitted before TransUpd01.

EXAMPLE  
The TransUpd01 job requires 35% of the CPU, the TransSumm01 job requires only 15% of the 
CPU, but TransUpd01 is a critical job.

1. In the Priority field in the Execution tab of TransUpd01, define a priority of *, and then click 
Critical.

2. In the Priority field in the Execution tab of TransSumm01, define a priority of X4.

If only 20% of the CPU is available, CONTROL-M reserves that CPU until another 15% of the 
CPU is free, and then submits TransUpd01.

NOTE  
Do not confuse the Maxwait parameter with the Retro parameter in the Scheduling tab. The 
Retro parameter determines whether jobs that were unscheduled for one reason or another 
will be retroactively scheduled. The Maxwait parameter determines how long scheduled but 
not submitted jobs will remain active awaiting submission.
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To define how long a not submitted job should remain active

In the Maxwait field in the AJF Retention area of the Execution panel, select the 
maximum number of days the job can remain active.

 

Defining dependencies for the current job

You define dependencies between jobs by means of In prerequisite conditions and 
Out prerequisite conditions that you define in the Conditions tab. 

■ By defining an In prerequisite condition, you establish the requirement that the 
condition must exist in the active environment before the job can be submitted. 

■ By defining an Out prerequisite condition, you establish that the condition is 
added to (or deleted from) the active environment when the job ends.

The most basic usage of prerequisite conditions to establish dependencies is as 
follows:

■ In a predecessor job, define an Out prerequisite condition to be added to the active 
environment when the job ends OK. 

■ In the successor job, define this same condition as an In prerequisite condition.

EXAMPLE  
If the ABC job is not submitted on the day it is scheduled, it should remain active until it is 
submitted, up to a maximum of 3 days, at which time, if it has not been submitted, it should be 
cleaned during New Day processing.

Set Maxwait to 3.

NOTE  
Alternatively, you can create job dependencies by simply clicking and dragging between job 
nodes in the flow diagram. This will automatically generate the In and Out prerequisite 
conditions. For details, see “Defining job dependencies by using the flow diagram” on 
page 109.

TIP  
If an In prerequisite condition in a successor job is no longer needed after the successor job 
runs, you can have the successor job delete that condition by define it as an Out prerequisite 
condition to be deleted. This is especially useful if the job might be run more than once (for 
example, cyclic or rerun jobs). It also helps eliminate clutter from the active environment even 
before New Day processing is run the following day.
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To define prerequisite conditions

1 To define In prerequisite conditions, do the following in the In condition area of 
the Conditions tab:

A Specify the name and date of each required condition. The most common date 
value is ODAT, which resolves to the job’s original scheduling date. Dates must 
be 4-characters. Table 8 lists the complete set of valid dates that can be specified 
for an In and Out condition.

B If you are defining multiple In prerequisite conditions, select the relationship 
between the conditions in the list box. If the relationship is complex (that is, a 
combination of And and Or), select Set relationship manually, which adds 
columns that let you specify a relationship parameter and parentheses on each 
line; fill in these columns as needed. You cannot nest parentheses.

You can use the buttons above the area to add, delete, copy or move conditions.

2 To define Out prerequisite conditions, do the following in the Out condition area 
of the Conditions tab: For each condition, specify the condition name and date (see 
Table 8), and in the Effect column, indicate whether the job should add (+) or delete 
(-) the condition when the job ends. 

You can use the buttons above the area to add, delete, copy or move conditions.

Table 8 Valid date values for In and Out conditions

Date Value Description

date 4-digit date in mmdd or ddmm format, depending on the site standard. 

offset + or - followed by a number from 0 through 999, indicating the number of 
days in the future (+), or in the past (-), relative to the actual order date.

This value is valid only for jobs running in CONTROL-M for z/OS version 
6.2.00 or later. 

ODAT Original scheduling date of the job.

PREV Previous scheduling date of the job.

NEXT Next scheduling date of the job.

STAT The condition is not date-dependent.

Note: This value is valid only for CONTROL-M/Server version 6.0.01 and 
above, and for CONTROL-M for z/OS.

**** or $$$$ Any scheduling date.
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Allocating resources for a job

To ensure that a job is not submitted for execution before required resources are 
available, you identify available resources to the system in CONTROL-M/EM (for 
details, see Chapter 15, “Identifying data center resources available for CONTROL-M 
use”), and then define the resources required by the job here in the Resources tab. 
Resources can be of one of two types:

■ Quantitative Resources — these are resource definitions for which you specify in 
CONTROL-M/EM an overall quantity available to the CONTROL-M, and the 
amount required by the job in the Resource tab. Examples of quantitative resources 
you might define are CPU (%), RAM (MB), Hard Disk (GB), and Tape Drives (# ).

■ Control Resources — these are resource definitions for which you specify the type 
of control the jobs needs (Exclusive or Shared). They are often used to represent 
files or databases.

Use the buttons above the areas to add lines, delete, copy or move resources.

EXAMPLE  
Job1 and Job2 are predecessors of Job3. Define the necessary conditions in the Conditions tab 
for Job1, Job2, and Job3, as follows:

■ In Job1, define that the job should add a Job1-EndedOK Out condition. 

■ In Job2, define that the job should add a Job2-EndedOK Out condition.

■ In Job3, define Job1-EndedOK and Job2-EndedOK In conditions (that is, that these 
conditions must exist before the job is submitted).

■ If the Job1-EndedOK and Job2-Ended OK conditions are no longer needed after Job3 
successfully ends, remove them from the active environment after Job3 ends by defining 
them as Out conditions to be deleted in Job3 (when defining the Out condition, select - in 
the Effect column).

■ If Job3 is a predecessor job to another job, define that it should add a Job3-EndedOK Out 
condition, which can then be specified as an In condition in a successor job of Job3.

TIP  
After defining job dependencies, you can use the loopdetecttool utility to detect loops in 
conditions. For details, see the CONTROL-M Utility Guide. 
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Defining and using variables that are dynamically resolved at 
runtime

By specifying AutoEdit variables in job scripts and job processing definitions, you can 
eliminate the need to change the scripts and job processing definitions before job 
submission. For example, if a job ID run date must appear in a file name, you can use 
an AutoEdit variable to represent the ID or date. AutoEdit variables are resolved at 
time of job submission, during job execution, or immediately following job execution 
(depending on the variable).

EXAMPLE  
Quantitative Resource Usage

A job will use 56% of the processing capacity of the CPU, and 12 Gb of the hard disk.

■ In CONTROL-M/EM, choose Tools =>Quantitative Resources and define the following 
quantitative resources and their total quantities in the CONTROL-M/Server (if not 
already defined):

— CPU (%) 
— Hard Disk (Gb) 

■ In the Resources tab in the job editing form for the job, define the following resources and 
their required usage values:

— A quantitative resource called CPU (%) with a required usage value of 56.
— A quantitative resource called Hard Disk with a required usage value of 12.

EXAMPLE  
Control Resource Usage

A job requires exclusive control of the Employees Weekly Timesheets file.

■ In CONTROL-M/EM, choose Tools =>Control Resources and allocate a control resource 
called Employees Weekly Timesheets.

■ In the Resources panel of the job editing form, specify that the job requires exclusive 
control over the Employees Weekly Timesheets file.

While the resource (the file) is currently in use by another job, this job will not be submitted. 
While this job is currently running, another job that needs the resource will not be submitted.
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AutoEdit terms are prefixed by the %% symbol. Predefined AutoEdit terms include 
system variables, functions and operators.

You can also define user-defined AutoEdit variables using the Set tab or (or Do Set 
Var statements in the Steps tab) in the job editing form. Definition of user-defined 
variables requires that you specify the following elements:

■ variable name — this is a user-assigned name that must have a valid AutoEdit 
prefix. The most common prefixes are

— %% for local variables
— %%/ for global variables

■ value — this is an expression or formula used for determining the value to be 
assigned during job processing. This expression or formula can be made up any 
combination of literals, constants, and AutoEdit system variables, functions 
operators, and user defined variables.

Besides using AutoEdit terms in the job script, you can use them in several places in 
the job editing form, including

■ Shout and Do Shout statements
■ Sysout and Do Sysout statements
■ Do Mail statements

For detailed instructions regarding the AutoEdit facility components and usage, see 
the CONTROL-M Parameter Guide, and for mainframe CONTROL-M users, see the 
CONTROL-M for z/OS User Guide.

NOTE  
When AutoEdit variables are used in post processing, as part of On or Do statements, they are 
re-evaluated.

NOTE  
Application-specific job parameters may not be specified in AutoEdit variables. The names of 
application-specific job parameters are prefixed by two percent signs, the application’s 
abbreviation and a hyphen (for example, %%SAPR3- for SAP, %%OAP- for Oracle E-Business 
Suite). 
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To define and assign values to user-defined AutoEdit variables for use in job 
scripts

1 Do one of the following:

■ To define and assign a value to an AutoEdit variable unconditionally, display the 
Set tab.

■ To define an assign a value to an AutoEdit variable if conditional criteria are 
satisfied

— display the Steps tab
— define the condition criteria in an On statement
— click Do and select Set-var as the Do statement

2 In the Var Name field (or the name= field of a Do Set-var statement), specify the 
name to be assigned to the variable. Ensure that you prefix the name with a valid 
AutoEdit prefix. 

3 In the Value field, specify the expression or formula to be used to assign the value 
to the variable. This formula can consist of any combination of literals, constants, 
AutoEdit system variables, user-defined variables, functions, operators and 
relationship indicators. For more information, see the CONTROL-M Parameter 
Guide, and for mainframe CONTROL-M users, see the CONTROL-M for z/OS User 
Guide.

 

 

EXAMPLE  
The job script must access a file called BranchTrans with the current date as a suffix (for 
example, BranchTrans_061025).

Specify in the job script the file name BranchTrans_%%Odate.

EXAMPLE  
A user-defined variable for the day before yesterday is needed in the job script.

In the Set tab, define the user-defined variable as follows:

1. In the Var name field, specify TwoDaysAgo.

2. In the Value field, specify %%Day %%Minus 2.

Note: %%Day is a system variable; %%Minus is an operator. 
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Defining postprocessing actions that depend on job 
processing results

To define postprocessing actions that are conditional upon the job processing results, 
you use the Steps tab to define On statements and accompanying Do statements:

■ On statements—identify the job processing results that will determine if the 
accompanying conditional (Do) actions are to be performed.

■ Do statements—identify the actions to perform when the On statement criteria are 
satisfied. 

EXAMPLE  
If the job ends Not OK, shout an appropriate message containing the completion code.

In the Step tab, define the following:

■ On Statement stmt=* code=NOTOK
■ Do Shout To=ECS Urgn =Very Urgent Msg=Job %%JOBID ended NOTOK. 

Completion code: %%COMPSTAT 

EXAMPLE  
To distinguish between SYSOUT iterations of a cyclic job, rename the SYSOUT file with a 
counter.

1. To track the number of iterations in a cyclic job, define the following user-defined variable 
in the Set tab:

■ Var name= %%counter 
■ Value = %%counter %%plus 1 

2. To rename the SYSOUT, in the PostProc tab, do the following:

A. In the Sysout Handling field, select Copy.

B. In the displayed File Name field, specify %%JOBNAME.SYSOUT.%%counter.

NOTE  
You fill in On statements differently for z/OS jobs than for other jobs. For details on filling in 
On statements for z/OS jobs, see “Defining conditional processing under z/OS” on page 94.
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To define conditional postprocessing actions

1 In the Steps panel of the job editing form, click the arrow below the On/Do 
heading and select On. Before performing the next step, note the following points:

■ To fill in On criteria, you supply two values:

— statement
— code

■ You can define On criteria that depend on values returned from any of the 
following:

— job SYSOUT
— job completion code
— job completion status

2 In the displayed On statement, fill in the stmt= and code= values:

■ To make the processing conditional on a particular completion code, fill in the 
fields as follows:

— In the stmt= field, specify *.
— In the code= field, specify a string in the COMPSTAT operator completioncode 

format:

Valid values for operator are: =, EQ, <. LT, >, GT, ! (not equal to), or NE. If you 
specify EQ, LT, GT, or NE, you must place a blank before and after the value.

Valid values for completioncode are either a literal completion code, or the 
value Even or Odd (which are satisfied by any even or odd completion codes).

■ To make the processing conditional on a particular completion status, fill in the 
fields as follows:

— In the stmt= field, specify *.
— In the code= field, specify one of the following completion statuses: OK, 

NOTOK, JLOST (perform the Do statements if the job’s SYSOUT cannot be 
found).

■ To make the processing conditional on a particular result from the SYSOUT, fill 
in the fields as follows:

— In the stmt= field, specify the job script statement (as formatted by the control 
module).

— In the code= field, specify the operating system response (as formatted by the 
control module).
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NOTE  
■ On statements that depend on the job SYSOUT are checked against statements 

passed from the SYSOUT by the relevant Control Module, and therefore must be in 
the same format as the statements passed by the Control Module. 

— For information on how control modules format the job script and operating 
system responses, see the appropriate Control Module administrator guide. 

— For formatting instructions for job types designated as OS (the default), and for a 
description of the logic used to determine if On criteria are satisfied, see the 
description of the On parameters in the CONTROL-M Parameter Guide. Also, see 
the following example.

■ You can use *, ?, and $ wildcards. (In Chinese, Japanese and Korean character sets: 
The ? and $ wildcards are not supported. The * wildcard is supported only as a 
standalone value or as a suffix to another value; it cannot be embedded in, or act as 
a prefix to, another value.) 

■ You cannot use AutoEdit variables.
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3 Press Enter.

4 To add more On statements repeat the process. The relationship between multiple 
On statements in the same On-Do block is And (they must all be satisfied).

5 After defining the On statement(s) in the On-Do block, define the Do actions as 
follows:

EXAMPLE  
Defining On statements relating to the SYSOUT

A job script requests (among other things) that the operating system run the following 
commands (which it does):

pwd                   (this is request to run a Dir command on the specified directory)
ls                        (this is a request to list the files in found in the Dir request)

The job’s SYSOUT contains the following results from these requests.

+pwd
/data/wrkfle
+ls
file1
file2
dir1
dir2

To define the On criteria, you must know the format of the SYSOUT data as formatted 
and returned by the Control Module. The data is formatted as follows:

       data returned by the Control Module    
■ statement= pwd code=/data/wrkfle
■ statement=ls code= file1
■ statement=ls code=file2 
■ statement=ls code=dir1 
■ statement=ls code=dir2

Assume that the On statement is satisfied if the ls request returns a value beginning with 
the prefix dir. Define the following On (and Do) statements in the Steps tab:

On statement stmt= ls   code=dir*  
Do ...
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A Click the arrow below the On/Do heading and select Do.

B Select the Do action, and then fill in the values for the displayed fields. Table 9 
lists possible Do actions and where useful, the parameters that can activate 
those actions. For a brief explanation of Do actions, and where useful, the 
parameters that can activate those actions, see Table 9. For a complete 
explanation of the Do statement parameters, see the CONTROL-M Parameter 
Guide.

C Repeat this process to define as many Do actions as needed. The relationship 
between them is AND (if the ON criteria are satisfied, all the Do actions in that 
block are performed).

You can define as many On-Do blocks as needed. Use the buttons above the areas 
to add lines, delete, copy or move On or Do statements.

Table 9 DO actions  (part 1 of 2)

Desired Action Parameter

To set the job’s completion status to OK regardless of the job’s completion 
status. (This statement has no subparameters.)

Do OK

To set the job’s completion status to NOTOK regardless of the job’s 
completion status. (No subparameters.)

Do NOTOK

To cause the job to be rerun according to the parameters specified in the 
Rerun parameter. No subparameters.

Do Rerun

To stop the cyclic job from running. Do Stop Cyclic

To assign a value to an AutoEdit variable. You must specify the name of 
the variable, and the value to which the variable should be set. Note: This 
parameter is also called Do AutoEdit or similar in various CONTROL-M 
products (and the CONTROL-M Parameter Guide). 

Valid values can either be a constant value or a resolvable AutoEdit 
expression. Note: Do not specify any application-specific job parameters 
(which are also prefixed by two percent signs, as well as the application’s 
abbreviation and a hyphen; for example, %%SAPR3- for SAP, %%OAP- 
for Oracle E-Business Suite). For more information about AutoEdit 
expressions, see the CONTROL-M Parameter Guide.

Do Set-Var

To send (“shout”) a message to a destination. You must specify a 
destination, degree of urgency, and the message text as subparameters.

Do Shout

To force a job or a complete scheduling table to be ordered under 
CONTROL-M regardless of the scheduling criteria.

You must specify as subparameters the name of the scheduling table (to be 
forced or containing the job to be forced), the scheduling date to use, (and 
for z/OS, the library containing the scheduling table).

Do Force-job
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To specify how the job’s output should be handled.

The following subparameter fields are displayed for this DO statement:

Do Sysout

option SYSOUT option code (list box). The following 
options are available: 

■ C Change job class.
■ F Copy output.
■ D Delete output.
■ N Move output.
■ R Release for Printer.

PRM Relevant SYSOUT data. The appropriate value 
depends on the option code above. For use with 
codes F, C or N. (Text)

■ For option F, specify the file name.

■ For option C, specify the New class (one 
character) or * to indicate the jobs original 
MSGCLASS.

■ For option N, specify the new destination (up 
to 8 characters).

FROM From class. Limits the SYSOUT handling 
operation to SYSOUTs originating in the specified 
class.

To add or delete a prerequisite condition. You must specify as 
subparameters the condition name and date, and whether to add or delete 
the condition.

Do Condition

To e-mail a message. Under the Parameters heading you must specify as 
subparameters the To=, Subject=, and Msg= fields. These details can also 
be entered in the Mail dialog box (displayed by clicking the arrow in the 
Details field) along with the following additional fields: Cc:, Urgency:, and 
Attach SYSOUT:.

Valid values for Attach SYSOUT: are:
■ Yes
■ No
■ Default (This subparameter takes its value from the 

ADD_SYSOUT_TO_EMAIL configuration parameter)

Do Mail

To open or close a Remedy ticket. You must specify as subparameters a 
problem summary, description, and the problem urgency. AutoEdit terms 
are supported.

Do Remedy

Table 9 DO actions  (part 2 of 2)

Desired Action Parameter
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EXAMPLE  
If the word “error” appears anywhere in the SYSOUT, shout to the Administrator.

On Statement stmt= * code= *error* 
Do Shout To= Admin Urgency: Very Urgent Msg= Potential error in Job %%jobid

EXAMPLE  
Any even completion code should cause the job to end OK.

On Statement stmt= * code= COMPSTAT EQ Even
Do OK

EXAMPLE  
If the job ends NOTOK, add a condition that triggers a job that now becomes necessary.

On Statement stmt= * code= NOTOK
Do Condition Name=JobX_NotOK Date= odat sign= + 

EXAMPLE  
Set the status of the job to NOTOK if the SYSOUT indicates that the password directory is not 
found. In such a case, the SYSOUT of the UNIX job might contain the following:

cp  /etc/passwd /tmp
cp  /etc/passwdx /tmp
cp: /etc/passwdx: No such file or directory
cp  /etc/passwd /usr/kvm/xyzzy
cp: /usr/kvm/xyzzy: Permission denied
exit 12

On Statement stmt= cp/etc/passwdx/tmp code= cp*no*file 
Do NOTOK 

EXAMPLE  
Rerun the job if the SYSOUT indicates that a particular file to be copied was not found:

On Statement stmt= copy job411.dat code= File not found 
Do Rerun 
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Defining conditional processing under z/OS

When defining On statements for jobs running under z/OS, you specify the 
particular start and end procedure and program step to be checked for a particular 
code result. Optionally, you can define and name step ranges, and then reference the 
step ranges by specifying their names (preceded by an asterisk) in On statements.

1 To define a step range, in the Step Range area of the Steps panel, do the following:

A Specify a name for the step range.

B Fill in the start program and procedure step and the end program and 
procedure step.

C Repeat for as many step ranges as you want to define.

2 To define On statements (other than On Sysout), do the following:

A Click under the On/Do header, and select On. 

B Click under the Type header and select Statement.

C Specify the program step. Alternatively you can specify

■ *step_range_name 
■ ANYSTEP (code criteria can be satisfied in any step)
■ +EVERY (code criteria must be satisfied in every step)

D Specify the procedure step. Alternatively you can specify

■ (blank) 
■ +EVERY (code criteria must be satisfied in every step)

E Specify the codes that will satisfy the On step criteria. You can precede them 
with relational operators <, >, or N (not). Most codes will be in one of the 
following formats:

■ Cnnnn - step condition code, where nnnn is a 4-digit value.
■ Sxxx—Step system abend code where xxx is a 3-character hex value.
■ Unnnn—Step user abend code, where nnnn is a 4-digit value.
■ Keyword value such as JLOST, JNRUN, and JFAIL, OK, and NOTOK. 

For for information, and rules regarding usage, see the description of the On 
statement in the CONTROL-M Parameter Guide.
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3 To define an On Sysout statement, do the following:

A Click under the On/Do header, and select On. 

B Click under the Type header and select Sysout.

C In the Sysout= field, specify a string or pattern to check for in the SYSOUT 
(blanks are invalid characters).

D Specify the From column and To columns of the SYSOUT to be checked for the 
string or pattern.

4 To define additional On Statements in the block, specify an And or Or relationship 
between the current statement and the new statement to be defined. A new On 
statement for you to fill in will be automatically opened.

5 When the On block is as it should be, fill in the Do actions as follows:

A Click under the On/Do heading, and select Do.

B Click under the Type header, and select the Do statement.

C Fill in the displayed fields. For a complete explanation of the Do statement 
parameters, see the CONTROL-M Parameter Guide.

D Repeat as necessary.

 

NOTE  
The N qualifier indicates that the DO statements must not be performed if the specified 
condition exists. It does not indicate that the DO statements must be performed if the 
specified condition does not exist.

EXAMPLE  
If Step1 ends with a condition code of C0004, and Step 5 ends with system abend code S0C4, 
perform the indicated Shout.

On Statement PGMST= Step1 PROCST=          Codes=C0004         AND
On Statement PGMST= Step5 PROCST=          Codes=S0C4
Do Shout         To=emuser       Urgn=Regular         Msg= Backup operations ...



Defining messages to be shouted at the end of job processing

96 CONTROL-M User Guide

Defining messages to be shouted at the end of job processing

1 In the PostProc tab, click When and select the situation in which CONTROL-M 
should shout the message, and if necessary, specify the accompanying parameters 
in the Param field. Use the following table as a guide.

NOTE  
Shout statements in CONTROL-M for z/OS allows additional values beyond those described 
below. For details, see the CONTROL-M for z/OS User Guide or the CONTROL-M 
Parameter Guide.

Situation When option Parameters

The job completion status is ended OK OK (none)

The job completion status is NOTOK NOTOK (none)

The job completion status is RERUN. RERUN (none)

The job has not been or cannot be 
submitted by the specified time

Late Sub time in hhmm format (from 0000 through 2359).

The job does not finish executing by the 
specified time

Late time time in hhmm format (from 0000 through 2359).

The job’s elapsed runtime is outside of 
a specified limit

Exectime According to the format specified, Shout the 
message if the elapsed runtime is

■ >n—is greater than n minutes (1-999).

■ <n— is less than n minutes (1-999).

■ +n—exceeds the job’s average execution time by 
at least n minutes (1-999).

■ -n—is less than the job’s average execution time 
by at least n minutes (1 – 999).

■ +n%—exceeds the job’s average execution time 
by at least n% (1 – 900)

■ -n%—is at least n% less than its average 
execution time. (1 – 999).

You can specify more than one parameter in a Shout 
When Exectime statement.
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2 In the To field, specify the Shout destination in the CONTROL-M. Valid values are

■ user ID
■ user e-mail
■ a specific terminal
■ system console
■ alerts window (specify ECS as the To destination)
■ CONTROL-M log

3  Select the message urgency (regular, urgent or very urgent).

4 Specify the message (1 -255 characters).

5 Repeat these steps as necessary to shout as many messages needed in different 
situations. You can use the buttons above the Shout area to add, delete, copy or 
move shout statements up and down.

 

NOTE  
Shout When Late Sub applies only if the job is not submittable (that is, if a runtime criterion 
such as an in condition or quantitative resource is not satisfied) at the specified time. 
However, if a job is ordered after the specified time but starts running immediately because it 
meets all runtime criteria, the Late Sub parameter doesn't apply.

EXAMPLE  
If the BackupAllSystems job ends not OK, shout an alert indicating the job’s completion code.

In the PostProc tab, do the following:

1. In the When field, select NOTOK.

2. In the To field, specify ECS.

3. In the Urgency field, select Urgent.

4. In the Message field, specify Backup failed. Completion code=%%COMPSTAT.
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Defining how to handle the job’s sysout when the job ends OK

1 In the PostProc tab, in the Sysout Handling field, select required handling.

2 For the following SYSOUT handling, specify the require parameters in the 
displayed field, as follows:

■ For sysout being copied, specify the full path and name for the target file.
■ For sysout being moved, specify the full path for the target destination.
■ For sysout being printed (released), specify the target printer.

EXAMPLE  
Other jobs depend on the CalcExpenses job being executed in a timely fashion. If the 
CalcExpenses job does not finish executing by 8:00 PM, shout an appropriate very urgent 
message to the Administrator.

In the PostProc tab, do the following:

1. In the When field, select Late Time.

2. In the Param field, specify 2000.

3. In the To field, specify Admin.

4. In the Urgency field, select Very Urgent.

5. In the Message field, specify Job CalcExpenses not completed by 8:00 PM. 

EXAMPLE  
If the CalcSalary job executes in less that half its average execution time, there might be a 
problem with the data being used. Shout a message to the Payrol234 user Id.

In the PostProc tab, do the following:

1. In the When field, select Exectime.

2. In the Param field, specify -50%.

3. In the To field, specify Payrol234.

4. In the Urgency field, select Urgent.

5. In the Message field, specify Job CalcSalary completed quickly. Check data and results. 
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Archiving sysdata (z/OS only)

You can archive the job’s SYSDATA to a common data set. If you do, you can 
(optionally) specify how many days, and for how many job runs, to retain the 
archived SYSDATA.

To archive the job’s sysdata to a common data set

1 In the Archiving area of the PostProc tab, click in the SYS DB.

2 Optionally, specify one or both of the following types of retention criteria:

■ number of days (00–99) to retain archived SYSDATA
■ number of job runs (000–999) for which to retain the SYSDATA.

 

Creating and editing scheduling groups
This section describes the following topic:

Defining general scheduling group information
Defining scheduling criteria for a scheduling group
Defining dependencies, variables, and notifications in the scheduling group
Defining actions to be performed after all scheduled jobs in the table have ended

EXAMPLE  
If the job ends OK, print the SYSOUT on the EWH14 printer.

In the PostProc tab, do the following:

1. In the Sysout Handling field, select Release.

2. In the displayed Printer Name field, specify EWH14.

EXAMPLE  
Archive the SYSDATA and retain it for 30 days.

In the PostProc tab, do the following:

1. Click SYS DB.

2. Specify 30 in the Max Days to retain archived SYSdata field.
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When creating a group scheduling table, in addition to defining the basic set of table 
definition parameters (CONTROL-M and table name), you must define the extended 
set of table definition parameters that determine how the table will handle its jobs as a 
unified group. This extended table definition parameter set is referred to as a 
scheduling group. Each group scheduling table must have one, and only one, 
scheduling group.

In many ways, you interface with scheduling group as you do job processing 
definitions. For example

■ when you display the list of jobs in a table (using the Job List window, described in 
Chapter 5, “Organizing and managing jobs in scheduling tables”), the scheduling 
group is listed along with the jobs

■ you can edit or browse the scheduling group definition much as you would a job 
processing definition

■ many actions you can perform on job processing definitions can also be performed 
on scheduling groups

You define scheduling group parameters in a form called the group editing form. 
This form is very similar to the job editing form used for defining job processing 
definitions, and the definition tasks are also very similar.

Fill in the criteria as you would for a job, but keep in mind that the group scheduling 
table will apply its scheduling group criteria to all the scheduled jobs as a whole.

Defining general scheduling group information

When filling in the General tab in scheduling groups, the following require special 
consideration:

■ Specifying a scheduling group name, task type, and table name
■ Ignoring prerequisite conditions if predecessor jobs that set them are unscheduled 

NOTE  
■ Because most details of the group editing form are similar to the details of the job editing 

form, instructions for those details are not repeated here. Instead, see “Creating and 
editing jobs” on page 57.

■ The group editing form contains a Schedule Tags tab, instead of the Scheduling tab found 
in the job editing form. This tab provides additional scheduling functionality.

■ This section describes details that are unique or different for the scheduling group.
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Specifying a scheduling group name (job name) and task type, and table name

■ The name you assign to the scheduling group (in the Job Name field) appears in 
the scheduling group node in the flow diagram and in the Job List window. We 
recommend that you indicate that the “job” is a scheduling group by, for example, 
using a prefix or suffix of GRP in the name.

■ The tasktype is always Scheduling Group.

■ Specify the name of the group scheduling table in the Table field.

Ignoring prerequisite conditions if predecessor jobs that set them are unscheduled 

If predecessor jobs in a scheduling group are not scheduled on a day that successor 
jobs are scheduled, the conditions required by the successor jobs cannot be satisfied, 
and by default the successor jobs are not submitted. However, you can override this 
default. To instruct CONTROL-M to ignore prerequisite condition requirements if the 
predecessor jobs that set them are not scheduled, in the Adjust Conditions field in 
the Execution tab of the scheduling group, select Yes. (The default is No — required 
conditions are not ignored.)

Defining scheduling criteria for a scheduling group

The Schedule Tags tab of the scheduling group is very similar to the Scheduling tab of 
job processing definitions, only it enables you to define multiple sets of scheduling 
criteria that can applied to selected jobs in the table. 

The Schedule Tags tab of a scheduling group must contain at least one set of 
scheduling criteria that can be applied to the job processing definitions in the group 
scheduling table (you can define multiple sets of scheduling criteria). To each set of 
scheduling criteria that you define in a scheduling group, you assign a unique name 
called a scheduling tag (in the Tag Name field).

You can then apply any of these sets of scheduling criteria to a job in the group 
scheduling table by selecting the tag name in the job processing definition’s 
Scheduling tab. 

NOTE  
When the same or similar scheduling tags are used in different scheduling groups, you can 
copy them from one scheduling group to another rather than defining them manually. For 
details, see “Copying scheduling tags from one scheduling group to another” on page 109.
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Figure 6 Scheduling tab in the group editing form

To define sets of scheduling criteria that can be applied to job processing 
definitions in the group scheduling table

1 In the Tag Name field in the Schedule Tags tab, specify a name that can later be 
used to identify the set of scheduling criteria.

2 Fill in the scheduling criteria as you would for any job.

3 To define additional scheduling tags, go to the next Tag Name line and repeat the 
process.

NOTE  
■ For z/OS groups, only uppercase letters are allowed in tag names. 
■ Tag names for groups on non-z/OS platforms are case sensitive.

TIP  
For CONTROL-M/Forecast users only:
Using the Forecast Tag and Forecast Group buttons, you can graphically display when and 
how often jobs in the scheduling group will be scheduled for submission based on the defined 
scheduling tag criteria.
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Defining dependencies, variables, and notifications in the 
scheduling group

Fill in the scheduling group parameters as you would for a job, but keep in mind that 
the group scheduling table will apply these criteria to all scheduled jobs as a whole.

When defining Shout notifications, be aware that

■ in the group editing form, you define Shout notifications in the Shouts tab; but in 
the job editing form, you define Shout notifications in the PostProc tab

■ the format of the Shout statements, and the procedure for defining the Shouts, are 
the same in both locations

EXAMPLE  
In the scheduling group, create scheduling tags that will enable some jobs to be scheduled on 
workdays, others on the first day of each month, and others on the first day of the new 
quarter. 

In the Schedule Tags tab of the scheduling group, do the following:

1. In the Tag Name field, enter Daily.

2. In the Month Days area, select All; click And as the connector; and in the Week Days area, 
click Mon, Tue, Wed, Thu, and Fri.

3. In the Tag Name field, enter Monthly.

4. In the Month Days area, click 1; in the Months area click All.

5. In the Tag Name field, enter Quarterly.

6. In the Month Days area, click 1; in the Months area click Jan, Apr, Jul, and Oct.
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Defining actions to be performed after all scheduled jobs in 
the table have ended

CONTROL-M performs post-processing defined in a scheduling group only after all 
jobs that were ordered as a group have ended or timed out. At this time, 
CONTROL-M assigns the group of jobs a completion status, and the post-processing 
actions specified for that group completion status are performed.

■ If one or more jobs ended with errors (NOTOK), CONTROL-M assigns the group a 
status of Not OK.

■ If all jobs in the group ended successfully, CONTROL-M assigns the group a status 
of OK.

If a group is reactivated because jobs in the group were rerun or new jobs were 
ordered into that group after the group finished, CONTROL-M reevaluates the 
completion status of the group when the new jobs are completed, and performs 
post-processing for the group according to the new completion status.

EXAMPLE  
A number of jobs belong to a group scheduling table whose scheduling group is called 
CalcsGrp. No jobs in this table should be executed until the BranchSumm job (in a different 
table) has ended OK. Furthermore, the jobs should not be submitted unless they have Shared 
control of the BranchSummTots file and exclusive control over the TransUpd file.

Note: This is a z/OS example; the Resources tab is only available for scheduling groups in 
z/OS.

1. In the Conditions tab of the BranchSumm job processing definition, define the following 
Out prerequisite condition (to be added): BranchSumm-EndedOK ODAT +.

2.  In the Conditions tab of CalcGrp, add BranchSumm-EndedOK ODAT as an In 
prerequisite condition.

3. In the Resources tab of CalcGrp, define Shared control over the control resource 
BranchSummTots.dat and exclusive control over the control resource TransUpd.dat.

NOTE  
If there are no jobs submitted in a group (for example, due to basic scheduling criteria), the 
completion status of the group is OK. Post-processing actions for a group completion status 
OK are performed.
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You fill in the post-processing criteria as you would Steps criteria for a job, only 
instead of filling in a regular On statement, you fill in an On Group-end statement, 
which applies the criteria to the results of the scheduling group processing as a whole 
(for details, see “Defining postprocessing actions that depend on job processing 
results” on page 87). 

1 In the On Group-end block, select whether the post-processing actions you will 
specify should be performed if the processing of the scheduling group ends OK or 
NOTOK:

■ OK — all jobs in the table ended ok.
■ NOTOK — at least one job in the table ended not OK.

2 In the On Group-end block, select the post-processing (Do) actions that 
CONTROL-M should perform.

3 Repeat the process for another On-Group-end block if necessary (that is, one block 
if the table ends OK and one block if the table ends NOTOK).

EXAMPLE  
The salary check-printing job is located in a regular table. It should not be run unless all 
scheduled jobs in the table containing the scheduling group Payroll ended OK.

In the PostProc tab of scheduling group Payroll, do the following

1. Click On/Do and select On; then select type OK.

2. Click On/Do and select Do; then select Condition.

3. Define the condition as follows: Name=PayrollGroup-EndedOK Date=ODAT Sign=+.

(Alternatively, you can specify the condition as an Out condition in the Conditions tab).
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Creating and editing jobs in a group 
scheduling table

After you have defined the scheduling group for a group scheduling table, you can 
define the table’s job processing definitions, using the job editing form.

Defining scheduling criteria for a job in a group scheduling 
table

When defining scheduling criteria in a job processing definition, you can apply any 
sets of scheduling criteria that you defined in the Schedule Tags tab of the scheduling 
group by specifying the scheduling tag names in the job processing definition. You 
can define individual scheduling criteria in the job processing definition, just as you 
would for any job.

When you specify scheduling tags and define individual scheduling criteria in a job 
processing definition, you must specify the relationship (And or Or) between those 
criteria. You do this specification in the Tags Relationship field.

To define scheduling criteria for a job processing definition in a group 
scheduling table

1 In the Scheduling tab, define any individual scheduling criteria (not related to 
scheduling tags) for the job as you would for any job.

2 Select scheduling tags whose criteria should be applied, as follows:

NOTE  
■ In addition to the criteria you define for the scheduling group as a whole, you define 

individual criteria for the particular job processing definition.

■ Most parameters in job processing definitions in a group scheduling table are the same as 
those in job processing definitions in regular scheduling tables. For instructions, refer to 
“Assigning a name to the job” on page 58.

■ This section describes details that are unique or different for the job processing definitions 
in group scheduling tables. 
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A Click Select Tags at the bottom of the Scheduling tab, and in the displayed dialog 
box, select the scheduling tags, and when you have finished, click OK. (To apply 
all scheduling tags, specify an asterisk *.)

B In the Tags Relationship field, click the relationship (And or Or) that you want to 
establish between the scheduling tags you selected and the individual 
scheduling criteria you defined.

Determining whether jobs in a group scheduling table will 
be scheduled

Before jobs in a group scheduling table can be scheduled, at least one scheduling tag 
in the scheduling group must be satisfied (or the job cannot be scheduled). If at least 
one schedule tag in the scheduling group is satisfied, job scheduling depends on the 
following logic (where the Tags Relationship value defines the relationship between 
the jobs basic scheduling criteria and the job’s scheduling tags):

■ If the job’s basic scheduling criteria are satisfied, and its Tags Relationship value is 
OR, the job is scheduled.

■ If the job’s basic scheduling criteria are satisfied, its Tags Relationship value is AND, 
and any of its scheduling tag criteria are satisfied, the job is scheduled.

■ If the job’s basic scheduling criteria are satisfied, its Tags Relationship value is AND, 
and none of its scheduling tag criteria are satisfied, the job is not scheduled.

■ If the job’s basic scheduling criteria are not satisfied, its Tags Relationship value is 
OR, and any of its scheduling tag criteria are satisfied, the job is scheduled.

■ If the job’s basic scheduling criteria are not satisfied, its Tags Relationship value is 
OR, and none of its scheduling tag criteria are satisfied, the job is not scheduled.

■ If the job’s basic scheduling criteria are not satisfied, and its Tags Relationship value 
is AND, the job is not scheduled.

Table 10 on page 108 summarizes the group scheduling table logic. (An * in a column 
indicates that the item has no impact on the scheduling decision for that row.)
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Table 10 Determining which jobs in a group scheduling table get scheduled 

Scheduling tag in the 
group scheduling table

Job’s basic 
scheduling criteria

Tags 
Relationship Scheduling tag in the job Scheduling result

none satisfied * * * job not scheduled

at least one satisfied satisfied OR * job scheduled

AND at least one satisfied job scheduled

AND none satisfied job not scheduled

not satisfied OR at least one satisfied job scheduled

OR none satisfied job not scheduled

AND * job not scheduled

EXAMPLE  
Schedule a job in a group scheduling table only if the criteria in the Monthly schedule tag are 
satisfied, and the day of the week is a Monday, Tuesday Wednesday Thursday or Friday.

In the Scheduling tab

1. In the Week Days area, click Mon, Tue, Wed, Thu, and Fri.

2. In the Tags Relationship area, click and.

3. Click Select Tags and in the displayed dialog box, select Monthly, click the right arrow, 
and click OK.

EXAMPLE  
Schedule a job in a group scheduling table when either the criteria in the Quarterly schedule 
tag are satisfied, or on any Saturday that is the 15th day of the month.

In the Scheduling tab

1. In the Month Days area, click 15.

2. In the Months area, click All.

3. Between the Month Days area and the Week Days area, click And.

4. In the Week Days area, click Sat.

5. In the Tags Relationship area, click or.

6. Click Select Tags and in the displayed dialog box, select Quarterly, click the right arrow, 
and click OK.
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Copying scheduling tags from one scheduling 
group to another

1 From the CONTROL-M/Desktop window, choose Edit => Copy Tags, which 
opens the Copy Tags dialog box.

2 In the Copy Tags dialog box, do the following:

A In the From area of the dialog box, choose the source data center and source 
group scheduling table from which to copy the scheduling tags, which displays 
the list of available scheduling tags in the scheduling group.

B In the To area of the dialog box, choose the target data center and target group 
scheduling table to which to copy the scheduling tags.

C In the From area, select the scheduling tags to be copied and click the right 
arrow, to add the selected tags to the list of tags in the To area.

3 Click OK, to save the current list of tags in the To area.

Defining job dependencies by using the flow 
diagram

You can create or redefine job dependencies simply by clicking and dragging 
between jobs in the flow diagram. (This capability is especially useful after you have 
used the Mass Create feature to create multiple jobs.) CONTROL-M/Desktop uses a 
default condition format to automatically define the In and Out conditions needed to 
create the dependency. 

You can modify the default condition format. For details, see “Defining a condition 
format” on page 110.

NOTE  
The Copy Tags option is enabled only when at least two scheduling groups, each 
containing at least one scheduling tag, are opened in CONTROL-M/Desktop.

NOTE  
■ To use this feature, you must be working in your local workspace. 
■ This feature cannot be used to create Do conditions.
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To create a job dependency

1 If you are not yet in Definition mode in CONTROL-M/Desktop, click  to enter 
Definition mode. 

2 In the flow diagram, click the predecessor job node and drag the mouse to the 
successor job node. 

CONTROL-M/Desktop automatically adds the required Out prerequisite condition 
to the predecessor job scheduling definition, and In prerequisite conditions to the 
successor job scheduling definition, and uses In and Out connectors, and dependency 
lines, to indicate the dependencies in the flow diagram.

To delete a dependency between jobs

1 Right-click the dependency line of the condition that you want to delete, and in the 
displayed pop-up menu click Delete Dependency. 

2 In the Delete Dependency dialog box, select the name of the condition to be deleted 
and the names of the jobs from which to delete the condition.

3 Click OK.

Defining a condition format

You can change the default dependency format used for creating job dependencies 
when you drag between job nodes in the CONTROL-M/Desktop flow diagram.

Condition format definitions use functions. An example of a condition format is 
{MemName}-TO-{ToJob{MemName}}, which is the default condition format.

TIP  
You can customize CONTROL-M/Desktop such that when you create dependencies using 
this procedure, CONTROL-M/Desktop will automatically create the Out condition needed by 
the successor job to delete the condition from the Conditions file after the job has successfully 
run. For details, see the Flowdiagram-Links panel for CONTROL-M/Desktop in Appendix A, 
“Customizing the interfaces.”.

NOTE  
In the Flowdiagram - Links panel of the Options dialog box, you can customize whether the 
Delete Dependency dialog box will delete only In Conditions, delete both In and Out 
Conditions, or prompt for the type of condition to delete. For details, Appendix A, 
“Customizing the interfaces.”
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To define a Condition Format

1 In the CONTROL-M/Desktop window, choose Tools => Options and select the 
Flowdiagram => Links page.

2 In the Condition Format field, select the format for the condition. (For an 
explanation of the functions comprising available condition formats, see Table 46 
on page 329.)

3 Click OK.

 

EXAMPLE  
Format of the automatically generated conditions should be jobname-ENDED-OK.

1. In CONTROL-M/Desktop, select Tools => Options.

2. In the Options dialog box tree diagram, click Flowdiagram => Links.

3. Select {Job Name}-ENDED-OK.

4. Click OK.
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C h a p t e r 5
5  Organizing and managing jobs in 
scheduling tables

This chapter presents the following topics: 

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  113
Managing scheduling tables. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  114
Managing jobs and scheduling groups. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  118

Introduction
You can manage scheduling tables and jobs from the

■ CONTROL-M/Desktop window (that is, the flow diagram or list display, and the 
navigation tree)

■ Scheduling Table manager (and its Job List window) available in 
CONTROL-M/Desktop

You can choose either method at any time. Factors that might affect your choice are

■ where you are currently working

■ whether you want to work in your workspace (use the CONTROL-M/Desktop 
window) or directly in the CONTROL-M/EM database (choose the Scheduling 
Table Manager)

■ the task you want to perform
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Managing scheduling tables
To display the scheduling table manager, select Tools => Scheduling Table Manager or 
click  in CONTROL-M/Desktop.

Figure 7 Scheduling Table Manager

Table 11 lists table management tasks you can perform with the Scheduling Table 
Manager.

NOTE  
The following tasks are described elsewhere in this book:

■ To move jobs and tables to production or to manually schedule jobs, see Chapter 13, 
“Putting jobs into production.”

■ If CONTROL-M/Forecast is installed, to generate a schedule forecast for scheduling 
tables (that is, graphically the scheduling criteria of the jobs in the table), see the 
CONTROL-M Business Service Management Solution User Guide.
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To create a scheduling table 

1 In the Scheduling Table Manager window, click  (New), which opens 
the Scheduling Table dialog box.

2 Fill in the details for the new scheduling table, as follows:

A Choose the CONTROL-M and specify a name for the scheduling table.

B If you are creating a z/OS scheduling table, specify the library name.

Table 11 Table management tasks 

Task to perform How to perform it

to refresh the Scheduling Table 
Manager display

Click .

to unlock a locked table Select the table and click . (You must be authorized.) 
Note: When you select an unlocked table, clicking the 
(modified) icon locks the table.

to display the list of jobs in a 
table

Double-click the table name. For additional details, see 
“To display the list of jobs in a table” on page 119.

to create a table See “To create a scheduling table” on page 115.

to establish a new table as a 
group scheduling table

See “To establish a new scheduling table as a group 
scheduling table” on page 116.

to change the basic details of a 
table

Select the scheduling table and click  (Table Details). 
For additional information, see “To change the basic 
details of a scheduling table” on page 117.

to copy a table Select the scheduling table and click  (Copy). For 
additional details, see “To copy a scheduling table” on 
page 117.

to delete tables Select the table(s), click the selection arrow by the Delete 
button, and choose the appropriate Delete option. For 
additional details, see “To delete scheduling tables” on 
page 118.

TIP  
You do not need to explicitly create scheduling tables. When you specify a table name in the 
job or group editing form, if the table does not already exist, CONTROL-M/Desktop 
automatically creates it. 

NOTE  
Each scheduling table is associated with the platform of its CONTROL-M. For example, 
if you choose a z/OS CONTROL-M, the scheduling table will be a z/OS scheduling 
table.
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C Fill in the User daily field as follows, but only if one of the following applies:

■ If the scheduling table should be ordered by a specific User Daily job, specify 
the name of the job (1-10 characters, case sensitive).

■ If the scheduling table should be ordered by the New Day procedure, specify 
SYSTEM (uppercase only) as the value.

The New Day procedure and User Daily Jobs are described briefly in 
Chapter 14, “Automating job scheduling and maintenance,” and in detail in the 
CONTROL-M Administrator Guide. 

3 Click OK, which saves the scheduling table in the CONTROL-M/EM database 
(and displays the name in the Scheduling Table Manager window). 

To use the scheduling table, you must perform an upload. For instructions, see 
“Uploading tables to the CONTROL-M database” on page 166.

To establish a new scheduling table as a group scheduling table

1 After you have created a new scheduling table, before you add job processing 
definitions, double-click on the scheduling table name in the Scheduling Table 
Manager window.

2 In the Job List dialog box, click New.

3 In the Create New Job/Scheduling Group dialog box, click Scheduling Group, 
which displays the group editing form to enable you to define the extended set of 
table parameters in the scheduling group.

NOTE  
If you are defining a z/OS scheduling table, any value you specify in the User daily field 
is for documentation purposes only. To actually assign the scheduling table to the New 
Day procedure or to a specific User Daily job, follow the instructions in the 
CONTROL-M for z/OS User Guide.

NOTE  
After you have created an empty scheduling table by using the Scheduling Table Manager, to 
establish it as a group scheduling table, you must define its scheduling group while it is still 
empty (that is, before adding job processing definitions). For details, see “To establish a new 
scheduling table as a group scheduling table” on page 116.
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4 Fill in the group editing form as follows:

A Select the Group template.

B Fill in required details of the definition. (For tips on filling in the scheduling 
group details, see “Creating and editing scheduling groups” on page 99.)

C Click Save & Close.

The table is now a group scheduling table, and you can define job processing 
definitions in it. The name of the scheduling group appears in the Job List window. 

To change the basic details of a scheduling table

1 In the Scheduling Table Manager, select the scheduling table and click  (Table 
Details). 

2 In the Scheduling Table dialog box, make the changes and click OK (you must be 
authorized), which saves the changes in the CONTROL-M/EM database. 

To apply the changes to the table definition in the CONTROL-M database, you must 
perform an upload. For instructions, see “Uploading tables to the CONTROL-M 
database” on page 166.

To copy a scheduling table

1 In the Scheduling Table Manager, select the scheduling table to be copied, and 
click  (Copy). 

2 In the Copy Scheduling Table dialog box, specify a name for the new table in the 
Name field, modify the other criteria as needed, and click OK, which saves the 
scheduling table in the CONTROL-M/EM database. 

WARNING  
■ If you modify a table associated with more than one User Daily and then upload it to 

CONTROL-M, that table is removed from all User Dailies except the one it is associated 
with in CONTROL-M/EM.

■ To modify the extended set of table parameters for a group scheduling table, you must 
edit the scheduling group definition in the group editing form. For instructions, see 
“Creating and editing scheduling groups” on page 99.

NOTE  
If you specify a different target CONTROL-M, it must have the same platform and version 
as the original scheduling table’s CONTROL-M.
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To use the scheduling table, you must perform an upload. For instructions, see 
“Uploading tables to the CONTROL-M database” on page 166.

To delete scheduling tables

In the Scheduling Table Manager, select the table, click the selection arrow by the 
Delete button, and then choose the appropriate Delete option, as follows:

■ To delete the scheduling tables from both the CONTROL-M/EM database and the 
CONTROL-M database, click Delete (R + L). (This option is the default if you click 
Delete without selecting a Delete option.)

■ If the deletion fails, click Force Delete (R + L), which can often successfully perform 
a deletion in a non-serious error situation.

■ To delete the scheduling tables from the CONTROL-M/EM database only, click 
Local Delete.

■ To delete the scheduling tables from the CONTROL-M database only, click Remote 
Delete.

Managing jobs and scheduling groups
The Job List dialog box enables you to perform many job management tasks. Table 12 
lists common job management tasks.

Table 12 Job management tasks  (part 1 of 2)

Task to perform How to perform it

display the list of jobs (and the 
scheduling group) in a table in 
the Job List dialog box

Double-click the table name in the Scheduling Table 
Manager. For additional details, see “To display the list of 
jobs in a table” on page 119.

edit the details of a job or 
scheduling group

In the Job List dialog box, select the job or scheduling 
group, and click Edit; alternatively, for jobs only (not for 
scheduling groups), in the flow diagram, double-click the 
job’s node. For additional details, see “To display the 
details of a job or scheduling group” on page 120.
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To display the list of jobs in a table

1 If the Scheduling Table Manager window is not already displayed, display it by 
choosing Tools => Scheduling Table Manager in CONTROL-M/Desktop.

2 In the Scheduling Table Manager, double-click the scheduling table name, which 
opens the Job List dialog box to display the list of jobs in the selected table. 

move a job Either redefine the relevant parameter (for example, 
CONTROL-M) in the job editing form, or drag the job to its 
new location in the navigation tree. For additional details, 
see “To move a job to a different CONTROL-M, 
scheduling table, scheduling group table, application, or 
group” on page 121.

delete jobs from a scheduling 
table

In the flow diagram, navigation tree, list display, or Job 
List dialog box, select the jobs, and click Delete. For 
additional details, see “To delete jobs from a scheduling 
table” on page 121.

browse a job In the pop-up menu of the job node in the Flow Diagram, 
choose Browse Job. 

copy a job In the Flow Diagram, select the source job, and choose Edit 
=> Copy Job. 

A copy of the job, with a unique identification number, is 
added to the Flow Diagram. Note: This feature is only 
available in your local workspace.

to display the list of versions of 
a job

Select the job in the list and click  (Show History).

From the Job History window you can manage the 
versions of the deleted jobs as follows:

■ viewing the job properties
■ comparing versions
■ restoring previous versions of jobs
■ restoring and editing jobs

See “Managing job versions” on page 126 for a description 
of the job history dialog box.

Table 12 Job management tasks  (part 2 of 2)

Task to perform How to perform it
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Figure 8 Job List dialog box

3 To filter the list of jobs, click the Filter Jobs List check-box, specify values in the 
fields at the top of the Job List dialog box, and click Apply. (To remove filter 
criteria from the fields, click Clear.)

To display the details of a job or scheduling group

Do one of the following actions:

■ If you are working in the Scheduling Table Manager, select the job in the Job List 
dialog box and click Edit. (If the Job List dialog box is not already displayed for the 
scheduling table, display it by double-clicking the scheduling table that contains 
the job whose definition you want to display.)

NOTE  
■  If updates are not permitted (for example, the scheduling table is locked or you do not 

have authorization), the phrase [Read Only] appears in the title bar.

■ Pattern-matching special characters can be used for filtering. For details, see 
“Pattern-matching strings” on page 325.

■ The scheduling group name is always displayed, so that you can access its definition, 
regardless of specified filtering criteria.

■ The filter fields and the columns in the Job List dialog box represent job definition 
parameters. For parameter descriptions, see the CONTROL-M Parameter Guide. 
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■ If you are working in the CONTROL-M/Desktop window (for jobs only, not for 
scheduling groups), double-click the job’s node in the flow diagram or navigation 
tree.

The job or group editing form opens. For instructions on filling in the job or group 
editing form, see “Creating and editing jobs” on page 57.

To move a job to a different CONTROL-M, scheduling table, scheduling group 
table, application, or group

Perform one of the following actions:

■ In the job editing form for the job, redefine the relevant parameter (for example, 
CONTROL-M). 

■ In CONTROL-M/Desktop, display the appropriate hierarchy, and in the 
navigation tree, drag the job to the new location.

To delete jobs from a scheduling table

In the flow diagram, navigation tree, list display, or Job List window, select the jobs 
and click Delete.

NOTE  
If the job processing definition cannot be updated (for example, the scheduling table is locked 
or you do not have authorization), the Job List dialog box contains a View button instead of an 
Edit button.

NOTE  
■ Deleting a job deletes it from the draft, and therefore from any CONTROL-M/Desktop 

panes in which it is displayed.

■ The job will be deleted from the database when you write the scheduling table back to the 
CONTROL-M/EM database.

■ If you delete a scheduling group, all jobs in the table are deleted automatically.

■ If you delete a job from the flow diagram, to avoid cutting the connection between the 
deleted job’s predecessor and successor jobs, set the appropriate option in the 
Flowdiagram - Links panel. For details, see the description of the customization option 
“Automatically inherit job’s conditions if deleted” on page 293.This option works only 
when you are working in a Local workspace, and only if you delete one job at a time.
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C h a p t e r 6
6  Comparing jobs

This chapter presents the following topics: 
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Introduction
You can compare different jobs from the

■ CONTROL-M/Desktop window (that is, the flow diagram or list display, and the 
navigation tree)

■ Job List window available from the Scheduling Table manager in 
CONTROL-M/Desktop

You can choose either method at any time. Factors that might affect your choice are

■ where you are currently working

■ whether you want to work in your workspace (use the CONTROL-M/Desktop 
window) or directly in the CONTROL-M/EM database (choose the Scheduling 
Table Manager)

Comparing jobs
The Job Comparison window enables you to compare jobs and generate comparison 
reports. Table 13 lists common job comparison tasks.
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To display a list of differences between two jobs

1 Select two jobs in CONTROL-M/Desktop.

2 Choose Actions => Compare Jobs.

The Job Comparison window opens (see Figure 9). The tasks that can be performed 
with Job Comparison window are described in Table 13.

Figure 9 Job Comparison dialog box

Table 13 Job comparison tasks 

Task to perform How to perform it

to navigate to rows describing 
differences

Click on the Previous Difference or Next Difference arrows 
icons.

to export a report describing the 
differences between the two job 
versions

Click  (Export).

Select the destination folder and the type of document 
(HTML, text, or XML) for the report.

to search for a string in the field 
values

Type in the string and click  (Find Next). 

to display only the rows that 
contain differences between the 
jobs

Select Only show changes.
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C h a p t e r 7
7  Organizing and managing job 
versions

This chapter presents the following topics: 
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Introduction
You can manage versions of jobs from

■ CONTROL-M/Desktop window (that is, the flow diagram or list display, and the 
navigation tree)

■ Job List window available from the Scheduling Table manager in 
CONTROL-M/Desktop

You can choose either method at any time. Factors that might affect your choice are

■ where you are currently working

■ whether you want to work in your workspace (use the CONTROL-M/Desktop 
window) or directly in the CONTROL-M/EM database (choose the Scheduling 
Table Manager)
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Managing job versions
The Job History dialog box enables you to view previous versions of the selected job 
that were written to (saved in) the Definition file in the CONTROL-M/EM database. 
Table 14 lists common job version management tasks.

To display the list of versions of a job

1 Select a job in CONTROL-M/Desktop.

2 Choose Actions => Show History.

The Job History dialog box opens. The tasks that can be performed with Job 
History dialog box are described in Table 14.

Table 14 Job version management tasks  (part 1 of 2)

Task to perform How to perform it

to display the details of a job 
version

Select a job version in the list and click  (Properties).

The job or group editing form opens. Note: The details 
cannot be edited from this view.

compare two versions of a job In the Job History dialog box, select two job versions, and 
click  (Compare). 

The differences between the versions are marked with an 
icon and rows are highlighted.

Tip: While the Version Comparison window is open, you 
can select any of the available versions for comparison, 
without closing and reopening the Version Comparison 
window. 
Click either one of  (Down Arrow) icons, located at the 
right top corners of the Value in Version X columns, and 
select a version from the menu.

to replace a current job with a 
previous version of the job

Select required previous version in the list and click  
(Restore).

Note: If you are working in the Online workspace or in the 
Job List from the Scheduling Table Manager, the job is 
restored in the CONTROL-M/EM database. If you are 
working in the Local workspace, the job is only restored 
locally in the CONTROL-M/Desktop. You must then write 
the table containing the job to the CONTROL-M/EM 
database in order to restore it in the database.



Managing deleted jobs

Chapter 7    Organizing and managing job versions 127

Managing deleted jobs
To display the list of deleted jobs, select Tools => Deleted Jobs or click  in 
CONTROL-M/Desktop. In the filter area, you can enter regular expressions for filter 
criteria.

Table 15 lists tasks you can perform in the Deleted Jobs window.

to edit a previous version of the 
job and replace the current job 
with the edited version

Select the job in the list and click  (Edit & Restore).

The job editing form opens so that you can edit the 
previous version and replace the current version with the 
edited version.

to refresh the job versions list Click .

to export the list of job versions Right-click in the list area and click Export to File. The list 
is saved as a .csv file. 

to print the list of job versions Right-click in the list area and click Print.

to display the number of job 
versions in the list

Right-click in the list area and select Item Count. The 
number of job versions in the list is displayed in the status 
area below the horizontal scroll bar.

Table 15 Deleted jobs management tasks  (part 1 of 2)

Task to perform How to perform it

to view the properties of a 
deleted job

Double-click the selected job in the list. Note: You cannot 
edit the job from this view.

to display the list of versions of 
a deleted job

Select the job in the list and click  (Show History).

From the Job History window you can manage the 
versions of the deleted jobs as follows:

■ viewing the job properties
■ comparing versions
■ restoring deleted jobs
■ editing and restoring jobs

See description of job history dialog box on page.

Table 14 Job version management tasks  (part 2 of 2)

Task to perform How to perform it
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Examples
The following examples illustrate how the version management features can be 
helpful in solving scheduling problems:

Modified Job - troubleshooting using the version history feature

Deleted Job - troubleshooting using the deleted jobs feature

Calendar change - troubleshooting using the Reporting Facility’s Audit report with 
the Calendar Modifications template

Modified Job

Why did Job22 finish with a NOT-OK status? Until today, Job22 always ran without 
any problems, finishing everyday with an OK status.

to restore one or more deleted 
jobs

Select one or more jobs in the list and click  (Restore).

Note: If you are working in the Online workspace or in the 
Job List from the Scheduling Table Manager, the job is 
restored in the CONTROL-M/EM database. If you are 
working in the Local workspace, the job is only restored 
locally in the CONTROL-M/Desktop. You must then write 
the table containing the job to the CONTROL-M/EM 
database in order to restore it in the database.

to edit a deleted job and then 
restore it

Select the job in the list and click  (Edit & Restore).

The job editing form opens so that you can edit the deleted 
version of the job and after editing it you can choose to 
restore the edited version.

to edit and restore a deleted job 
version

Select the job in the list and click  (Edit & Restore).

The job editing form opens so that you can edit and restore 
a deleted job version.

to export the list of deleted jobs Right-click in the list area and click Export to File. The list 
is saved as a .csv file. 

to print the list of deleted jobs Right-click in the list area and click Print.

to display the number of deleted 
jobs in the list

Right-click in the list area and select Item Count. The 
number of deleted jobs in the list is displayed in the status 
area below the horizontal scroll bar.

Table 15 Deleted jobs management tasks  (part 2 of 2)

Task to perform How to perform it
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To find out the problem with Job22 do the following:

1 Load the table containing Job22 to the CONTROL-M/Desktop.

2 Select Job22 from the job list. Right-click and choose Show History from the context 
menu.

The Job History window shows the user emuser, working from the host tlvd0120, 
modified Job22 the previous day.

3 Select the current and previous versions of Job22 and click Compare.

The Compare Versions window shows that emuser changed the value of the 
AutoEdit Amount parameter from 0.1 to 1.0.1.

After discussing the reason for the change with the person who modified Job22, it 
becomes apparent that the change was a mistake and the value should remain 0.1.

4 Select the previous version and click Restore. 

The job description of Job22 is updated. The current job description of Job22, in the 
job editing form in the CONTROL-M/Desktop draft, now contains the values from 
the previous version. 

5 Write the table back to the definition file in the CONTROL-M/EM database.

Deleted Job

Why isn’t Job22 running? Until today, Job22 ran on a daily basis without problems.

To find out why Job22 is not running do the following:

1 Perform a Why operation on Job22.

The results indicate that Job22 is waiting for condition Cond1. Since all jobs 
completed successfully it is not immediately apparent why condition Cond1 is not 
available. Perhaps the job with Out condition Cond1 was not ordered due to 
changes in the scheduling definition or perhaps the job was removed or modified.

2 Run an Audit report using the Sample 8 - All Table Modifications template.

The generated report shows that emuser on host tlvsrv021 deleted Job21 and 
modified Job20 three days ago.

3 Load the application jobs to the CONTROL-M/Desktop.
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4 Select Job20 for the job list. Right-click and choose Show History from the context 
menu.

5 Select the current and previous versions of Job20 and click Compare.

The Versions Comparison window shows that emuser only modified the 
description of the job, without effecting the scheduling. Something else must be 
causing the problem. 

6 Select Tools => Deleted Jobs and filter by time frame and Application. The resulting 
job list contains only Job21.

7 Select Job21 and click Properties. Job21 has an Out condition called Cond1.

After talking to the person (emuser on host tlvsrv021) who deleted the job to 
determine whether a previous version of the job should be restored, it becomes 
clear that Job21 should have been removed, but the person forgot to remove Cond1 
from the definition of Job22.

8 Remove Cond1 from the list of conditions in the job editing form of Job22.

9 Write the application with Job22 back to the CONTROL-M/EM database.

Calendar change

Why isn’t Job33 running? Until today, Job33 ran every Wednesday for the past 6 
months without any problems. Today, on 23/01/2008, Job33 was not ordered. 

To find out why Job33 was not ordered do the following:

1 Load the table containing Job33 to CONTROL-M/Desktop.

2 Select Job33 from the Job List. Right-click and choose Show History from the 
context menu.

The Job History window shows that none of Job33’s scheduling parameters were 
changed during the last 6 months.

3 Run an Audit report using the Sample 7- Calendar Modification template.

In this template, the filter is set to <Calendar Modifications> and Calendar name is 
specified for the Fields Filter. Specify the name of the calendar used by Job33. The 
generated report shows that the calendar was modified recently by user X and the 
details for the month of January were changed. Comparing the scheduling values 
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of January before and after the change shows that 23/01/2008 was removed and 
some dates were added. After talking to the person that changed the calendar, it 
appears that between 20/01/2008 and 10/02/2008, Job33 should run twice a week. 
However, by mistake 23/01/2008 was removed during the change.

4 Edit the calendar definition to correct the mistake. 

5 Write the table with Job33 back to the CONTROL-M/EM database.
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C h a p t e r 8
8  Using predefined calendars to 
schedule jobs

This chapter presents the following topics:
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Introduction
You can define and use calendars to simplify how you define job scheduling criteria. 
Calendars enable you to define a set of scheduling criteria once in a calendar 
definition and then apply those criteria to job schedules by specifying the calendar 
name in the job processing definitions. This feature saves you from having to define 
those sets of criteria individually in each job. 

You create, modify, and manage calendars by using the Calendar Manager dialog 
box, which you access from CONTROL-M/Desktop. This dialog box accesses the 
CONTROL-M/EM database. Before a calendar can be used for scheduling, it must 
also be uploaded to the appropriate CONTROL-M/Server database.

The Calendar definition facility supports the following types of calendars:

■ Regular calendars, which use dates as they appear in regular calendars.

■ Periodic calendars, which divide the year into working periods instead of the 
standard twelve months. Periods can be nonconsecutive, of varying length, and 
overlapping. No single period can exceed 255 days.
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■ Relative calendars (for z/OS jobs only), which you create by combining two 
calendars (relative or regular) through the CONTROL-M IOABLCAL utility. For 
details, see the CONTROL-M for z/OS User Guide. 

Each calendar you create is defined for a specific year and on a specific 
CONTROL-M, but you can copy calendar definitions to other years and to other 
CONTROL-Ms.

To see the effect of a calendar on a job’s schedule plan, use CONTROL-M/Forecast. 
For details, see Chapter 26, “Planning production with CONTROL-M/Forecast.”(If 
CONTROL-M/Forecast is not licensed at your site, you can use the CTMRPLN utility 
to produce a report that indicates when jobs in a selected calendar are scheduled to 
run. For more information, see the CONTROL-M Administrator Guide and the 
CONTROL-M for z/OS User Manual.)

Creating and modifying calendars
1 In CONTROL-M/Desktop, display the Calendar Manager by choosing Tools => 

Calendar Manager or by clicking , which opens the Calendar Manager dialog 
box to display the list of calendars that exist in the CONTROL-M/EM database.

Figure 10 Calendar Manager dialog box
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2 To modify an existing calendar, select the calendar in the Calendar Manager dialog 
box, and click  (Edit). To create a new calendar, do the following:

A In the Calendar Manager dialog box, click  (New).

B In the displayed Calendar dialog box, select the CONTROL-M in which the 
calendar will be defined, enter a name for the calendar, and select the type of 
calendar (regular / relative, or periodic). 

C In the displayed Year dialog box, select the year for which you are defining the 
calendar, which displays the calendar definition dialog box—the main dialog 
box for defining (or modifying) calendar schedules. 

You perform the following steps in the calendar definition dialog box (see 
Figure 11).

Figure 11 Calendar definition dialog box

3 Fill in a free text description that will appear in the Calendar Manager. (This step is 
optional, but recommended. It will later help you identify and select calendars.)

4 Select the year for the calendar (if different from the already selected year).
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5 To define a regular or relative calendar, set a Y indicator in the calendar’s 
scheduling date boxes, as follows: 

■ To set individual date boxes to Y, select the box clicking it and type Y. (Selected 
boxes turn blue; boxes set to Y have a Y indicator on a green background.)

To avoid repeatedly typing Y, you can first select all required scheduling dates 
and then, right-click one of them and choose Y. All selected dates will be set to Y. 

■ As a short cut, to select an entire row or column of dates in a month, click the 
row or column header. Select the required rows or columns, then type Y.

■ As a short cut, to apply the same set of dates to all the months

— click Advanced

— in the displayed General Calendar dialog box, select the dates by clicking any 
combination of specific dates, column and row headers, and days of the week

— click OK (be sure you are clicking OK in the General Dialog box)

— in the displayed calendar, type Y.

To clear currently selected dates, click the appropriate date, column or row boxes 
again. To undo Y indicators, select the appropriate date, column or row boxes, 
right-click one of them, and choose N.

6 To define a periodic calendar, do the following:

A Select the dates for which you want to provide the same period identifier.

B Type the identifier to identify the period. Valid values are any alphabetic or 
numeric character, except Y or N. (To undo a periodic calendar value, right-click 
the box.)

The same shortcut principles that apply to regular calendars (step 5) apply to 
periodic calendars.

7 To add an additional year to the calendar, with the same settings, click Copy. In the 
New Year dialog box select the additional year and click OK. 

TIP  
To select all the days of a month, click the box at the top, left corner of the calendar. 

In some cases, it might be quicker to select a set of dates and then undo the exceptions. 
For example, to select all days but one in a particular week, click the row heading 
column (to select the week) and then click the exception to unselect it.
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8 When you have finished defining the calendar, click OK, which saves the changes 
in the CONTROL-M/EM database. 

To use the calendar, you must perform an upload.

 

 

 

Managing calendars
This section describes how to upload and download calendars, how to copy or delete 
them, and several other calendar management tasks.

EXAMPLE  
 

To schedule a job on each Wednesday in March, do the following:

1. In the calendar for March, click the W button at the top of the calendar.

2. Type Y.

3. Click OK.

EXAMPLE  
 

To schedule a job on each Tuesday in every month, do the following:

1. Click Advanced.

2. In the General Calendar dialog box, click the Tue check-box, and then click OK.

3. With the calendar displayed, type Y.

4. Click OK in the calendar.

EXAMPLE  
To schedule a job on first and fifteenth day in every month except April, do the following:

1. Click Advanced.

2. In the General Calendar dialog box, click calendar days 1 and 15, and then click OK. 

3. In the calendar, in April, click (off) calendar days 1 and 15.

4. With the calendar displayed, type Y.

5. Click OK.
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Uploading and downloading calendars

You must upload calendars from the CONTROL-M/EM database to the 
CONTROL-M/Server database, to use them for job scheduling, 

To upload updated calendars to the CONTROL-M/Server database

In the Calendar Manager dialog box, select the calendar, and click .

To download calendars from the CONTROL-M/Server database to the 
CONTROL-M/EM database

In the Calendar Manager dialog box, select the calendar, and click  (Download).

Copying calendars

Instead of creating new calendars from beginning to end, you can copy and modify 
existing calendars. Although calendars are defined on a particular CONTROL-M, you 
can copy them to other CONTROL-Ms.

NOTE  
Upload and download are background processes; during these processes, you can perform 
other actions.

TIP  
If the CONTROL-M/Server database contains a more recent version of the calendar you 
are trying to upload, an “Already Updated” error is issued and the upload is prevented. To 
force the upload in this case, click  (Force Upload).

TIP  
To download a calendar that is not displayed in the Calendar Manager dialog box, create 
an empty calendar with the same name and save it; then download the calendar normally. 
(The downloaded version will overwrite the empty version.)

NOTE  
When copying a calendar, if you specify a different target CONTROL-M, it must be the same 
platform and version as the source calendar’s CONTROL-M.
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To copy a calendar

1 In the Calendar Manager dialog box, select the calendar and click  (Copy).

2 In the displayed Copy Calendar dialog box, select the CONTROL-M to which the 
calendar will be copied, and enter a name for the new copy of the calendar. 

3 Click OK, which saves the copy of the calendar in the CONTROL-M/EM database, 
and displays the new calendar name in the Calendar Manager.

Deleting calendars

In the Calendar Manager dialog box, select the calendars and click the appropriate 
button option, as follows: 

■ To delete the calendars from both the CONTROL-M/EM database and the 
CONTROL-M/Server database, click the Delete button or click Delete (R + L). (This 
is the default if you click Delete without selecting a Delete option.)

■ If the delete fails, click Force Delete (R + L), which can often successfully perform a 
delete in a non-serious error situation.

■ To delete the calendars from the CONTROL-M/Server database only, click Remote 
Delete.

■ To delete the calendars from the CONTROL-M/EM database only, click Local 
Delete.

Refreshing and unlocking calendars

If you have the required permissions, you can also refresh the calendar display, and 
unlock locked calendars. (Calendars are locked automatically while they are being 
edited, and you should exercise great caution before unlocking them. For example, 
you might need to unlock a calendar that was being edited when a crash occurred.)

To refresh or unlock calendars

In the Calendar Manager, click  (Refresh).
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To unlock calendars

In the Calendar Manager, select the calendars and click  (Unlock).
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C h a p t e r 9
9  Setting up templates for 
standardized job definition

This chapter presents the following topics:
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Adding functions to template fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  143

Managing templates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  145

Different jobs will often have the same values for many parameters. To make the 
process of defining such jobs easier, you can define the common values in a template, 
and use the template to place those values into the job processing definitions. 
Templates can be useful whether you are creating job processing definitions one at a 
time or creating large numbers of job processing definitions, all at the same time.

You can also define scheduling group templates. Scheduling group templates can be 
used not only for creating scheduling groups, but for defining jobs within the group 
scheduling table as well. This means that if you define values for a scheduling group 
template, you do not need to define those same values in a job template.

Templates are platform-specific. The product comes with sample job and scheduling 
group templates for supported platforms, which you can use as a basis for 
developing your own templates.
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Defining templates
1 In the CONTROL-M/Desktop window, choose Tools => Template Manager, which 

displays the Template Manager.

Figure 12 Template Manager

2 In the Template Manager, do one of the following, to display the template editing 
form, which is essentially identical to a job or group editing form:

■ To modify an existing template, or create a new template from an existing 
template, select the template in the list of templates and click  (Update 
Template).

■ To create an all new template from beginning to end:

— Click  (New Job Template) to create a template for a regular job.

— Click  (New Scheduling Group Template) to create a template for a 
scheduling group.
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Figure 13 Template editing form

3 Fill in or modify the template. For instruction and hints, see the instructions for 
filling in the Job Editing Form in “Creating and editing jobs” on page 57. (For a 
description of the parameters of in Job Editing Form, and their usage and values, 
see the CONTROL-M Parameter Guide.)

In most free text fields (exceptions include Control Resource Name, Quantitative 
Resource Name, AutoEdit var, and Steps, which are located in the appropriate tabs), 
you can insert predefined functions instead of, or in addition to, literal values. (For 
example, in the Job Name field, you might insert the function jbl{counter}). For 
instructions on inserting functions, see “Adding functions to template fields” on 
page 143. 

4 When you have finished defining the template, save it by clicking Save, Save As, or 
Save and Close at the top of the template.

Adding functions to template fields

When defining values in template fields, you can add functions that get resolved 
when the template is used to create job processing definitions. For example, when 
using a template to create many jobs beginning with the same name, you can add a 
counter function after the name prefix in the template’s Job Name field, to ensure that 
each job is created with a unique name. 
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To insert functions into a field

1 Place the cursor in the field and click Insert Function on the toolbar at the top of the 
template.

2 In the Insert Function dialog box, click Insert Function.

3 In the displayed list, perform one of the following actions (to perform several of 
the following actions, select just one and perform it, and then continue with the 
remaining steps, which will have you cycle through this step again):

■ To use the value from another field

— select {Field Name}

— in the displayed From source list, select the field whose value should be used 
in the field.

■ To insert a counter

— select {Counter}

■ To insert a substring

— select {Substr}

— in the displayed From source list, select the source from which the substring 
should be taken

— select the number of characters that should be taken from the source for the 
substring, and the character position from which to begin taking the 
substring extract

■ To add or subtract a value to a numeric function

— select {+} or {-}

— select the source of the value

— select the quantity to be added or subtracted

4 If a green check-mark is displayed to the right of the Insert Function dialog box, 
click it.

5 To add more functions, repeat the process beginning with Step 2.

6 To add a literal value before or after the function, position the cursor in the correct 
position and specify the value.
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7 When finished, click OK in the Insert Function dialog box.

For a list description of available functions, see Table 46 on page 329.

 

Managing templates
This section explains how to copy and delete templates.

To copy a template locally

1 In the Template Manager, select the template to be copied and click  (Copy 
Template). 

2 Enter a new name for the template, and click OK.

To copy a template to another computer

Templates are stored as .xml files under <InstallationDirectory>\Data\Templates. You 
can transfer them to any computer that has the same operating system and version.

To delete a template

In the Template Manager, select the template and click  (Delete Template).

TIP  
If you clicked OK in the Insert Function dialog box, and functions you selected did not 
appear, you might have forgotten to click the green check-mark. Specify each missing function 
again and ensure you click the green check-mark. Then click OK again.

EXAMPLE  
The template should add the following values to jobs (along with other values not included in 
the example):

■ a job name of APXYn, where n is incremented by 1
■ a file name of jobname.bat

In the following template fields, define the following indicated values and functions:

■ In the Job Name field: APXY{Counter} 
■ In the File Name field: {Job Name}.bat 
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C h a p t e r 10
10  Creating and updating many jobs at 
once
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Introduction
Through the Mass Create feature of CONTROL-M/Desktop, you can automatically 
create large numbers of job processing definitions through a single request. 

Although you must later provide these jobs their unique values individually in the 
Job Editing form, this technique saves you from having to enter the common values 
for these jobs individually.

You can use the Find and Update feature of CONTROL-M/Desktop to perform 
updates on large numbers of existing job processing definitions.

Creating large numbers of jobs
This section describes how to use the Mass Create feature to create large numbers of 
jobs with similar parameters.
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To create multiple jobs with similar parameters

1 In the CONTROL-M/Desktop window, choose Tools => Mass Create or click .

2 In the Mass Create dialog box, choose the number of jobs to create and select the 
template to be used for creating the new job processing definitions. (To create a 
new template or edit an existing template, click Edit Template. For details about 
editing templates, see Chapter 9, “Setting up templates for standardized job 
definition.”)

3 Click OK.

4 After you have performed mass job creation, you can create dependencies between 
the jobs by clicking and dragging on job nodes in the flow diagram. For details, see 
“Defining job dependencies by using the flow diagram” on page 109.

Finding and updating many entities at once
The CONTROL-M/Desktop Find and Update feature can find jobs and update fields 
and values in jobs and scheduling groups. 

Using the Find and Update feature, you can

■ search for job processing definitions with various values in any field, including 
application form fields and list fields such as On/Do statements

■ update, add, or remove any of the job processing definition fields

NOTE  
To use the Mass Create feature, you must be working in your local workspace.

TIP  
Instead of creating all jobs in a table with a single request, you can use several requests and 
modify the template before each request. The resulting jobs might then require less cleanup 
after you have created them. 

NOTE  
The Update button is only enabled when working in a Local workspace and can not be used 
for Online workspaces and Forecast workspaces.

In Forecast workspaces, conducting a search is limited to certain fields, because only part of 
the job is loaded from the Forecast Server.
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Finding and updating jobs and scheduling groups

To find and update jobs and scheduling groups

1 In CONTROL-M/Desktop, choose Edit => Find and Update.

Figure 14 Find and Update window

2 In the Find grid area of the Find and Update window, choose or fill in the 
following information:

■ field in the job or group processing definition to be searched and possibly 
updated

■ an operator
■ a search value 

When specifying complex fields (such as In Condition) you can further refine the 
search by clicking  one or more times and selecting subordinate fields.

NOTE  
When supported application forms are installed, applications fields can be selected from 
the Forms submenu. You must to restart CONTROL-M/Desktop after installing an 
application panel.
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3 To add additional search criteria expressions, click  or Insert, and repeat step 2 
for each expression. An AND relationship applies to multiple criteria expressions; 
a job must satisfy all specified criteria to match. To delete search criteria 
expressions, select the expression and click  or Delete.

4 To save the specified Find and Update criteria for future use, choose Presets => 
Save and specify a name in the Save Preset dialog box, and click OK.

5 Click Find. Jobs that match the criteria in the Find grid are displayed in the Results 
grid area.

6 In the Update grid area, choose or fill in the following information:

■ one of the following update actions:
— Update - value of field is changed regardless of the previous value
— Update where - value of field is changed depending on the previous value
— Add - a new item is added to a list field such as In conditions
— Remove - an item is removed from a list field such as In conditions

■ field in the job or group processing definition to be updated
■ an operator
■ a search value 
■ an assign function or replacement value, if the search value is found

7 To add additional search criteria expressions, click , and repeat step 6 for each 
expression. There is a sequential relationship between the expressions. To change 
the order of the expressions click on the up and down arrow icons. To delete 
criteria expressions, select the expression and click .

8 Click Update to perform the update.

The tables that follow provide a description of the search criteria used in finding and 
updating jobs and scheduling groups.
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Table 16 FIND and Update actions

Expression Type Description

Find Evaluate simple fields such as Job Name and Application, according to the find 
operator and find value selected. For example: Find CONTROLM like “ABC*”

Find any Specifies list fields such as In Conditions and Shouts and updates or evaluates as 
specified in the sub-expressions of this complex expression.

Example 1: 

“Find any Control Resource” matches to any job that has at least one control 
resource defined.

Example 2:

“Find any Control Resource where Name like C*, D*” matches to any job that 
contains at least one control resource that starts with the letter C or D.

Update Update simple or sub-fields as defined (not conditional).

Update where Conditional updates of simple fields or sub-fields. 

For example:

“Update where Application starts with the letter A replace substring A with xyz,” 
updates application fields that start with the letter A and replaces every occurrence 
of the letter with the substring xyz. 

Add Adds a new complex field into a list field. 

For example:

Add In Condition:

■ Set Name like “incondition1”
■ Set Date like “ODAT”

Add a new in condition to all jobs found (according to the rest of the criteria) and 
set the sub-fields as defined.

Remove Removes a complex field from a list field. 

For example:

Remove Shout:

■ Where To like “ECS”

Removes all shouts to destination ECS from all jobs found according to the rest of 
the criteria.
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Table 17 FIND operators

Operator Description

like Enhances regular expressions supported. For more information, see 
“Pattern-matching strings” on page 325. It is supported by the like operator in all 
other windows (for example, viewpoint collection definition, and alert filter).

not like The opposite of “like”.

is (exactly) The field value is equal to the value provided (exact match, no wildcards or 
regular expressions).

is not (exactly) The field value is not equal to the value provided.

starts with The field value starts with the value provided. Pattern-matching rules apply. 
Special characters such as ‘*’ are not processed as literals unless there is a 
backslash.

■ DESCRIPTION Starts with “abc*”
■ Matches DESCRIPTION values “abcd”, “abc888”, and “abc*”
■ The DESCRIPTION that starts with “abc\*”, matches only DESCRIPTION 

values “abc*999”, “abc*ddd” etc. 

ends with The field value ends with the value provided. Pattern-matching rules apply.

contains The field value contains the substring (exact or pattern) provided. 
Pattern-matching rules apply.

doesn’t contain The field value does not contain the substring (exact or pattern) provided. 
Pattern-matching rules apply.

is empty The field has no value (NULL or empty string). 

is not empty The field has ANY value. 

< or < = or > or > = Used for numeric or lexicographic comparison.

Table 18 Update Operators  (part 1 of 2)

Action Description

assign Assigns the value as is (no functions, place holders or regular expressions). 

If the field contains several values (a list field, such as scheduling Dates field), 
you can add or modify values in the list, by providing comma-separated values. 
If only one value is specified, only the first value in the list field is updated.

For example, to add three scheduling dates to the list use:

Update “Dates” assign “0909,0807,0221”



Finding and updating jobs and scheduling groups

Chapter 10    Creating and updating many jobs at once 153

assign function Table 46 on page 329 describes special functions that you can use to specify 
complex assign function values using the Insert Function dialog box. 

Additionally, the '*' character is a special place holder of the previous field value 
(or a part of it).

Examples:

■ Set the job’s 
MEMLIB FROM ‘/home/user1/*’ TO ‘/home2/user3/*’

■ Update where Out Condition Name like “*” assign function 
“*@HHMMSS”.
The condition name is evaluated and set by CONTROL-M at runtime, 
enabling users for example to create unique condition names in cyclic jobs. 
The character ‘*’ has a special meaning and can save the previous field 
value.

■ Update Application assign function to new{Application}.

clear Clears the field value. Fields that are assigned with a predefined set of values 
reset to the default value.

replace substring Replace all occurrences of the substring specified in FROM field with the one 
specified in the TO field (which may be empty).

For example, 

If the field contains several values (a list field, such as the “SAP R3:Variant 
Name” field), you can replace a substring like “VAR1” with another string 
“VAR2” in all cell values using the following statement:

Update “SAP R3:Variant Name” replace substring “VAR1” “VAR2”

replace expression Regular expressions search and replace support (can use references to 
numbered groups). 

For example, 

Update Application replaces expression (.*)account(.*) with \2account\1

In this example, if the Application's original value was GLOBALaccount45, the 
update is set to 45accountGLOBAL.

If the field contains several values (a list field, such as the “AFT::File Path on 
Host 1” field), the assign operator allows you to modify the whole list at once, 
using comma-separated values. However, you can set all cell values with the 
same “test” value like this:

Update “AFT::File Path on Host 1” replace expression “.*” “test”

Table 18 Update Operators  (part 2 of 2)

Action Description
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Managing updated jobs

When processing update expressions, if the conditions of a particular expression is 
not met, the expression is skipped and the next expression is evaluated. 

However, if a particular update expression fails (for example, if the specified change 
is not supported) the job will not be updated for any of the other expressions and the 
update process will skip to the next job. In the list of results, the job is marked as 
“skipped”.

To correct a job with a validation error

1 In the Results grid area, click Validate...

2 In the Validity Checks dialog box, double-click a validation error. The job editing 
form opens and the invalid field value is highlighted.

3 Enter the correct value and click Save and Close.

To rollback updates

1 Select the jobs in the Results grid area that you want to rollback.

2 Click Rollback Updates.

To highlight a job in the Desktop

1 Ensure that the Select in View toggle button appears pressed.

2 Select the job in the Results grid area that you want to highlight. You can then view 
it highlighted in the Flow diagram, Gantt view, or List view.
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Introduction
If for a specific job or set of jobs there is usually a variation in statistic values for 
different periods during the week, month, or year, there is a great advantage in 
collecting the statistics separately for each distinct period. Statistics which are 
collected separately for each period are called periodic statistics, and are managed 
using the Periodic Statistics Manager. 

This section describes how to collect periodic statistics using the Periodic Statistics 
Manager. 

EXAMPLE  
If the average runtime of a job during work days is different than during weekends there is an 
advantage of collecting statistics for this job separately for work days and for weekend 
periods. The average runtimes will then be much more accurate for each period. 
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Defining periodic statistics definitions
A periodic statistics definition determines the periods according to which statistics 
are collected for a specific job or set of jobs. These periods are defined in a Periodic 
Calendar, using the Calendar Manager. The periodic statistics definition relates the 
desired Periodic Calendar to a job or set of jobs. 

To relate a Periodic Calendar to a job or set of jobs do the following:

■ Use the Calendar Manager, available in CONTROL-M/Desktop, to find or create 
an appropriate Periodic Calendar. 

■ Use the Periodic Statistics Manager, available in CONTROL-M/Desktop, to create 
a periodic statistics definition.

To display the Calendar Manager, select Tools => Calendar Manager. For details about 
defining and using Periodic Calendars, see Chapter 8, “Using predefined calendars to 
schedule jobs.”

To display the Periodic Statistics Manager, select Tools => Periodic Statistics Manager.

A list of periodic statistics definitions are displayed in the Periodic Statistics Manager. 
The user must arrange the periodic statistics definitions in order of precedence, so 
that if a job is included in two or more periodic statistics definitions, the definition 
with the greater precedence (higher up on the list) is applied to the job. By default, 
new definitions are added to the bottom of list as they are created. Since the order of 
the definitions is important, the list cannot be sorted.

Changing periodic statistics definitions

The following use cases involve changing the periodic statistics definitions.

Consider the case where periodic statistics are collected for the following two 
periods: weekends (defined as period A) and weekdays (defined as period B). 
Initially, Friday is considered a weekday, but after a few weeks have passed, it is 
decided to consider Friday as part of the weekend. To reflect this change, all Fridays 
in the Periodic Calendar are marked with "A’s" instead of a "B’s".

NOTE  
A statistics calendar that is defined in an MVS job takes precedence over a Periodic Calendar 
that is related to the job through the Periodic Statistics Manager.
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In this case, the statistics collected on the Fridays before the change, remain part of 
the weekday statistics, since the periodic statistics are not recalculated retroactively. 
When a change is made in the Periodic Calendar, only future statistics calculations 
are affected.

Consider the case where the holidays for the current year are marked in the Periodic 
Calendar with the letter "G". In this case, holidays for future years should also be 
marked with the same letter, "G". This ensures that statistics collected during 
holidays in the current year will be used for jobs that will run on holidays of future 
years. If, over time, more than one period letter is used to mark holidays, each set of 
holidays marked by a different letter is considered a different period.

Managing periodic statistics definitions
Table 19 lists periodic statistics management tasks you can perform with the Periodic 
Statistics Manager.

To create a periodic statistics definition

1 In the Periodic Statistics Manager window, click  (New), which opens 
the Periodic Statistics Definition dialog box.

2 Fill in the details for the new periodic statistics definition, as follows:

Table 19 Periodic statistics management tasks 

Task to perform How to perform it

to create a periodic statistics 
definition

Click  (New). For additional details, 

see “To create a periodic statistics definition” on page 157.

to change the basic details of a 
periodic statistics definition

Select the periodic statistics definition and click 
(Edit). For additional information, 
see “To change the basic details of a periodic statistics 
definition” on page 158.

to change the precedence of a 
periodic statistics definition

Click  (Move Up) and  (Move Down).

For additional details, see “To change the order of 
precedence of a periodic statistics definition” on page 158.

to copy a periodic statistics 
definition

Select the periodic statistics definition and click 
(Copy). For additional details, 
see “To copy a periodic statistics definition” on page 159.

to delete a periodic statistics 
definition

Select the periodic statistics definition(s), click 
(Delete). For additional details, 
see “To delete a periodic statistics definition” on page 159.
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A Specify a name and enter a description for the periodic statistics definition.

B Choose an appropriate Periodic Calendar by specifying the name of the 
CONTROL-M where the calendar is defined and the name of the Periodic 
Calendar.

C Fill in the job filter criteria. The fields of the job filter support regular 
expressions. Statistics are collected for jobs matching these criteria according to 
the periods of the Periodic Calendar specified in the previous section.

3 Click OK. The Periodic Statistics Definition dialog box closes, putting the new 
periodic statistics definition into the temporary Periodic Statistics Manager buffer. 
You can now repeat the procedure from Step 1, creating additional periodic 
statistics definitions.

4 Click OK or Apply in the Periodic Statistics Manager window to save the newly 
created periodic statistics definitions. 

To change the basic details of a periodic statistics definition

1 In the Periodic Statistics Manager, select the periodic statistics definition in the list 
and click  (Edit). 

2 In the Periodic Statistics Definition dialog box, make the changes and click OK.

3 Click OK or Apply in the Periodic Statistics Manager window to save the edited 
periodic statistics definition.

To change the order of precedence of a periodic statistics definition

1 In the Periodic Statistics Manager, select the periodic statistics definition in the list 
and click the Move Up and Move Down arrow buttons, as needed, to move the 
definition to the required position in the list.

2 Repeat Step 1 for any periodic statistics definition that you want to reposition.

NOTE  
Although the Periodic Calendar might be defined for a particular CONTROL-M server, 
the Periodic Statistics Manager ensures that the new periodic statistics definition is 
applied globally to all jobs included in the definition, regardless of which CONTROL-M 
server runs the job.

NOTE  
Before saving the new periodic statistics definitions, you can arrange the order of their 
precedence using the Move Up and Move Down arrow buttons. 
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3 Click OK or Apply in the Periodic Statistics Manager window to save the new order 
of precedence for the periodic statistics definitions.

To copy a periodic statistics definition

1 In the Periodic Statistics Manager, select the periodic statistics definition to be 
copied, and click  (Copy). 

2 In the Copy Periodic Statistics Definition dialog box, specify a name for the new 
periodic statistics definition in the Name field, modify the other criteria as needed, 
and click OK.

3 Click OK or Apply in the Periodic Statistics Manager window to save the edited 
periodic statistics definition.

To delete a periodic statistics definition

1 In the Periodic Statistics Manager, select the periodic statistics definition, click 
 (Delete).

2 Click OK or Apply in the Periodic Statistics Manager window to save the change.
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Part 3Moving to production
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C h a p t e r 12
12  Introduction to moving to 
production

This chapter presents the following topics: 

Moving to production . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  163
Where to go from here. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  163

Moving to production
After you have defined scheduling tables and jobs, to move to production you must 
perform the following tasks:

■ Move the jobs to production
■ Automate job scheduling by using New Day processing
■ Define resources to CONTROL-M
■ Define global conditions to establish job dependencies globally

Where to go from here
■ To move jobs into production, see Chapter 13, “Putting jobs into production.”
■ To automate job scheduling, see Chapter 14, “Automating job scheduling and 

maintenance.”
■ To define resources to CONTROL-Ms, see Chapter 15, “Identifying data center 

resources available for CONTROL-M use.”
■ To define global conditions, see Chapter 16, “Establishing job dependencies across 

CONTROL-Ms.”
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C h a p t e r 13
13  Putting jobs into production

This chapter presents the following topics: 

Writing tables to the CONTROL-M/EM database . . . . . . . . . . . . . . . . . . . . . . . . . . . .  165
Uploading tables to the CONTROL-M database. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  166
Manually scheduling jobs and tables  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  168
Downloading tables from CONTROL-M to CONTROL-M/EM . . . . . . . . . . . . . . . .  170

After you have finished defining or modifying job processing definitions, to use them 
you must ensure that the tables that contain them are written to the 
CONTROL-M/EM database and loaded to the appropriate CONTROL-M database. 

Writing tables to the CONTROL-M/EM 
database

If you are working in an online workspace or using the Scheduling Table manager, 
when you save your work, the CONTROL-M/EM database is directly updated, so 
there is no need to perform a write operation. 

A write operation is only relevant when you are working in a local workspace. 

To write a scheduling table to the CONTROL-M/EM database

1 From your local workspace in CONTROL-M/Desktop, do one of the following:

■ To write multiple tables:

1. Choose File => Write to CONTROL-M/EM.

2. In the displayed Write to CONTROL-M/EM dialog box, select the tables and 
click Write. (To filter the display, select the filtering criteria and click Apply.)



Uploading tables to the CONTROL-M database

166 CONTROL-M User Guide

■ To write an individual table, do the following:

1. If the CONTROL-M hierarchy is not displayed, choose View => Hierarchy => 
Data Center/Scheduling Table/Job. 

2. In the flow diagram or navigation tree, right-click the scheduling table node, 
and in the pop-up menu choose Write. 

2 If the Confirm Write Scheduling Tables dialog box is displayed, it means that the 
tables listed in the dialog box (that you are trying to write) already exist in the 
CONTROL-M/EM database and are unlocked. If you continue the write operation 
on those tables, you will overwrite the existing version.

Click the check box next to the tables that you want to overwrite, and click Write.

Depending on how system parameters are set, after you click Write in the Confirm 
Write Scheduling Tables dialog box, CONTROL-M/Desktop might prompt for an 
additional confirmation.

The results of the Write operation are displayed in the Write Scheduling Tables 
Results dialog box.

Uploading tables to the CONTROL-M database
The upload operation copies the tables from the CONTROL-M/EM database to the 
CONTROL-M database. Therefore, you must ensure that your changes are first saved 
in, or written to, the CONTROL-M/EM database before you upload them to the 
CONTROL-M database.

WARNING  
BMC Software recommends that you not overwrite any tables unless you are certain that you 
are not overwriting any important data.

NOTE  
This operation does not upload to the CONTROL-M database. To use the changes in 
production, you must still perform an upload.
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By default, you perform write and upload operations separately. However, by 
changing the default setting of the Write before upload (in local workspace) option in 
the General panel of the CONTROL-M/Desktop Options dialog box, you can ensure 
that whenever you perform an upload, a write operation is automatically performed 
first. (This option lets you to perform both a write and an upload using a single 
upload request.) For details, see the option description in Table 30 on page 290.

You can upload a scheduling table from either the scheduling table manager or the 
flow diagram. (If you happen to be Saving and Ordering a job in the job editing form, 
you can also upload the job’s scheduling table as part of the Save and Order request. 
For details, see “Manually scheduling jobs and tables” on page 168.)

To upload scheduling tables to the CONTROL-M database

From one of the following locations, upload the scheduling table to the CONTROL-M 
database:

■ From a workspace (online or local), do the following:

1. If the CONTROL-M hierarchy is not displayed, choose View => Hierarchy => 
Data Center/Scheduling Table/Job.

2. In the flow diagram or navigation tree, right-click the scheduling table node, 
and in the pop-up menu choose Upload. 

3. If you are prompted for confirmation, confirm.

■ From the Scheduling Table manager, do the following:

1. Select the table(s) to be uploaded. 

2. Click . If you are prompted for confirmation, confirm.

CONTROL-M/Desktop uploads the table to the CONTROL-M database. (If you are 
working in a local workspace, and you adjusted the Write before upload (in local 
workspace) option in the General panel of the CONTROL-M/Desktop Options dialog 
box appropriately, CONTROL-M/Desktop automatically writes the table to the 
CONTROL-M/EM database before uploading it to the CONTROL-M database.)

TIP  
If the CONTROL-M database contains a more recent version of the scheduling table you are 
trying to upload, an “Already Updated” error is issued and the upload is prevented. To force 
the upload in this case, click Force Upload.
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Manually scheduling jobs and tables
Ideally, the process of job ordering should be automated at your site (for details, see 
Chapter 14, “Automating job scheduling and maintenance”). However, you can 
manually order or force jobs or scheduling tables from CONTROL-M/Desktop at any 
time. 

To order or force scheduling tables or a job

1 Perform one of the following:

■ To order or force a job, display its job editing form and click Save and Order in 
the toolbar at the top of the form.

■ To order or force scheduling tables from the CONTROL-M/Desktop window, 
do the following:

A. If the CONTROL-M hierarchy is not displayed, choose View => Hierarchy => 
Data Center/Scheduling Table/Job.

B. In the flow diagram or navigation tree, select the scheduling tables, 
right-click the scheduling table icon, and in the pop-up menu choose Order.

C. If you are prompted for confirmation, confirm

■ To order or force scheduling tables from the Scheduling Table manager, do the 
following:

A. Select the tables. 

B. Click . 

C. If you are prompted for confirmation, confirm.

NOTE  
■ When you order or force a table, what you really order (or force) are the jobs in the table.

■ When you manually order or force scheduling tables or a job in CONTROL-M/Desktop, 
the Order/Force dialog box lets you automatically place the tables into the production 
databases (the CONTROL-M/EM database and the CONTROL-M database).

■ You can order or force scheduling tables and jobs from CONTROL-M/EM. However, the 
dialog box and process are different. For details, see “Manually rescheduling jobs in the 
active environment” on page 236.
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The Order/Force Parameters dialog box is displayed. 

Figure 15 Order/Force Parameters dialog box (in CONTROL-M/Desktop)

2 Fill in the Order/Force Parameters dialog box, as follows:

■ If you are ordering (rather than forcing), to specify a different date than ODAT 
(the default), click the button by the date selection field and select the date.

■ To place the table into the CONTROL-M database before ordering, click Upload 
Table before ordering. 

NOTE  
If you are ordering a table under CONTROL-M for z/OS version 6.2.00 or later, to 
ensure that the jobs do not run before the Odate, check the Wait for Odate to run 
check-box. (If this box is not checked, the job runs as soon as its execution criteria are 
satisfied.) 

TIP  
■ If you are working in the CONTROL-M/EM database (that is, in Online mode or the 

Scheduling table manager), you should update the CONTROL-M/EM database by 
performing a Save before you perform an upload.

■ If you are working in local mode, when you request an Upload, CONTROL-M/EM 
automatically writes the table to the CONTROL-M/EM database before performing 
the upload (default). This makes it unnecessary for you to manually perform the 
Write.
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■ To force the table, click Force (Ignore scheduling criteria).

■ To order or force a job so that it is automatically put on hold as soon as it starts 
to run, click Order/Force with Hold. This enables you to customize an individual 
run of a job using AutoEdit variables. (This feature is available only for versions 
6.2.01 and later of CONTROL-M.)

3 Click Order, which displays the progress of the order or force action in the Table 
Action Report.

4 Click Close at any time to close the Table Action Report. 

The table is first written to the CONTROL-M/EM database, and then uploaded to the 
CONTROL-M/Server. It is then ordered (if its scheduling criteria are satisfied) or 
forced into the active environment.

Downloading tables from CONTROL-M to 
CONTROL-M/EM

It is usually not necessary to download tables from CONTROL-M to 
CONTROL-M/EM, because a table in CONTROL-M is not normally more current 
than the same table in CONTROL-M/EM. Nevertheless, there might be instances 
when you want to perform a download. For example, if someone incorrectly 
modified the table and wrote the changes to CONTROL-M/EM, you might want to 
overwrite the incorrect CONTROL-M/EM version with the version from 
CONTROL-M.

To download scheduling tables from CONTROL-M to CONTROL-M/EM

Download the scheduling table from one of the following locations:

■ In the CONTROL-M/Desktop window, do the following:

WARNING  
If you modified the job or table but did not upload the changes, the version of the tables 
and jobs currently residing in the CONTROL-M database will be ordered or forced. In 
this case

■ the modifications are not reflected in the job order

■ if you saved the modifications in Online mode, the CONTROL-M/EM database and 
CONTROL-M database will not be synchronized; an error message will be issued 
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1. If the CONTROL-M hierarchy is not displayed, choose View => Hierarchy => 
Data Center/Scheduling Table/Job. 

2. In the flow diagram or navigation tree, right-click the scheduling table icon, and 
in the pop-up menu choose Download. 

3. If you are prompted for confirmation, confirm.

■ From the Scheduling Table manager, do the following:

1. Select the tables to be downloaded. 

2. Click  (Download). 

3. If you are prompted for confirmation, confirm.

TIP  
To download a scheduling table that is not displayed in the Scheduling Table Manager 
window, create the scheduling table and then download the scheduling table normally.
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C h a p t e r 14
14  Automating job scheduling and 
maintenance

This chapter presents the following topic: 

Identifying automation criteria for scheduling tables  . . . . . . . . . . . . . . . . . . . . . . . . .  174

After job processing definitions have been defined for your production jobs, you can 
automate daily job ordering (and daily maintenance) through a feature called New 
Day processing. At the same (site-defined) time each day (called New Day time), 
CONTROL-M automatically runs a procedure called the New Day procedure. A site 
can set the same or a different New Day time for each CONTROL-M. 

The New Day procedure contains instructions for running a number of maintenance 
and cleanup utilities that, among other things, archive the previous day’s processing, 
and remove the previous day’s jobs and conditions. 

The New Day procedure is also responsible for placing jobs that should be ordered 
that day into a file called the Active jobs file. CONTROL-M automatically submits 
jobs in the Active jobs file when their submission criteria are satisfied.

■ The New Day procedure can directly order jobs that need scheduling to the Active 
Jobs file (a method sometimes suitable for small data centers).

■ The New Day procedure can order special jobs called User Daily jobs, which, in 
turn, order jobs that need scheduling (a method more suited for large data centers). 
Each User Daily job scans scheduling tables specifically assigned to it, looking for 
jobs that should be scheduled that day, and orders them to the Active jobs file.

Scheduling groups are ordered only if the scheduling criteria of at least one Schedule 
Tag in the table is satisfied. Whether individual jobs in the group scheduling table are 
ordered depends on the Relationship parameter and on the values of job-specific 
basic scheduling parameters.
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For instructions on defining the New Day procedure and User Daily jobs, see the 
CONTROL-M Administrator Guide for the particular CONTROL-M platform.

Identifying automation criteria for scheduling 
tables

For a scheduling table to be automatically ordered during New Day Processing, it 
must be assigned to the New Day procedure or a User Daily job. 

To assign or reassign a scheduling table to the New Day procedure or a User 
Daily job

1 If the Scheduling Table Manager window is not already displayed, display it by 
choosing Tools => Scheduling Table Manager in CONTROL-M/Desktop. To filter 
the list of tables, use the fields at the top of the Scheduling Table Manager.

2 In the Scheduling Table Manager, select the scheduling table and click  (Table 
Details).

3 Edit the User daily field as follows (you must have authorization):

■ If the scheduling table should be ordered by a specific User Daily job, specify 
the name of the job (1-10 characters, case sensitive).

■ If the scheduling table should be ordered by the New Day procedure, specify 
the value SYSTEM (uppercase only).

4 Click OK to save the changes in the CONTROL-M/EM database.

5 To upload the changes to the CONTROL-M, select the table in the Scheduling 
Table Manager and click .

WARNING  
If you modify a table associated in CONTROL-M with more than one User daily and then 
upload it to CONTROL-M, the table is removed from all User Dailies except the one it is 
associated with it in CONTROL-M/EM.
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C h a p t e r 15
15  Identifying data center resources 
available for CONTROL-M use
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Defining quantitative resources . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  179

Introduction
To ensure CONTROL-M does not submit a job unless all resources that the job 
requires are available, CONTROL-M provides a feature for specifying resource 
requirements. Resources are logical constructs that can be of one of the following 
types:

■ Control resources — these are resource requirements generally characterized by 
the control that a job needs over them: exclusive or shared. Data information 
resources, such as files, tables, and databases, are frequently control resources. 

■ Quantitative resources — these are resources requirements that are generally 
quantified. Physical resources, such an quantity of memory, percentage of CPU, 
megabytes of storage, or number of tape drives, are frequently quantitative 
resources.

The success of this feature requires that the following be specified for each resource:

■ The resource must be associated with a specific CONTROL-M that tracks the 
availability of the resource in the data center. This chapter describes how you 
perform this task in CONTROL-M/EM. 
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■ You must specify the resource usage requirement in the job processing definition 
of the job requiring the resource. You perform this task in CONTROL-M/Desktop. 
For details, see “Allocating resources for a job” on page 83.

The following example illustrates control resource usage.

The following example illustrates quantitative resource usage.

Filtering resources on startup
You can filter resources on startup before they are loaded from the database. This is 
recommended when working with a large amount of resources. In the status bar you 
can view the filter criteria.

EXAMPLE  
A job called DeductCharges requires exclusive control of a file called AcctBalance. To enable 
CONTROL-M to handle this correctly, do the following:

■ In the job processing definition of DeductCharges, specify exclusive control of a control 
resource called AcctBalance.

■ Using the Control Resources dialog box in CONTROL-M/EM, allocate the control 
resource, AcctBalance, to CONTROL-M.

CONTROL-M will only submit DeductCharges if AcctBalance is not being used by another 
job. If another job also requires AcctBalance, it will not be submitted as long as 
DeductCharges is running.

EXAMPLE  
CONTROL-M has three tape drives available. A job called BKP_Tallies requires one tape 
drive. To enable CONTROL-M to handle this correctly, do the following:

■ In the job processing definition of job BKP_Tallies, specify that the quantity, 1, of a 
quantitative resource, TapeDr, is required.

■ Using the Quantitative Resources dialog box in CONTROL-M/EM, define a quantitative 
resource, TapeDr, having a total quantity of 3, to CONTROL-M.

Whenever a job using TapeDr is submitted, CONTROL-M drops the currently available 
quantity of the resource by the quantity the job uses, until the job ends. CONTROL-M will 
only submit BKP_Tallies if there is at least one TapeDr available.
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To filter resources on startup:

1 Choose Options=> Show ‘Refresh Filter’ on startup.

2 In the Refresh Filter dialog box, fill in the data that defines the resource and click 
OK.

To change the filter:

1 Choose View=>Refresh Filter.

2 In the Refresh Filter dialog box, fill in the data that defines the resource and click 
OK.

Allocating control resources
You allocate, release, and view control resources in your production environment 
using the Control Resources window. 

To allocate or release a control resource

1 In the CONTROL-M/EM GUI, choose Tools => Control Resources, which displays 
the Control Resources window.

2 In the Control Resources window, do the following as needed:

■ To quickly filter, choose View => Filter Row, and enter the filter criteria.

■ To filter the displayed data, click on the right top corner of a column header and 
select the appropriate filtering option.

■ To create an advanced filter, right-click on any column header and choose Filter 
Editor. Use the Filter Builder to enter the appropriate filtering criteria and the 
relationships between them.

NOTE  
You can filter resources on startup before they are loaded from the database. This is 
recommended when working with a large amount of resources. For more information on 
filtering resources on startup, see “Filtering resources on startup” on page 176.
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The following information is useful for understanding the filtering criteria:

— Type — Types of control:

■ Exclusive — resources “owned” exclusively by one job
■ Shared — resources shared by a number of jobs
■ Requested — resources requested by a critical job (a Requested entry exists for 

each job that requests the resource needed by a critical job)

— RBA — (For z/OS only) Relative Byte Address, a unique identifier.

— Priority — it contains the priority (indicated by one character, 0-9/A-Z) of the 
critical path job waiting for exclusive control of the resource. The field only 
appears in entries of critical path jobs waiting for a resource. In all other 
entries the field is blank.

— Counter —indicates the number of jobs currently using the resource. (This 
value is not relevant for requested resources. The value is always 1 for 
exclusive resources.)

3 To allocate a control resource do the following:

A In the Control Resources window, choose Actions => Add.

B In the displayed Control Resource dialog box, fill in the data to associate the 
control resource with a CONTROL-M data center, specify the type of control, 
and click OK. 

4 To release a control resource, select it and choose Actions => Delete.

Viewing the list of jobs and tables that use a control resource

You can view a list of jobs and scheduling groups for which a selected control 
resource is specified. This list might help identify potential sources of resource 
contention. For example, if too many jobs require exclusive control of a resource, you 
might want to see if it is possible to give some of the jobs shared control. 

NOTE  
You can delete a Shared control resource only if

■ no jobs “own” the resource, that is, the Counter field is 0 for all resource table entries 
for the resource

■ no jobs are requesting the resource, that is, there are no table entries for this resource 
with a Requested resource type
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Because the list of control resources only displays resources in use at the time of the 
last update, only jobs and tables that use those resources are in the list. From the 
displayed list of jobs, you can display a job in the job editing form.

To view the job list for a resource

1 If the Control Resources window is not displayed, choose Tools => Control 
Resources in the CONTROL-M/EM GUI, and set the filtering criteria in the Control 
Resources window (see “To allocate or release a control resource” for details).

2 In the Control Resources window, select the resource and click View Jobs, which 
displays the View Jobs dialog box.

3 To edit a job (or scheduling group) in the list (optional), double-click the job, which 
displays the job editing form or group editing form for the selected item. 

Defining quantitative resources
You create, delete, and view quantitative resources in your production environment 
by using the Quantitative Resources window.

To create or delete a quantitative resource

1 In the CONTROL-M/EM GUI, choose Tools => Quantitative Resources, which 
displays the Quantitative Resources window. 

2 In the Quantitative Resources window, do the following as needed:

■ To quickly filter, choose View => Filter Row, and enter the filter criteria.

■ To filter the displayed data, click on the right top corner of a column header and 
select the appropriate filtering option.

NOTE  
If you do not have authorization to view job details, the job or group editing form is not 
displayed; only the RBA value is displayed.

NOTE  
You can filter resources on startup before they are loaded from the database. This is 
recommended when working with a large amount of resources. For more information on 
filtering resources on startup, see “Filtering resources on startup” on page 176.
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■ To create an advanced filter, right-click on any column header and choose Filter 
Editor. Use the Filter Builder to enter the appropriate filtering criteria and the 
relationships between them.

The following information is useful for understanding the filtering criteria:

— Type — type of quantitative resource entries to display:

■ Defined— displays all defined resources. General information about the 
resource. Only one definition entity exists per resource. This entity is added 
by the user to define a new quantitative resource.

■ In Use —displays only resources being used by a job (an In Use flag exists for 
each CONTROL-M job that is currently using the resource).

■ Required —displays only resources requested by a critical job (a 
Required flag exists for each critical job that requests the resource).

— Resource — note that quantitative resources used for load balancing have the 
resource_name@node_ID name format. In this format, node_ID specifies the 
Agent platform on which the resource is located. If a critical job to be 
submitted by the load balancing mechanism is waiting for available 
resources, the required resources are displayed in this window using the 
resource_name@ format.)

— Quantity — for an entry whose type is Defined, this column indicates the 
number of units of the resource that are currently available. For In Use and 
Required entries, this column indicates the number of units of the resource 
currently used by the job specified by its RBA.

— Maximum —for an entry whose type is Defined, this column indicates the 
maximum quantity of the resource existing in the CONTROL-M installation. 
For In Use and Required entries, the value in this column is 0.

— Priority — for an entry whose type is Defined, this field is not applicable. For 
entries with a type of In Use or Required, Y or N indicates whether the job 
identified in RBA is critical.

— RBA — (for z/OS only) this field displays the Relative Byte Address, a 
unique identifier. For an entry whose type is Defined or Required, RBA is not 
applicable. For In Use entries, this column contains the RBA of the z/OS job 
using the resource.
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3 To create a quantitative resource

A In the Quantitative Resources window, choose Actions => Add.

B In the displayed Quantitative Resource dialog box, fill in the data that defines 
the quantitative resource.

C Click OK.

4 To delete a quantitative resource, select it and choose Actions => Delete.

NOTE  
You can delete a quantitative resource only if

■ no jobs “own” the resource, that is, the Counter field is 0 for all resource table entries 
for the resource

■ no jobs are requesting the resource, that is, there are no table entries for this resource 
with a Requested resource type
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C h a p t e r 16
16  Establishing job dependencies 
across CONTROL-Ms

This chapter presents the following topics:

Defining global conditions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  183
Deleting global conditions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  185
Global condition logic and examples  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  186
Best practices. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  188

Frequent updates to a global condition (toggles) . . . . . . . . . . . . . . . . . . . . . . . . . .  188
Bi-directional global conditions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  188

Normally, prerequisite conditions used to establish job dependencies are local — that 
is, they apply only on the particular CONTROL-M in which they are defined. This 
chapter explains how you can define global prerequisite conditions to establish job 
dependencies across different CONTROL-Ms. You establish these dependencies by 
defining condition name prefixes that will indicate that a condition is global.

Defining global conditions
Global conditions are special case prerequisite conditions that create dependencies 
between jobs running on different CONTROL-M servers. (For example, you can 
specify that jobs in CONTROL-M servers in Rome and Paris begin executing only 
after successful completion of a job in Sydney.) 

Global conditions are like normal prerequisite conditions except that their names 
begins with a prefix that identifies the condition as a global condition. When you 
define global conditions, what you actually define are the following:

■ prefixes (up to 255 characters long) that indicate that a condition is a global 
condition 
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■ From and To CONTROL-M servers for which the global condition prefix is relevant 

When CONTROL-M/EM detects the addition or deletion of a global condition in a 
From CONTROL-M, it automatically adds or deletes the same global condition in 
the designated To CONTROL-M installations.

You define and manage global conditions in the Global Conditions dialog box, which 
you display from either CONTROL-M/Desktop or CONTROL-M/EM. After a global 
condition is defined, you can handle it (for example, view or delete it) like a 
non-global prerequisite condition, from the Prerequisite Conditions dialog box.

To define and manage global conditions, you need appropriate security permissions.

To create or modify a global condition definition

1 In CONTROL-M/EM or CONTROL-M/Desktop, choose Tools => Global 
Conditions, which opens the Global Conditions dialog box. 

2 To refresh the display, click Refresh. 

3 To filter the display, click the Filter check-box, fill in the filtering criteria in the 
fields at the top of the dialog box, and click Apply. 

4 To add (or modify) a global condition definition, do the following steps:

A Click New (or select the condition and click Update).

B In the displayed Add New Global Condition dialog box, fill in or modify the 
definition, as follows:

■ Specify the global condition prefix.
■ Specify the From and To CONTROL-Ms for which the global prefix will apply 

by selecting the CONTROL-Ms and clicking Add or Remove.

TIP  
By appropriately designating the same CONTROL-M installations as both From and To 
CONTROL-Ms, you can create “bi-directional” flows (as opposed to From/To flows). In this 
case, addition or deletion of a global condition in any such installation will always result in 
the automatic addition or deletion of the global condition in the opposite direction. For Best 
Practices implementation tips, see “Bi-directional global conditions” on page 188.
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If your site is planning on adding a new CONTROL-M installation, you can add 
that CONTROL-M to global condition definitions even though it is not yet 
functional and does not yet appear in the CONTROL-M selection lists.

C To add an anticipated CONTROL-M installation to a global condition definition, 
do the following:

■ Click Add New CONTROL-M in the From or To area. 

■ In the New CONTROL-M Name dialog box, enter the name of the new 
CONTROL-M and click OK.

D Click OK.

Deleting global conditions
Select the condition in the Global Conditions dialog box, and click Delete. 

WARNING  
■ When filling in the Prefix text box, be careful about specifying special characters, 

such as asterisks, as prefix indicator. Special characters in this field are treated as 
text characters, not wildcards, and unless you intend them as literals, they might 
cause undesired results. For example, if you specify glo* instead of glo as a global 
prefix, glo*-job1_started will be a global condition, but not glo-job1_started.

■ Even truncated strings of the global condition prefixes must be unique or 
unpredictable results might occur. For example, do not define both a DA prefix and 
a DAY prefix because DA is a substring of DAY and therefore not unique.

NOTE  
■ Changes made using the Global Conditions dialog box (for example, defining a new 

prefix) only affect conditions that are created or deleted after the change was saved. 

■ Although you can create any combination of global condition prefixes, BMC Software 
recommends that you

— limit the global condition prefixes to very specific, less general prefixes that do not 
match large numbers of conditions.

— refrain from defining prefixes that encompass a large number of CONTROL-Ms in the 
From and To fields.

The more general the prefix, the more stress is added to the system. This can slow down 
other requests and data transmissions. For more information about implementing global 
conditions efficiently, see “Best practices” on page 188.
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Global condition logic and examples
When sending a global condition with an ODAT date reference to CONTROL-Ms in 
different time zones, a problem can arise when target CONTROL-M installations 
have an earlier current working date than the source CONTROL-M (as a result of the 
time zone changes). Such a situation can be problematic due to the following:

■ A global condition with ODAT as its date reference is assigned a date according to 
the CONTROL-M that triggers its creation. 

■ During New Day processing cleanup, when CONTROL-M detects an already 
existing condition having the new working date (month and day), it logically 
assumes that the condition is a holdover from the previous year because the 
production jobs that might create this condition during the new working date have 
not yet been run, and it deletes the condition. 

In the event of a temporary communication failure between CONTROL-M/EM and a 
CONTROL-M installation, global conditions are accumulated and transmitted when 
communication is resumed.

Examples

The following examples illustrate how global conditions behave in a complex 
CONTROL-M network. They are based on information the following table.

EXAMPLE  
Assume the following:

■ New day processing in both Rome and San Francisco runs at 6:00 AM local time.
■ At 8:00 AM in Rome, a job creates Global Condition: Glo1-RecReady with an ODAT date 

and sends it to San Francisco.
■ At 9:00 AM in San Francisco, a job requiring that condition awaits submission.

The following occurs at new day in Rome on August 4th.

■ August 4th at 6:00 AM in Rome — new day processing runs.

■ August 4th at 8:00 AM in Rome — Global condition Glo1-RecReady is added with the date 
0804. This global condition is then sent to San Francisco with a date of 0804 (the date the 
condition was created). However, the current working date and time in San Francisco 
when it receives the global condition is August 3rd, 23:00.

■ August 4th 6:00 AM in San Francisco — New Day processing runs. During maintenance, it 
assumes that the Glo1-RecReady condition dated 0804 was added last year (because jobs 
that might have added the condition today did not run yet), and it deletes the condition.

■ August 4th at 9:00 AM in San Francisco— a job in San Francisco waiting for the condition 
Glo1-RecReady dated 0804 is not submitted because the condition is already deleted.
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■ If the GL1_JOB_END prerequisite condition is added in CONTROL-M ROME, the 
same condition is automatically added in CONTROL-M installations NY, LA, and 
SF. The Prerequisite Conditions window displays four different conditions called 
GL1_JOB_END, each belonging to a different CONTROL-M (ROME, NY, LA, and SF).

■ However, if this condition is added in any CONTROL-M other than ROME, it is 
not automatically duplicated in other CONTROL-M installations. If CONTROL-M 
NY adds the condition GL1_JOB_END, it will not be automatically added in 
ROME (or anywhere else).

■ If the GL1_JOB_END prerequisite condition is deleted in CONTROL-M ROME, 
CONTROL-M/EM deletes the GL1_JOB_END prerequisite condition in 
CONTROL-M installations NY, LA, and SF (if the condition exists there).

■ If the GL1_JOB_END prerequisite condition is created in CONTROL-M ROME but 
CONTROL-M SF is disconnected or downloading, CONTROL-M/EM creates this 
condition in NY and LA only, and sends the change to SF when SF is able to 
receive updates.

■ If the GLALL_OK prerequisite condition is added or deleted in any CONTROL-M, 
the condition is automatically added or deleted in CONTROL-M installations 
PARIS and SYDNEY. The asterisk (*) in the From CONTROL-M field indicates all 
CONTROL-M installations.

■ If the GLNY_OK prerequisite condition is added or deleted in CONTROL-M NY, 
the condition is automatically added or deleted in all other CONTROL-M 
installations.

■ If a prerequisite condition beginning with the GL2WAY prefix is added or deleted 
in either CONTROL-M HQ or CENTER1, the same operation is performed on the 
corresponding condition in the other CONTROL-M.

Prefix From CONTROL-Ms To CONTROL-Ms

GL1 ROME NY,LA,SF

GLALL * PARIS,SYDNEY

GLNY NY *

GL2WAY HQ,CENTER1 HQ,CENTER1
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Best practices
This section provides recommendations for implementing global conditions between 
different CONTROL-M installations. 

Frequent updates to a global condition (toggles)

If the status of a global condition frequently changes (is added and deleted) within a 
short period of time, the Global Conditions server might become overloaded and the 
global conditions might not be distributed correctly. 

To prevent this problem, find a balance for Global Conditions server processing by 
setting appropriate values using Global Conditions Server Parameters options from 
the root menu. These parameters define how the Global Conditions server should 
handle frequent updates to global conditions. For details, see the following menu 
options in the CONTROL-M Administrator Guide:

■ Delete Time For Sent Conditions
■ Method for Handling Conflicting Conditions
■ The Mode for Handling Conflicting Conditions

Bi-directional global conditions

Global conditions can be “bi-directional,” meaning that if a global condition is added 
or deleted in one of several CONTROL-M installations, it is automatically added to or 
deleted from the others.

However, the definition of bi-directional global conditions generates additional 
overhead and puts additional stress on system processing, particularly in the Global 
Conditions server. This can slow down other requests and data transmissions. For 
this reason, BMC Software recommends that you avoid implementing bi-directional 
global conditions.

You can achieve the benefits of bi-directional global conditions using regular, 
one-way global conditions. This more efficient alternative involves

■ definition of additional “dummy” jobs for maintaining (adding and deleting) 
global conditions

■ definition of two global condition prefixes (instead of one), each representing a 
direction between the CONTROL-M installations
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■ definition of two extra “dummy” global conditions for triggering the maintenance 
functions performed by the two “dummy” jobs

A sample implementation is provided below, first using bi-directional global 
conditions and then by simulating the use of bi-directional global conditions.

Sample scenario

A set of jobs can only run if the company’s intranet is up and running at all sites. 
Therefore, all sites (CONTROL-M installations) have cyclic jobs that, at regular 
intervals, check intranet status and update the status using global conditions. If a 
particular intranet site in the company is down, a job deletes the global conditions 
that indicate that the intranet is up and running.

In this scenario, the company has two sites:

■ one CONTROL-M installation exists in Seattle
■ another exists in London

In Seattle, a job called CheckS checks and updates conditions starting with the 
Intranet prefix (such as IntranetS-Up and IntranetL-Up). In London, a job named 
CheckL performs the same function. Addition and deletion of conditions with the 
Intranet prefix in either location should always occur in both locations.

Using bi-directional global conditions (not recommended)

The following representation of the Global Conditions window illustrates a basic and 
intuitive way to define bi-directional global conditions. 

This definition specifies that addition and deletion of a condition that begins with the 
characters Intranet in either the Seattle or London site automatically generates the 
same update at the other site. This is a valid definition for bi-directional global 
conditions, but is not efficient.

Prefix From CONTROL-Ms To CONTROL-Ms

Intranet Seattle, London London, Seattle
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Using regular global conditions (recommended)

For more efficient distribution and processing of global conditions, define jobs and 
global condition prefixes as follows.

The setup

In this scenario, you would create the following job processing definitions:

Define the following job global condition prefixes:

Processing flow: an overview

The following figure provides an overview of the processing flow of jobs defined 
when implementing the recommended practice for simulating bi-directional global 
conditions. Each phase in the processing flow is numbered and described in detail 
under “Processing flow: step-by-step” on page 191.

Jobs Purpose

CheckS In Seattle, this job checks intranet status and updates global conditions 
starting with the prefixes defined below. 

This job updates two global conditions (instead of one, Intranet, as was done 
in the sample above) with each global condition representing one direction. 
CheckS updates conditions with an West2East prefix. Updates to these 
conditions are passed towards the East to London.

CheckL In London, checks intranet status and updates global conditions starting with 
the prefixes defined below.

This job updates two global conditions (instead of one, Intranet, as was done 
in the sample above) with each global condition representing one direction. 
CheckL updates conditions with an East2West prefix. Updates to these 
conditions are passed towards the West to Seattle.

MaintainS “Dummy” job processing definition in Seattle for removing global conditions 
that are no longer necessary; serves administrative and maintenance purposes 
only. MaintainS tracks, and deletes, unnecessary conditions by updating 
“dummy” global conditions.

MaintainL “Dummy” job processing definition in London for removing global conditions 
that are no longer necessary; serves administrative and maintenance purposes 
only. MaintainL tracks, and deletes, unnecessary conditions by updating 
“dummy” global conditions.

Prefix From CONTROL-Ms To CONTROL-Ms

East2West Seattle London

West2East London Seattle
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Processing flow: step-by-step

1 The CheckS cyclic job in Seattle runs when the East2West-Maint global condition 
is created (the first time, manually). 

This job

— checks intranet status
— creates a global condition named West2East-Check 

The Global Conditions server passes this condition to London.
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2 The CheckL job is triggered by the creation of the West2East-Check In condition.

This job

— checks intranet status
— creates the East2West-Check condition
— deletes the West2East-Check condition locally (meaning, at the local 

CONTROL-M installation only), because West2East is a one-way prefix

3 The MaintS job, which waited for the creation of its East2West-Check In 
condition, runs and

— creates the West2East-Maint condition
— deletes the East2West-Check condition locally
— deletes the West2East-Check condition in both Seattle and London 

Because this condition was already deleted by CheckL in London, processing is 
minimal.



Bi-directional global conditions

Chapter 16    Establishing job dependencies across CONTROL-Ms 193

4 The MaintL job, which waited for the creation of its West2East-Maint In condition, 
runs and

— adds the East2West-Maint condition, which will trigger the CheckS job in 
Seattle

— deletes the West2East-Maint condition locally
— deletes the East2West-Check condition in both Seattle and London

Again, because this condition was already deleted in Seattle, processing is 
minimal.

5 The cycle begins again. The CheckS job is again triggered by its In condition, 
East2West-Maint (this time, not manually). 

When the CheckS job runs, it

— checks intranet status
— recreates the West2East-Check condition, which will trigger the CheckL job in 

London
— deletes the East2West-Maint condition locally
— deletes the West2East-Maint condition in both Seattle and London, with 

minimal effect on processing
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6 The CheckL job is again triggered by its West2East-Check In condition, and the 
cycle continues. 

When the CheckL job runs, it

— checks intranet status
— recreates the East2West-Check condition.
— deletes the West2East-Check condition locally
— deletes the East2West-Maint condition in both Seattle and London, with 

minimal effect on processing

7 The cycle is repeated beginning with Step 3 on page 192.
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4Part

Part 4Monitoring and intervening in 
production

This part presents the following topics:

Chapter 17
Introduction to monitoring and intervention . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 197

Chapter 18
Ensuring CONTROL-M components are communicating . . . . . . . . . . . . . . . . . . . 199

Chapter 19
Selecting jobs to monitor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 203

Chapter 20
Monitoring and handling alerts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 215

Chapter 21
Monitoring and intervening in production . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 221

Chapter 22
Monitoring business-critical batch services using BMC Batch Impact Manager. 243
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C h a p t e r 17
17  Introduction to monitoring and 
intervention

This chapter presents the following topics: 

Monitoring and intervening in production . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  197
Where to go from here. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  197

Monitoring and intervening in production
After you have implemented job scheduling under CONTROL-M, your next task is to 
ensure that CONTROL-M is up and running, and that jobs are processing as required. 
Ideally, no intervention should be required, but if intervention becomes necessary, 
you want to know about it. Because of the sheer number of jobs running in your 
production environment, you will want to manage the environment by exception; 
that is, focus on and monitor special critical processes, and potentially problematic 
situations indicated by user complaints or error messages. 

The information provided in this part of the book enables you to perform critical user 
tasks — monitoring the processing of the jobs in your production environment and 
intervening and handling problems and issues as necessary.

Where to go from here

NOTE  
These guidelines assume that you are already familiar with the information in Part 1 of this 
book. If you are not, review the instructions for starting and navigating in CONTROL-M/EM 
in Chapter 2, “Working with CONTROL-M/Desktop and CONTROL-M/EM” before 
continuing with this part of the book.
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Monitoring the production environment and handling or intervening in problems is 
the subject of the chapters in this part of the book. After familiarizing yourself with 
the preceding material in this introductory chapter, review the following list, and 
after you have reviewed this list, proceed to the appropriate chapters. 

■ To check if CONTROL-M is up and that communication exists between 
components, see Chapter 18, “Ensuring CONTROL-M components are 
communicating.”

■ To select or filter the jobs that you want to monitor, see Chapter 19, “Selecting jobs 
to monitor.”

■ To check or handle alerts, see Chapter 20, “Monitoring and handling alerts.” An 
alert is a message indicating that a problem or exception has occurred for a job. 
Alerts are sent to the Alerts window.

■ To check job status summaries and job status details, and perform other 
monitoring function see “Monitoring” on page 221 (in Chapter 21, “Monitoring 
and intervening in production”).

■ To perform bypasses or immediate fixes, see “Intervening” on page 228 (in 
Chapter 21, “Monitoring and intervening in production”).

■ To handle batch service management problems, see Chapter 22, “Monitoring 
business-critical batch services using BMC Batch Impact Manager.”

■ To perform root cause analysis or other analyses in the production environment, 
see the introductory chapter to Part 5 of this book (Chapter 23, “Introduction to 
analyzing and optimizing production”).
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C h a p t e r 18
18  Ensuring CONTROL-M components 
are communicating

This chapter presents the following topics:

Communicating with the GUI Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  199
Automatically reconnecting to the GUI Server . . . . . . . . . . . . . . . . . . . . . . . . . . . .  199
Manually intervening in the reconnection process  . . . . . . . . . . . . . . . . . . . . . . . .  200

Communicating with CONTROL-M/Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  200

This chapter describes how to view the communication status between 
CONTROL-M/EM components and CONTROL-M installations. It also includes 
instructions for maintaining this communication. 

Communicating with the GUI Server
CONTROL-M/EM must be constantly connected to the GUI Server. The GUI Server 
handles communication between each CONTROL-M/EM GUI and other 
CONTROL-M/EM components.

Automatically reconnecting to the GUI Server

As part of CONTROL-M/EM customization (using Tools => Options), you normally 
designate alternative GUI servers in case of GUI Server failure. 

If the connection to the GUI Server fails, CONTROL-M/EM displays the 
CONTROL-M/Enterprise Manager — Reconnect dialog box, and attempts to 
reestablish connection with an alternate server, beginning with the first designated 
alternate server. (Depending on site defaults, you might first be prompted to click 
Connect.) 
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The CONTROL-M/EM — Reconnect dialog box indicates reconnection progress:

■ If reconnect with an alternate server is successful, the CONTROL-M/EM GUI 
continues to function, restoring ViewPoints as desired. The CONTROL-M/EM 
GUI – Reconnect dialog box closes and a message in the status bar indicates that a 
communication problem was resolved. 

■ If CONTROL-M/EM cannot establish a connection with any of the alternate 
servers, it attempts reconnection with the servers at regular (user-defined) 
intervals, until the maximum number of allowed retries has been attempted. If a 
connection still cannot be established, CONTROL-M/EM displays a message 
notifying you that it is about to shut down.

Manually intervening in the reconnection process

When the CONTROL-M/Enterprise Manager GUI – Reconnect dialog box is 
displayed, you can

■ stop the reconnection process (for example if you are terminating 
CONTROL-M/EM), by clicking Stop

■ close the dialog box and terminate CONTROL-M/EM, by clicking Exit Application

■ display more reconnection process details and options, by clicking Advanced

In the advanced display (that is, if you clicked Advanced), to redefine the 
customization options, first click Stop, then click Settings. This displays the 
appropriate Options panel for redefining the settings.

Communicating with CONTROL-M/Servers
CONTROL-M/Enterprise Manager (CONTROL-M/EM) depends on a constant flow 
of information from CONTROL-M/Servers to present you with an up-to-date picture 
of the status of jobs. Operator requests and global conditions are transmitted back 
and forth between CONTROL-M/EM and the CONTROL-M server.

The Communication Status dialog box displays the status of communication between 
each CONTROL-M/Server and the CONTROL-M/EM workstation. 

NOTE  
This information is intended for the typical CONTROL-M/EM user. If more complicated 
communication issues arise, contact your CONTROL-M/EM administrator.
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To display the status of communications

In CONTROL-M/EM, choose Tools => Communication => Status.

The Communication Status dialog box opens and displays the status of 
communications. CONTROL-M/EM refreshes the display every two minutes, but 
you can manually refresh the display at any time.

Each component in the communication path is represented graphically in the 
Communication Status dialog box, as described in Table 20. 

■ If a symbol is green, the relevant component is active.
■ If a symbol is red, the relevant component is inactive.

Table 20 Communication Status dialog box fields and symbols (part 1 of 2)

Field Icon or Value and Description

CONTROL-M 
name

Each CONTROL-M/Server has a color-coded indicator:
■ A green check indicates that the CONTROL-M is 

enabled.
■ A Red X indicates that the CONTROL-M is disabled. 

When the gateway is restarted, CONTROL-M/EM 
attempts to communicate with the CONTROL-M.

Gateway CONTROL-M/EM gateway connection to the 
CONTROL-M.

Communication Communication route between the gateway and the 
CONTROL-M.

Synchronization Synchronization of the active environment with the Active 
Jobs file in the CONTROL-M. If red, CONTROL-M/EM is 
not synchronized with the CONTROL-M.

Network Status Status of communication between the CONTROL-M/EM workstation 
and the CONTROL-M. The following statuses can appear in this field:

Up The CONTROL-M is connected and available. (Note: Data 
displayed in the CONTROL-M/EM ViewPoint might not 
necessarily be synchronized with data in the CONTROL-M 
Active Jobs file.)

Reconnecting The workstation is trying to reconnect to the 
CONTROL-M.

Initial The Active environment is not yet loaded. The workstation 
is trying to connect to the CONTROL-M.

Formatting 
AJF

The Active Jobs file cannot be accessed because either the 
New Day procedure or Active Jobs File Compress 
procedure is in progress at the CONTROL-M.

Downloading The workstation is receiving a download from the 
CONTROL-M.

Last Update Time the last message was sent from a CONTROL-M. This field is 
displayed in 24-hour clock format.
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To display communication and other information about CONTROL-Ms

In CONTROL-M/EM or CONTROL-M/Desktop, choose Tools => Communication => 
Details.

The CONTROL-M Details dialog box opens and displays data about each 
CONTROL-M, including status information. CONTROL-M/EM refreshes the display 
every two minutes, but you can manually refresh the display at any time. You can 
also filter the display. However, you cannot update the data. (An updatable version 
called the Communication Administration dialog box is available in the 
CONTROL-M Configuration Manager facility. For details, see the CONTROL-M 
Administrator Guide.)

Remarks If the Synchronization symbol is not green, this field displays the reason. 
For example, one possible reasons is

Loading Jobs The CONTROL-M/EM Server is loading jobs from the 
CONTROL-M/Server database.

Table 20 Communication Status dialog box fields and symbols (part 2 of 2)

Field Icon or Value and Description
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C h a p t e r 19
19  Selecting jobs to monitor

This chapter presents the following topics:

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  204
Selecting a ViewPoint  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  204

Displaying nodes in their own ViewPoint. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  205
Filtering the ViewPoint display . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  205

Switching filters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  205
Defining dynamic filters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  206
Defining global filters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  208

Defining ViewPoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  210
Defining the set of jobs to load to memory (collections) . . . . . . . . . . . . . . . . . . . .  211
Defining the display hierarchy  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  212
Alternative method for defining ViewPoints — the ViewPoint wizard . . . . . . .  213
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Introduction
Job processing problems are the exception, not the rule, and it is the exceptions that 
you want to monitor. By limiting the active environment jobs that you load and 
display in the CONTROL-M/Enterprise Manager window to those jobs that appear 
problematic, you simplify job monitoring and significantly reduce processing 
overhead. The mechanisms described in this chapter provide this functionality:

■ ViewPoints — a ViewPoint consists of a number of referenced subcomponents 
whose combined criteria determine which jobs will be selected and loaded into 
memory, how the jobs will be filtered, and the hierarchy that will be used to 
display those jobs. ViewPoints consist of the following subcomponents:

— Collection — selects which jobs are loaded from the active environment into 
memory, based on parameter values in the job processing definition. Reducing 
the number of jobs loaded to memory decreases system overhead and clutter.

— Global Filter — determines which loaded jobs are displayed in the ViewPoint. 
Filtering can be very useful for managing by exception. For example, you can 
filter to display only those jobs that ended Not OK and jobs in a Wait status. 
Though they do not reduce system overhead, filters do reduce screen clutter, 
enabling you to focus on jobs that really require monitoring. Each ViewPoint 
has an associated Global filter, but while a ViewPoint is displayed, you can 
select a different Global filter to alter which jobs are displayed in the current 
ViewPoints session. Once defined, Global filters are available site-wide.

— Hierarchy definition — defines the hierarchical structure used to display jobs.

CONTROL-M/EM comes with a set of predefined ViewPoints, but you can define 
your own ViewPoints. 

■ Dynamic filters — a Dynamic filter can be used to further filter which loaded jobs 
get displayed in the ViewPoint. Like Global filters, dynamic filters do not reduce 
system overhead, but they do reduce screen clutter, and facilitate monitoring by 
exception. Dynamic filters are defined locally on an on-need basis, and can be 
saved for reuse. 

Selecting a ViewPoint
You can open multiple ViewPoints at the same time in separate windows.
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To display an existing ViewPoint

1 In the CONTROL-M/Enterprise Manager window, choose File => Open Viewpoint 
or click . 

2 In the Open ViewPoint dialog box, select the ViewPoint and click OK.

Displaying nodes in their own ViewPoint

Select the nodes in the ViewPoint, and choose View => View Selection. 

A new, special ViewPoint opens, displaying the selected nodes. 

When you display selected nodes in their own special ViewPoint, the ViewPoint is 
similar to regular ViewPoints, but because it is based on a fixed set of nodes

■ you cannot filter the ViewPoint
■ you can not remove jobs from, or add jobs to, the ViewPoint

Filtering the ViewPoint display
Two types of filters can be used to filter the display, Global filters and dynamic filters. 
These filters differ in several ways, including how they are defined. For details, see

■ Switching filters
■ Defining dynamic filters
■ Defining global filters

Switching filters

This section describes how to switch global filters and how to filter with dynamic 
filters.

To switch global filters

In the Filter list box in the ViewPoint toolbar, select the global filter name. 

The selected filter replaces the assigned filter in the current session only; the 
ViewPoint’s permanent filter assignment remains unchanged.
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To filter with a dynamic filter

1 Depending on your current location, perform one of the following:

■ If the Open ViewPoint dialog box is currently displayed (that is, you are in the 
process of opening a ViewPoint), after you select the ViewPoint click Dynamic 
Filter. 

■ If the ViewPoint is currently displayed, choose <Dynamic Filter> in the Filter list 
box.

The Dynamic Filter Definition dialog box displays the last-used dynamic filtering 
criteria.

2 To use a different dynamic filter, select the name of the filter in the Filter Presets 
field and click OK. To create a new dynamic filter or edit the displayed filter 
definition, follow the instructions in “Defining dynamic filters” on page 206.

Defining dynamic filters

A dynamic filter is a filter that you define locally as you need it. You can then discard 
it or save it for reuse. 

To define a dynamic filter

1 If the Dynamic Filter Definition dialog box is not currently displayed, display it by 
performing one of the following tasks (whichever is appropriate):

■ If the Select ViewPoint dialog box is currently displayed (that is, you are in the 
process of opening a ViewPoint), after you select the ViewPoint, click Dynamic 
Filter. 

■ If the ViewPoint is currently displayed, select <Dynamic Filter> in the Filter list 
box.

The Dynamic Filter Definition dialog box displays the last-used dynamic filtering 
criteria.

TIP  
After you have defined a dynamic filter for a ViewPoint, if you click Dynamic Filter when 
opening the Open ViewPoint dialog box, this dynamic filter definition is redisplayed (until 
you clear this filter definition), even if you subsequently selected a different filter from the 
filter selection list.

To clear the dynamic filter definition, click Clear in the Dynamic Filter dialog box.
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2 To edit an existing filter, select it in the Filter Presets field and click OK. To create a 
new filter, specify a name for it in the Filter Presets field. 

3 Fill in filtering criteria. 

Consider the following when filling in filtering criteria: 

■ Most fields are self-explanatory. If you need a description of the fields that 
correspond to fields in the job editing form, see the CONTROL-M Parameter 
Guide. 

■ You can use the LIKE operator for all text fields except the Odate and Time 
parameters. For Odate From and Time From, use the >= operator. For the Odate 
To and Time To fields, use the <= operator.

■ For Odate From and Odate To, use the yymmdd format. For Time From and Time 
To, use the hh:mm format.

■ Fields can contain several criteria separated by commas (for example, 
CONTROLM = A*,B*). 

■ If you specify values for Time From and To fields in the filter, the filter processes 
values in the Start Time and End Time fields in the Job Detail screen (not the From 
and Until fields in the Job Detail screen).

■ The Job Status and TaskType fields each have a button ( ) that, when clicked, 
opens an appropriate dialog box (with relevant check boxes):

— You can select all check boxes, by clicking .

— You can clear all check boxes by clicking .

TIP  
To clear displayed criteria, click Clear at the bottom of the dialog box.

NOTE  
■ If you do not select any check-boxes, all options are loaded.

■ Do not select both Emergency and Critical, or no jobs will be displayed.

■ Task type for z/OS jobs can correspond to the following fields of UNIX jobs: Task Type, 
Cyclic and Emergency. To correctly filter on certain task types for z/OS jobs, specify the 
desired states (for example, Cyclic or Critical) along with the desired task type. For 
example, to filter for Cyclic Jobs, select Cyclic Only in the main dialog box and Job in the 
Task Type dialog box.
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■ For BMC Batch Impact Manager users: Check the Included in Business Service 
check box to filter on jobs belong to a critical batch service.

4 To save this definition for later reuse, click .

To save with a different name, type the new name in the Filter Presets field before 
clicking .

Defining global filters

A global filter is a filter definition, accessible by all users, that determines which jobs 
are displayed in the ViewPoint.

To define a global filter

1 In CONTROL-M/Enterprise Manager, choose Tools => ViewPoint Manager.

2 Perform one of the following actions:

■ To edit an existing global filter definition, select the filter name under the Filters 
node and click Edit.

■ To create a new global filter definition, select the Filters node and click New. 
Then, in the Filter dialog box, enter a name for the filter and click OK. (Filter 
names are not case sensitive.)

The Filter Definition dialog box is displayed.

NOTE  
■ Dynamic filter definitions are stored locally. The default storage location is under the user 

profile directory (which can be configured differently using the Environment-General 
panel of the Options dialog box), and each definition is stored in its own file. Only users 
with access to the computer on which a filter is saved can access and use that filter. 
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Figure 16 Filter Definition dialog box

3 In the Filter Definition dialog box, do the following:

A Optionally, define a description for the filter.

B Define the filtering criteria:

■ To add a set of criteria, select or specify a field name, relational operator, and 
a value (for example, CTM Name = ctmp1). Then add it to the Include or 
Exclude criteria area.

■ To modify an already added set of criteria, select it in the Include or Exclude 
area and then edit it in the Edit area.

■ To delete a set of criteria, select it in the Include or Exclude area and click 
delete.

4 Click OK.

NOTE  
You can define up to four sets of filtering criteria in a filter. Multiple criteria combine using a 
Boolean OR relationship—all jobs that satisfy at least one of the Include or Exclude criteria are 
included or excluded accordingly. 
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Defining ViewPoints
A ViewPoint builds a view of the active environment by retrieving and displaying 
data according to the criteria defined in the ViewPoint’s collection, hierarchy, and 
global filter definitions.

■ Collections determine the jobs to be loaded into memory.
■ Global filters determine which jobs to display.
■ Hierarchies determine the hierarchical structure in which to display jobs. 

CONTROL-M/EM is supplied with a number of predefined ViewPoints, but you can 
create or modify definitions.

To define a ViewPoint

1 In CONTROL-M/Enterprise Manager, choose Tools => ViewPoint Manager.

2 In the ViewPoint Manager dialog box, do one of the following:

■ To create a new ViewPoint definition, select the ViewPoints node and click New. 
Then, in the ViewPoint dialog box that opens, enter a name for the ViewPoint.

■ To edit an existing ViewPoint definition, select the definition under the 
ViewPoints node and click Edit.

3 In the ViewPoint Properties dialog box, do the following:

A Enter a description for the ViewPoint (optional).

B Select a collection for the ViewPoint. To edit the selected collection, click Edit, 
and follow the relevant steps in the procedure “Defining the set of jobs to load to 
memory (collections)” on page 211.

C Select a global filter for the ViewPoint. To edit the selected filter, click Edit, and 
follow the relevant steps in the procedure “To define a global filter” on 
page 208.

EXAMPLE  
An example hierarchy is: CONTROL-M, application, group

NOTE  
 If your new ViewPoint definition will require new collection, global filter or hierarchy 
definitions, create them before defining the ViewPoint; you cannot create them while defining 
the ViewPoint.
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D Select a Hierarchy definition for the ViewPoint. To edit the selected Hierarchy, 
click Edit, and follow the relevant steps in the procedure “To define a hierarchy” 
on page 212.

E After selecting the hierarchy, select the Initial Level of the Hierarchy to display 
when the ViewPoint is opened. 

By default, the highest hierarchy level nodes are displayed in when the 
ViewPoint is opened.

F Click OK.

Defining the set of jobs to load to memory (collections)

A collection defines criteria that determine which jobs in the enterprise are loaded 
into memory. Jobs are selected when the values in their job processing definitions 
match the criteria specified in the collection definition.

To define a collection

1 In CONTROL-M/Enterprise Manager, choose Tools => ViewPoint Manager.

2 In the ViewPoint Manager dialog box, do one of the following:

■ To edit an existing collection definition, select the collection name under the 
Collections node and click Edit.

■ To create a new global filter definition, select the Collections node and click New. 
Then, in the Collection dialog box, enter a name for the collection. (Collection 
names are not case sensitive.)

3 In the Collection Definition dialog box define sets of criteria that should be used to 
include or exclude matching jobs, as follows:

A In the Edit area, select a Field in the first column, a relational operator in the 
second column, and select or specify a value in the third column.

B Click Add next to the Include or Exclude area, depending on how the criteria 
should be applied. 

When filling in the selection criteria, keep in mind the following:

■ Many fields correspond to fields in the job editing form. If you need a 
description of the fields, see the CONTROL-M Parameter Guide. 
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■ The LIKE operator treats * and ? characters specified in the value as 
wildcards; the = operator treats * and ? characters specified in the value as 
literals.

■ For each field, you can specify several criteria separated by commas (for 
example, CTM Name= A*,B*). The implied relationship is OR.

4 To delete an entry, select it and click Delete.

5 When done, click OK.

Defining the display hierarchy

A hierarchy determines how selected jobs are displayed. The default hierarchy is: 
CONTROL-M – Application – Group Name. You can define other hierarchies in the 
Hierarchy Definition dialog box.

To define a hierarchy

1 In CONTROL-M/Enterprise Manager, choose Tools => ViewPoint Manager.

2 Perform one of the following:

■ To edit an existing hierarchy definition, select the filter name under the 
Hierarchies node and click Edit.

■ To create a new hierarchy definition, select the Hierarchies node and click New. 
Then, in the Hierarchy dialog box, enter a name for the hierarchy. (Hierarchy 
names are not case sensitive.)

3 In the Hierarchy Definition dialog box:

A Optionally, define a description for the hierarchy.

B Select criteria for each level of the hierarchy. You can define up to four hierarchy 
levels. 

NOTE  
■ Do not select both Emergency and Critical, or no jobs will be displayed.
■ Task type for z/OS jobs can correspond to the following fields of UNIX jobs: Task Type, 

Cyclic and Emergency. To correctly filter on certain task types for z/OS jobs, specify the 
desired states (for example, Cyclic or Critical) along with the desired task type. For 
example, to filter for Cyclic Jobs, select Cyclic Only in the main dialog box and Job in the 
Task Type dialog box.
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4 Click OK.

Alternative method for defining ViewPoints — the ViewPoint 
wizard

As an alternative to defining ViewPoints, hierarchies and filters from the ViewPoint 
Manager, you can define ViewPoints (and their accompanying hierarchies and filters) 
using the ViewPoint Wizard.

To define a ViewPoint using the ViewPoint wizard

In CONTROL-M/EM, choose File => New ViewPoint or click  and work through 
the displayed ViewPoint Wizard pages.

Most wizard pages are self-explanatory. For general details regarding the definition 
of collections, global filters and hierarchies, see “Defining the set of jobs to load to 
memory (collections)” on page 211, and “Defining the display hierarchy” on page 212 
respectively. 

TIP  
■ To return to the default hierarchy, click Default Levels.
■ To clear fields and reset levels, click Reset Levels.

NOTE  
When defining hierarchies and global filters using the ViewPoint wizard

■ if you define a new hierarchy but do not specify a name for it, the name defaults to the 
ViewPoint name with Hier appended to it 

■ if you are define a new global filter but do not specify a name for it, the name defaults to 
the ViewPoint name with Filt appended to it
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C h a p t e r 20
20  Monitoring and handling alerts

This chapter presents the following topics:

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  215
Connecting to the Global Alerts Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  216
Displaying alerts. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  216
Working with alerts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  217

Introduction 
An important way to monitor your production environment is to monitor alerts. An 
alert is a message that indicates that a problem or exception has occurred for a job.

Alerts are monitored and handled from the Alerts window, which must be connected 
to a Global Alerts Server (GAS). 

Alerts can originate from any of the following:

■ Shout facility — a job processing definition can include instructions in the Shout or 
Do Shout parameter to send a message to the Alerts window.

■ Jobs ending not ok — two system parameters, AlertOnAbend and DownCreAlerts, 
can automatically generate alerts when a job terminates with an Ended not OK 
status.

■ A communication breakdown (for example, between CONTROL-M and 
CONTROL-M/EM) will generate an alert.

■ BMC Batch Impact Manager, which can be used to relay messages of special 
importance. For more information, see the CONTROL-M Business Service Management 
Solution User Guide.

You can only view alerts for those jobs that you are authorized to view.
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Connecting to the Global Alerts Server
1 In the Alerts window, choose File => Connect.

2 In the Connect to Global Alerts Server dialog box, select a GAS server.

3 Click Connect.

4 Optionally, to disconnect from the Global Alerts Server, in the Alerts window, 
choose File => Disconnect. 

Displaying alerts
1 In the CONTROL-M/Enterprise Manager window, choose View => Alerts. 

The Alerts window opens and displays the alert data.

Figure 17 Alerts Window

2 Optionally, to filter information in the Alerts window, perform one of the 
following:

NOTE  
You can customize default settings for the alerts feature in the Alerts panel of the 
CONTROL-M/EM GUI Options dialog box. For details, see Appendix A, “Customizing 
the interfaces.”
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■ Click on the right top corner of a column header and select a filtering option.

■ Right-click on any column header and choose Filter Editor. Use the Filter Builder 
to enter advanced filtering criteria.

3 To set display preferences (for example, always displaying the Alerts window on 
top), choose the appropriate option in View menu. 

Working with alerts
The Alerts window is used to view the alert’s status and severity (urgency) according 
to the Shout – Urgency parameter in the job processing definition. 

Alerts first appear in the Alerts window with a status of Not Noticed. As you examine 
and work with the alerts, you can change their status. Alerts that are being handled 
are indented and grayed. 

The Alerts facility enables you to attach notes to alerts. For example, you might want 
to attach a note indicating the name of the person assigned to handle the alert. 

You can also open an alert into a local ViewPoint, which can help you examine and 
analyze the job that prompted the alert and its work environment. This can help you 
trace the cause of the problem and troubleshoot it. You can open multiple local 
ViewPoints.

To display alerts with severity identifying colors

In the Alerts window, choose View => Color Scheme => Old Scheme.

To display the details of a particular alert (opening the Alert Details dialog box) 
either:

■ In the Alerts window, select the alert and choose Actions => Properties.

■ Double-click on the alert information.

NOTE  
To perform the actions explained below you must be connected to the relevant Gateway (for 
example, to update the alert status and severity).
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To change the status of an alert

In the Actions menu of the Alerts window, choose the appropriate status as follows:

■ To indicate that you’ve noticed but not necessarily handled the alert, choose 
Notice. (To change the status back to Not Noticed, choose Unnotice.)

■ To indicate that you’ve handled the alert, choose Handle. (To change the status 
from Handled to Unhandled, choose Unhandle.)

To change the urgency of an alert

1 In the Alerts window, select the alert and choose Actions => Properties.

2 In the Alert Details dialog box, select the urgency in the Severity field and click OK.

To find and focus on the job that produced the alert in the Flow Diagram

In the Alerts window, select the alert and choose Actions => Find Job.

The relevant node is displayed and selected in the CONTROL-M/Enterprise 
Manager ViewPoint window.

To add a note to an alert

1 In the Alerts window, select the alert and choose Actions => Properties.

2 In the Alert Details dialog box, type the note in the Note field click OK.

To export the list of alerts to a csv file

In the Alerts window, choose File => Export. In the displayed dialog box, provide a 
path, file name, and a file type of .csv, and click Save.

To print the list of alerts

In the Alerts window, choose File => Print. Then, in the Print dialog box, provide the 
print details and click Print.

To open an alert into a Local ViewPoint

In the Alerts window, select the alert and choose Actions => Properties => Open into 
Viewpoint.
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A new ViewPoint is displayed in the GUI. This ViewPoint contains the job node of the 
job that prompted the selected alert. In addition, job nodes of jobs that depend on or 
are predecessors for the job are also shown in this ViewPoint. 

NOTE  
■ You cannot use this function for an alert with an empty Order ID.

■ If the job that prompted the selected alert is no longer in the CONTROL-M/EM 
environment, an empty ViewPoint is displayed.

■ Depending on the setting of the option Open into Local View area, certain nodes might 
not be displayed in the ViewPoint. For details and instructions on changing the setting, 
see the description in Table 40 on page 301.
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C h a p t e r 21
21  Monitoring and intervening in 
production

This chapters presents the following topics:

Monitoring  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  221
Checking job status summaries by CONTROL-M, application, and group . . . .  222
Checking job status details. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  223
Performing job monitoring actions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  223
Checking predecessor and successor job flows. . . . . . . . . . . . . . . . . . . . . . . . . . . .  224

Intervening . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  228
Viewing and editing the details of a job in the active environment  . . . . . . . . . .  228
Performing manual job intervention  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  230
Handling errors that occur when you intervene  . . . . . . . . . . . . . . . . . . . . . . . . . .  234
Manually indicating satisfied conditions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  234
Manually rescheduling jobs in the active environment. . . . . . . . . . . . . . . . . . . . .  236
Activating third-party applications  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  239

CONTROL-M/EM provides you a number of ways to monitor job processing in the 
active environment, and a number of ways to manually intervene in the job 
processing.

Monitoring
CONTROL-M/EM provides a number of methods for monitoring job processing. For 
example

■ The Alerts facility can indicate problems in the Alerts window. For details, see 
Chapter 20, “Monitoring and handling alerts.”

■ Shout statements defined in job processing definitions can notify you (for example 
through the console or through email) of job processing statuses or problems.
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■  SNMP traps defined in DO SNMP statements in job processing definitions can 
indicate problems to other applications. For details, see the CONTROL-M 
Administrator Guide.

■ You can use the Business Services window to monitor the overall processing flow 
of jobs that constitute critical batch services. If you have the BMC Business Impact 
Manager add-on installed, you can monitor critical jobs for mission critical 
operations. For details, see Chapter 22, “Monitoring business-critical batch services 
using BMC Batch Impact Manager.”

This section describes various methods for monitoring job processing from the 
CONTROL-M/Enterprise Manager window.

Checking job status summaries by CONTROL-M, application, 
and group

For selected high level nodes, such as CONTROL-M, application, or group, you can 
display status summaries for the jobs in that node.

To see a summary of job statuses in a high-level node

In the CONTROL-M/EM window, right-click the node in the flow diagram or 
navigation tree, and in the pop-up menu, choose Status Summary.

The General tab of the Status Summary dialog box displays, color-coded by status, 
the number and percentage of jobs in the node with the status. It also displays totals 
and the number of scheduling groups included in the totals. 

If you selected a CONTROL-M/Server node, an additional panel (CONTROL-M) 
provides basic details about the CONTROL-M, and the following communication 
information:

■ Sync — indicates if the current display is synchronized with the CONTROL-M Active 
Jobs file.

■ Refresh needed — indicates if the Refresh Needed button in the CONTROL-M/EM 
window should be clicked to display recently forced or ordered jobs.
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Checking job status details

To help you analyze jobs and manage job flows, you can display and modify the 
processing details of jobs in the active environment. You can also modify certain 
details for that job run. For instructions and additional information, see “Viewing and 
editing the details of a job in the active environment” on page 228.

Performing job monitoring actions

You can perform various job monitoring actions on jobs displayed in the 
CONTROL-M/EM ViewPoint. Regardless of the action, the process for performing 
the action is basically the same. 

To perform a job monitoring action

Right-click the job node in CONTROL-M/EM, and in the pop-up menu, choose the 
action option. The pop-up menu lists both monitoring and intervention actions. 
Table 21 on page 223 summarizes the monitoring actions you can perform on jobs in 
the active jobs file.

CONTROL-M/EM accesses and updates the relevant CONTROL-M server database.

NOTE  
To perform job actions, you must have appropriate authorizations in CONTROL-M/EM and 
the relevant CONTROL-M.

NOTE  
 Actions are disabled when communication is not synchronized.

Table 21 Job monitoring actions  (part 1 of 2)

Action Option

identify the maximum runtime for a series of jobs and list the dependent 
job nodes in the longest path. For details, see “To display the details of a 
Critical Path dependency” on page 225.

Critical Path

view the job’s documentation. Documentation

for a selected job, identify the predecessor jobs that failed to run OK. This 
feature can help you determine why a selected job or scheduling group 
failed to run as expected. For details, see “To display the details of a job’s 
predecessors that failed” on page 226.

Enhanced Why
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Checking predecessor and successor job flows

In CONTROL-M/EM, you can identify and gather details about the following 
predecessor and successor job situations:

■ Predecessor and successor jobs of a job (Neighborhood)—For details, “Identifying 
predecessor and successor jobs” on page 44.

■ Identify the maximum runtime for a series of jobs and list the dependent job nodes 
in the longest path. (Critical path)—described in this section.

■ Predecessor jobs (of a selected job) that failed to run OK (Enhanced Why)—
described in this section.

After you have generated the list of jobs and displayed their details, you can perform 
a number of other operations (for example, exporting the list).

view log messages for the job in the Job Log dialog box. Log

identify the predecessor or successor jobs of a selected job. For details, see 
“Identifying predecessor and successor jobs” on page 44.

Neighborhood

view statistics of the job’s latest runs. Statistics

view the job’s JCL or job script statements. View JCL/Script

view the job’s SYSOUTs. In the displayed dialog box, select the SYSOUT 
to view, and click OK.

Note: For z/OS, this option is available only if CONTROL-M/Restart is 
installed in the CONTROL-M.

Note: If the SYSOUT size exceeds the size limit defined for the 
CONTROL-M during installation, the SYSOUT cannot be viewed.

View Sysout List

view why the job has not yet been executed (and intervene as needed). 
Results are displayed in the Why dialog box. For instructions, see 
“To view why a job has not begun execution and to intervene if 
necessary” on page 233

Why

NOTE  
To navigate directly to a predecessor or successor node without generating detail lists, do the 
following:

1. In the job node’s pop-up menu, choose Branch Menus and then Predecessor or Successor.

2. In the submenu, select the target node.

Table 21 Job monitoring actions  (part 2 of 2)

Action Option
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To display the details of a Critical Path dependency

1 In the flow diagram, expand all relevant group nodes so all jobs to be included in 
the critical path are visible.

2 Select the first and last nodes in the path in the flow diagram. The last node should 
be a descendant of the first node, but not immediately below it.

3 In the Analysis menu, select Critical Path.

4 In the Critical Path dialog box

■ in the Use area, select the measure to be used to calculate the critical path — 
Average Runtime or Last Runtime

■ you can specify an Overlapping Tolerance, in seconds

This represents the maximum time, in seconds, that the end of one job can 
overlap the start of the subsequent job, which impacts critical path calculation.

5 Click Find Path. 

The number of nodes in the path and the total runtime for the path are displayed in 
the dialog box. 

The number of job nodes in the critical path is listed in the dialog box, and those job 
nodes are selected in the flow diagram. A display area opens at the bottom of the 
dialog box and displays the Details list, which is a list of those jobs and their details 
(for example, current status, order ID, RBA). For a summary of actions you can 
perform in the dependency Details list, see “Working with predecessor and successor 
job details (Details list)” on page 227.

NOTE  
Jobs that do not have runtime statistics have an expected runtime of 0, and are not 
factored into the critical path calculation.

TIP  
If the details display area does not open, click Details, which alternately displays or hides this 
display area.
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To display the details of a job’s predecessors that failed

1 In the flow diagram or the navigation tree, select the relevant job or scheduling 
group node.

Ensure that the selected job or scheduling group has In conditions and is in Wait 
status (that is, it has not yet run).

2 In the Analysis menu, select Enhanced Why. 

3 In the Enhanced Why dialog box, click the appropriate button.

■ To display all predecessor jobs and scheduling groups that did not end or did 
not end OK, click With path.

■ To display the oldest predecessor job or scheduling group that did not end or 
did not end OK, click the Without path button.

The predecessor jobs that failed to run OK are highlighted in the flow diagram.

4 Click Find. 

The number of predecessor jobs that failed to run OK is listed in the dialog box, and 
those predecessor jobs are selected in the flow diagram. A display area opens at the 
bottom of the dialog box and displays the Details list, which is a list of those jobs and 
their details (for example, current status, order ID, RBA). For a summary of actions 
you can perform in the dependency Details list, see “Working with predecessor and 
successor job details (Details list)” on page 227.

TIP  
If the details display area does not open, click Details, which alternately displays or hides this 
display area.
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Working with predecessor and successor job details 
(Details list)

While the Details list is displayed in a Critical Path or Enhanced Why dialog box, you 
can perform the following tasks on that list:

Properties of ViewPoints based on dependent jobs 

When you display the jobs listed in the Detail list in their own ViewPoint, the 
ViewPoint has the following special properties:

■ (For Neighborhood dependencies) The job on which the Neighborhood action was 
performed is highlighted.

■ You cannot change the filter on the new ViewPoint.

■ Changes made to the original ViewPoint are reflected in the new ViewPoint (but in 
the case of Enhanced Why, the Enhanced Why search is not recalculated).

■ Deletion of a job in the original ViewPoint is reflected in the new ViewPoint, but

— for Neighborhood dependencies, jobs are not added to this ViewPoint
— for Enhanced Why dependencies, jobs that are connected to the deleted job are 

not deleted

■ Additional Neighborhood, Enhanced Why, and Critical Path functionality is 
enabled in the new ViewPoint.

Task How to

display or hide an Item Count 
at the bottom of the Details 
list

Click Item Count in the pop-up menu for any job listing.

locate a listed job in the flow 
diagram

Click Find in the pop-up menu for the job listing.

open the job editing form for 
a listed job

Double-click the job listing.

export the details of the listed 
jobs to a comma-delimited 
(CSV) file

Click Export to File in the pop-up menu for the job listing.

create (and view) a text report 
containing the details about 
the listed jobs

Click Create Report to save this information as a file. (To 
open the saved report in your default text editor, click Show 
Report.)

display the listed jobs in their 
own ViewPoint

Click Open ViewPoint. For more information, see 
“Properties of ViewPoints based on dependent jobs.”
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■ The Refresh Needed button functions as in any ViewPoint, but in the case of 
Neighborhood dependencies no jobs can be added to or deleted from the new 
ViewPoint.

■ The hierarchy of the new ViewPoint is inherited from the original ViewPoint.

Intervening
The CONTROL-M/Enterprise Manager window provides you a number of ways to 
intervene in job processing if necessary.

Viewing and editing the details of a job in the active 
environment

When a job processing definition is ordered or forced (through New Day processing 
or manually), a modified copy of the original definition is placed in the active jobs 
file. To help you analyze jobs and manage job flows in CONTROL-M/EM, you can 
display and modify the processing details of the job in the active environment. 

To display (and update) the details of a job in the active environment

1 In CONTROL-M/EM, place the job processing definition (or scheduling group) in 
Held status by right-clicking the node and choosing Hold. (You can skip this step if 
you will only be viewing, but not updating, the details)

2 Double-click the job node.

The job editing form displays the job processing definition. The Active tab displays 
details unique to the job order in the active environment.

3  Edit the job processing definition as needed. For an explanation of how to edit the 
job processing definition, see Chapter 4, “Defining how jobs should run.” Keep in 
mind the following points:

■ You are working on a copy of the original. Any changes you make apply only to 
the current copy you are editing. They do not apply to the original or to any 
other copies that might appear in the active jobs file.

NOTE  
To update details, you must perform a Hold on the job in the active environment before 
opening the job editing form, and Free the job when you have finished the updates.
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■ Not all pages or parameters that appear in the original appear in the active jobs 
file copy. For example, because the job is already scheduled, the Scheduling tab 
parameters are unnecessary and this tab does not appear. 

■ Conversely, after a job is scheduled, certain required parameters are generated 
during job processing. These do not appear in the job editing form that you 
define in CONTROL-M/Desktop, but are displayed in a panel in the job editing 
form that is unique to CONTROL-M/EM—the Active tab. Furthermore, some 
variables and AutoEdit parameters might display their resolved values.

■ Changing certain parameters will not provide any benefit. Be cautious and be 
sure of the benefit before deciding to edit parameters. You might find it useful to 
edit parameters in the Active, Set, Step, or PostProc pages if a job is not being 
submitted or if there is a need for modified post-processing. It might also be 
useful to edit parameters before a rerun or cyclic run.

■  Table 22 describes parameters in the Active tab, many of which are unique to 
copies of the job processing definition in the active environment. For tips in 
modifying job details, see “Creating and editing jobs” on page 57. For a detailed 
description of the fields displayed in the job editing form, see the CONTROL-M 
Parameter Guide. 

4 Click Save.

5 Right-click the node and choose Free to free the job.

To order or force the job (again), see “To order or force jobs” on page 237.

Table 22 Fields of the Active tab  (part 1 of 2)

Field Description

Current Status Status of the job, such as Ended OK.

Held Indicates if the job is held.

Deleted Indicates if the job is deleted.

Restarted z/OS only: Indicates if the job has been restarted.

Order Date Original scheduling date of the job.

 Next Time:
(Date / Time)

Indicates the next expected submission date and time for the job, for rerun 
or cyclic jobs that use the Interval option. For z/OS jobs, only the time is 
specified.

Rerun counter Number of times the job has been rerun.

Sysout search 
count

z/OS only: Number of times CONTROL-M has looked for the job.

NJE Node z/OS only: Node ID of the NJE terminal.

NJE z/OS only: 1 indicates that the job was sent for execution to a computer that 
is connected to CONTROL-M through NJE (the node does not share a spool 
with CONTROL-M).
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Performing manual job intervention

You can perform various intervention actions on jobs displayed in the 
CONTROL-M/EM ViewPoint. Regardless of the action, the process for performing 
the action is basically the same. 

Logical 
Partition

z/OS only: For CONTROL-M for z/OS version 6.2.00 and later: 
Logical partition where the job is running.

Must end by z/OS only: Time by which the job must finish executing. 

+ num Days – The day by which the job must finish executing.
The + num Days subparameter is relevant only for jobs running in 
CONTROL-M for z/OS version 6.2.00 or later.

Elapse z/OS only: Length of time (in minutes) that the job is expected to run.

Due In z/OS only: Time at which the job must start executing.

+ num Days – The day on which the job must start executing.
The + num Days subparameter is relevant only for jobs running in 
CONTROL-M for z/OS version 6.2.00 or later.

Job Name z/OS only: Name of the job. 

Order ID Unique job order ID in CONTROL-M.

Job ID ID assigned to the job by the operating system.

Start Time Date and time the job began executing.

End Time Date and time the job finished executing.

Average 
Run Time

Average time (in hhmmss format) for the job to run, based on the last 
successful runs of the job. 

Standard 
Deviation

Standard deviation from the average runtime. This statistic is compiled 
from the last successful runs of the job.

From Step z/OS only with CONTROL-M/Restart: Step from which to rerun the job.

From Proc z/OS only with CONTROL-M/Restart: Procedure step from which to rerun 
the job.

To Step z/OS only with CONTROL-M/Restart: Step until which to rerun the job.

To Proc z/OS only with CONTROL-M/Restart: Procedure step until which to rerun 
the job.

NOTE  
To perform job actions, you must have appropriate authorizations in CONTROL-M/EM and 
the relevant CONTROL-M.

Table 22 Fields of the Active tab  (part 2 of 2)

Field Description
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To perform an intervention action on a job

Right-click the job node in CONTROL-M/EM, and in the pop-up menu, choose the 
action option. The pop-up menu lists both monitoring and intervention actions. 
Table 23 on page 231 summarizes the intervention actions you can perform on jobs in 
the active jobs file.

CONTROL-M/EM accesses and updates the relevant CONTROL-M server database.

NOTE  
 Actions are disabled when communication is not synchronized.

Table 23 Job intervention actions  (part 1 of 2)

Intervention Menu option

hold (stop processing) the job. You must hold the job before you update 
its details in the job editing form in the active jobs file. Note: 

■ If the job has not started to execute, Hold prevents it from executing 
even after all submission criteria are satisfied.

■ If the job is executing, Hold stops its execution but the job maintains 
its Executing status. 

■ If the job has completed executing, while it is Held it cannot be 
manually rerun.

The job remains in this state until you release it using the Free option.

Hold

free (resume the processing of) the job. If you held a job, you must free it 
before processing can resume.

Free

activate third-party applications. For details, see “Activating third-party 
applications” on page 239.

Activate 
Application

specify criteria and resources to be ignored. For instructions, see 
“To bypass selected submission criteria (z/OS only)” on page 232. [Only 
for jobs running under CONTROL-M for z/OS version 6.2.00 and later.]

Bypass

confirm that CONTROL-M should process a job that requires manual 
confirmation (that is, the job has a Wait User (pink) status).

Confirm 

delete the job. (This action does not physically delete the job; it only 
changes the job status to Deleted. The job remains visible in the active jobs 
file until the next cleanup of the Active Jobs file by the New Day 
procedure or manual request. Until then, you can undelete the job.)

Delete

undelete a deleted job that still appears in the active jobs file. Undelete
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To bypass selected submission criteria (z/OS only)

1 Right-click the job node, and in the pop-up menu choose Bypass.

2 In the displayed dialog box, check all required options as described in Table 24.

edit the job’s JCL or job script statements. Note: 
■ You cannot edit lines that contain over 200 characters.
■ You cannot edit scripts for SAP jobs.
■ To edit a job script in UNIX, you must be identified in the computer’s 

/etc/passwd file.

Edit JCL/Script

change the job’s status to Ended OK (and the color of the job node to 
green.) Available for jobs with a status of Ended Not OK or for jobs in a 
Wait status (such as Wait Time or Wait Cond). Note: For jobs running 
under CONTROL-M for z/OS, Force OK always performs post- 
processing, regardless of the default setting in the CTMPARM member.

Force OK

change the job status to Ended OK without performing the 
postprocessing actions of the job. [Only for jobs running under 
CONTROL-M for z/OS version 6.2.00 and later.]

Force OK – no 
Post Processing

terminate the job and its associated processes. Note: Killing a specific 
instance of a cyclic job does not affect subsequent runs of that job.

Kill

reactivate postprocessing for the selected job. [z/OS only] React

rerun the job. Rerun

restart the job using CONTROL-M/Restart. [z/OS only] For instructions, 
see “To perform a restart (z/OS only)” on page 233

Restart

view why the job has not yet been executed, and intervene as needed. 
Results are displayed in the Why dialog box. For instructions, see 
“To view why a job has not begun execution and to intervene if 
necessary” on page 233

Why

NOTE  
The Bypass option is only available for jobs running under CONTROL-M for z/OS version 
6.2.00 and later.

Table 24 Bypass options  (part 1 of 2)

If the job should run... Check option

... regardless of the Time From and Time Until parameter values. Time Limit

... even if prerequisite IN conditions are not satisfied. IN Conditions

... regardless of whether Quantitative resources specified in the job 
definition are available.

Quantitative 
Resources

... regardless of whether control resources specified in the job definition are 
available

Control 
Resources

Table 23 Job intervention actions  (part 2 of 2)

Intervention Menu option
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To perform a restart (z/OS only)

1 Right-click the job node, and in the pop-up menu choose Restart.

2 In the Job Restart dialog box (using uppercase letters only)

A Enter the range of steps to be restarted.

B Check any of the following tasks you want performed:

■ Recapture Abend Codes
■ Recapture Cond Codes
■ Perform Step Adjustment

C If desired, specify the name of the member in the CONTROL-R PARM library 
that contains processing defaults to be applied to the job.

D Click OK.

To view why a job has not begun execution and to intervene if necessary

1 Right-click the job node, and in the pop-up menu choose Why.

The Why dialog box opens displaying the reasons why the job did not run, for 
example, unavailable required resources or missing conditions.

2 If a prerequisite condition required by the job is missing, to add it do the following:

A Click on the line that identifies the missing condition

B If the Why dialog box shows a prerequisite condition with a date value of **** or 
$$$$, you can change it to a specific date.

C Click Add Condition. 

D If a confirmation is required, confirm the addition. 

... regardless of whether other jobs using the same Pipe as that specified in 
the definition of this job are ready to run.

Pipes

... as a dummy job, when the prerequisite criteria and conditions of the job 
are satisfied, and the job status should change to ENDED OK, and only the 
job postprocessing actions in the job should be performed

JCL (Run as 
Dummy Job)

Table 24 Bypass options  (part 2 of 2)

If the job should run... Check option
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Handling errors that occur when you intervene 

When you perform job actions, the Job Action Report window automatically opens 
and displays the status of the requested actions. If errors occur, these appear in the 
window. You can also manually request display of the Job Action Report window.

To display job action messages

1 In the CONTROL-M/Enterprise Manager window, choose 
View => Output Windows => Action Report. 

Messages remain in the window until you clear them or until the maximum 
number of messages allowed has been reached. (The maximum is customizable. 
For details, see “Environment Display panel” on page 299.)

2 After reviewing the errors, click one of the following action choices:

■ Hide — closes the Job Action Report window, but CONTROL-M/EM continues 
to record all messages that are issued.

■ Clear —erases all messages displayed in the Job Action Report window, leaving 
the window open.

Manually indicating satisfied conditions

Most commonly, prerequisite conditions are used to create job dependencies - that is, 
a predecessor job creates a prerequisite condition upon completion that is required 
for a successor job to be submitted.

But not all prerequisite conditions are added by jobs. When CONTROL-M must 
know the status of something outside its control, you can add a manual condition to 
notify CONTROL-M of the status. 

For example, a backup job might require that a tape be physically loaded on a tape 
drive before the job can be submitted. To handle this, you can define in the job 
processing definition an In prerequisite condition (such as Tape Loaded) that is not 
added by another job, but rather, manually, by the operator, after physically loading 
the tape drive.

NOTE  
You must be authorized to add the condition.
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You can manually add and delete prerequisite conditions using the Prerequisite 
Conditions window.

You create, delete, and view prerequisite conditions in your production environment 
using the Prerequisite Conditions window.

To create or delete a prerequisite condition

1 In the CONTROL-M/EM GUI, choose Tools => Prerequisite Conditions, which 
displays the Prerequisite Conditions window.

2 In the Prerequisite Conditions window, do the following as needed:

■ To quickly filter, choose View => Filter Row, and enter the filter criteria.

■ To filter the displayed data, click on the right top corner of a column header and 
select the appropriate filtering option.

■ To create an advanced filter, right-click on any column header and choose Filter 
Editor. Use the Filter Builder to enter the appropriate filtering criteria and the 
relationships between them.

The following information is useful for understanding the filtering criteria:

■ Name — the condition name
■ Order Date — specify the date for the condition. Valid values: specific date in 

mm/dd format or STAT- any date
■ CONTROL-M

3 To create a prerequisite condition do the following:

A In the Prerequisite Conditions window, choose Actions => Add.

B In the displayed Prerequisite Condition dialog box, fill in the data that defines 
the prerequisite condition, and click OK.

4 To delete a prerequisite condition, select it and choose Actions => Delete.

NOTE  
You can filter conditions on startup before they are loaded from the database. This is 
recommended when working with a large amount of conditions. For more information on 
filtering conditions on startup, see “Filtering prerequisite conditions on startup” on page 236.
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Filtering prerequisite conditions on startup

You can filter prerequisite conditions on startup before they are loaded from the 
database. This is recommended when working with a large amount of conditions. In 
the status bar you can view the filter criteria.

To filter conditions on startup:

1 Choose Options=> Show ‘Refresh Filter’ on startup.

2 In the Refresh Filter dialog box, fill in the data that defines the condition and click 
OK.

To change the filter:

1 Choose View=> Refresh Filter.

2 In the Refresh Filter dialog box, fill in the data that defines the condition and click 
OK.

Manually rescheduling jobs in the active environment

Ideally, the process of ordering jobs into the Active Jobs file should be automated 
through use of the New Day procedure or User Daily jobs. However you can 
manually reorder or force jobs appearing in the active jobs file as the need arises. To 
order or force jobs and scheduling tables, you must have the appropriate privileges. 

NOTE  
Addition and deletion of prerequisite conditions in one CONTROL-M might affect 
prerequisite conditions in other CONTROL-M installations (if the conditions are global). For 
details, see “Defining global conditions” on page 183.
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To order or force jobs

1 In the CONTROL-M/Enterprise Manager window, select Tools => Order/Force, or 
click . 

The Order/Force Jobs dialog box is displayed.

2 In the Order/Force Jobs dialog box, select the CONTROL-M and scheduling table 
name. (For z/OS, select also a Library name.)

The dialog box displays the list of jobs in the selected scheduling table (Figure 18 
on page 238).

3 To order or force specific jobs in the scheduling table, select the jobs, or type a job 
name or mask. (To order or force all the jobs in the scheduling table, skip this step.)

NOTE  
You can also order or force jobs using the cli command line utility (described in the 
CONTROL-M Utility Guide). And you can order or force jobs from the definition 
environment using the Order/Force dialog box of CONTROL-M/Desktop (for details, see 
“Manually scheduling jobs and tables” on page 168).

NOTE  
If the tables or jobs do not appear in the dialog box because they were created in 
CONTROL-M after the last update between CONTROL-M and the CONTROL-M/EM 
database, type the names in the appropriate (job or table) text box.
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Figure 18 Order/Force dialog box with advanced fields (in CONTROL-M/EM)

4 To provide additional, optional order/force instructions, click Advanced and then 
select the options to be used, as follows:

■ By default, scheduling tables and jobs are ordered or forced using the current 
ordering date (ODAT). To specify a different date, select the date in the ODATE 
area. 

■ To ensure that the jobs are not submitted before the Odate, select Wait for Odate 
to run. Otherwise, CONTROL-M will submit the jobs as soon as their execution 
criteria are satisfied. (Wait for Odate to run applies to jobs or tables submitted 
under CONTROL-M for z/OS version 6.2.00 or later, or under 
CONTROL-M/Server version 6.3.00 or later.)

■ To have the ordered or forced jobs automatically placed in Hold status as soon 
as they start to run, click Order/Force with Hold.
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■ If you are ordering jobs from a group scheduling table without ordering the 
scheduling group itself, click Order/Force into Group, and select the appropriate 
scheduling group pointer:

— To place the jobs into a new scheduling group in the active jobs file, click 
New.

— To add the jobs to the scheduling group that was most recently ordered, click 
Recent. You can use this option only if you are forcing, not ordering, jobs.

— To force the jobs without adding them to a scheduling group, click Stand 
Alone. You can use this option only if you are forcing, not ordering, jobs.

— To select a scheduling group, click Select. Then click the displayed ellipsis 
(...), and in the displayed Select Active Group dialog box, select the 
scheduling group to which to add the jobs. You can use this option only if 
you are forcing, not ordering, jobs.

If you chose Recent or Selected, to add the jobs to the scheduling group even if 
jobs with the same name already exist in the table, click Duplicate.

5 Click Order or Force.

Activating third-party applications

The Applications Activation feature enables you to insert job processing parameters 
from a CONTROL-M job or scheduling group into a command line used to activate a 
third-party program. To use this feature, you must perform the steps described in this 
section:

1. Create an Activate Application definition.

2. Use the definition you created to activate the application.

After you have created an Activate Application definition, you can reuse it as needed 
to active the application.

To create an Activate Application definition 

1 In the CONTROL-M/EM window, choose Tools => Activate Applications Editor. 

NOTE  
You can only define an Activate Application definition from an Administrator account.



Activating third-party applications

240 CONTROL-M User Guide

2 Perform one of the following actions in the Activate Applications Editor:

■ To create a new Application Activation definition, click New ( ) and in the 
entry field that opens in the Applications area, specify a unique name for the 
Application Activation definition.

■ To modify an existing Application Activation definition, select the definition in 
the Applications window.

3 Fill in (or modify) values for the definition, as follows:

A In the Program field, browse to and supply the full path and name of the 
application to run.

B In the Initial Dir field, browse to and supply the full path of the working 
directory. If not specified, the default is the Program directory. 

C In the Parameters field, select parameters, flags or switches (including job 
processing parameters) to be passed on the command line to the program at 
runtime.

4 Click OK.

5 To rename an Application Activation definition, double-click it, edit the name, and 
press Enter.

NOTE  
■ Inserted job processing parameters appear in red; literal values appear in black.

■ When you insert a parameter after a path, a space is automatically inserted between 
the path and the variable. You should manually delete this space if it is not needed.

■ The same parameter can be inserted multiple times.

■ You can use the up and down arrows in the dialog box to change the positioning of 
listed applications, and the delete button to delete listed applications.

When you click OK or Apply, changes made to all definitions in the current session (not 
just the changes made to the currently selected definition) are accepted.
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Figure 19 displays an example of a filled in Activate Applications Editor dialog box. 

Figure 19 Filled in Activate Applications Editor dialog box

To run an application using an Application Activation definition

1 In CONTROL-M/EM, right-click a job or scheduling group node in the flow 
diagram or navigation tree, and in the pop-up menu, choose Activate Application.

2 In the displayed list, select the appropriate Application Activation definition.

The program runs, using the command line and Scheduling table parameters 
specified in your definition.

NOTE  
The CONTROL-M on which the selected job was run does not need to be operational.
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C h a p t e r 22
22  Monitoring business-critical batch 
services using BMC Batch Impact 
Manager

This chapter presents the following topics:

Introduction to BMC Batch Impact Manager. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  243
BMC Batch Impact Manager integration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  244
Using CONTROL-M/EM to track business services . . . . . . . . . . . . . . . . . . . . . . . . . .  245

Introduction to BMC Batch Impact Manager
Batch processing and background job scheduling play a key part in automating the 
business services of your organization. Batch-related failures or external events, such 
as hardware and network problems, might cause delays in batch processing that 
affect the completion time and accuracy of business processes. Such delays and their 
potential effect on the business must be detected and analyzed before business is 
adversely impacted.

To solve this problem, BMC Batch Impact Manager

■ proactively detects potential delays and errors in critical batch business services
■ provides the status of critical batch business services
■ enables corrective actions to take place before the business service is affected

For detailed information about BMC Batch Impact Manager, see the CONTROL-M 
Business Service Management Solution User Guide.
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BMC Batch Impact Manager integration
BMC Batch Impact Manager is fully integrated into CONTROL-M/EM. This 
integration includes the ability to

■ monitor critical batch services directly from the CONTROL-M/EM GUI using the 
Business Services view 

■ filter alerts and jobs according to their association with a critical batch service

■ navigate from a job in a critical batch service to its position in the flow diagram, 
and back to the service

Certain BMC Batch Impact Manager features are available directly within 
CONTROL-M/EM. Additional options, buttons, dialog boxes, and menu commands 
appear after BMC Batch Impact Manager is installed. Table 25 lists these options and 
their locations.

Table 25 Where to look for integrated features in CONTROL-M/EM  (part 1 of 2)

Feature Location

monitoring and managing the status of 
services

the Business Services window, accessed by 
choosing Tools => Batch Impact Manager => 
Business Services 

(See “Using CONTROL-M/EM to track 
business services” on page 245.)

filtering alerts that originated from BMC 
Batch Impact Manager 

the Origin box in the Alerts window, accessed 
by choosing View => Alerts

specifying BMC Batch Impact Manager as a 
criterion when filtering 

the Included in Business Service check-box in 
the following dialog boxes: 

■ Dynamic Filter dialog box in 
CONTROL-M/EM

■ Find/Select Jobs dialog box in both 
CONTROL-M/EM and 
CONTROL-M/Desktop

navigating between nodes and their 
corresponding services

right-clicking the node in the flow diagram, and 
choosing the Services => Business Services 
option

opening all jobs associated with a service 
into a new flow diagram

right-clicking the node in the flow diagram or 
the Alerts window, and choosing the Services 
=> Open into ViewPoint option
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For information about using these features, see the CONTROL-M Business Service 
Management Solution User Guide.

Using CONTROL-M/EM to track business 
services

BMC Batch Impact Manager services can be monitored in the CONTROL-M/EM 
Business Services window. 

Figure 20 CONTROL-M/EM Business Services window

updating the refresh interval for the 
Business Service window

specifying a value for the Refresh Business 
Services Window parameter under Tools => 
Options

defining run times for exceptional cases 
(for example, jobs that require more time 
on a weekday than on the weekend)

■ the Exceptions box, accessed by choosing 
Tools => Batch Impact Manager => 
Exceptions

■ the Periods box, accessed by choosing 
Tools => Batch Impact Manager => 
Periods

Table 25 Where to look for integrated features in CONTROL-M/EM  (part 2 of 2)

Feature Location
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To monitor services from within CONTROL-M/EM

1 Choose Tools => Batch Impact Manager => Business Services from 
CONTROL-M/EM.

The Business Services window is displayed, showing services, their status, and 
other relevant information such as their estimated completion times, and the 
number of jobs in the service that have already completed.

2 You can perform the following functions by right-clicking on the selected service:

■ Refresh the service by choosing View => Refresh.

■ View additional details for a service by selecting the service and then choosing 
Service => View Details (or by double-clicking a specific service). 

In the Service Details window you can select an individual job and perform 
various actions on that job. Also, you can click the Tickets button to view 
information about Remedy tickets that were opened.

■ Open all the jobs of the service in a new flow diagram by choosing Service => 
Open into ViewPoint.

■ View the log of the service by choosing Service => Service Log. The log provides 
information about changes in the service’s status and the reasons for the 
respective changes. You can select an entry and view the details for the entry, 
using the Service Details window.

■ Jump to the BMC Batch Impact Manager job that defines the service in the 
currently-open flow diagram by selecting the service and choosing Service => 
Find Job.

■ Update the deadline for a service by selecting the service and choosing Service 
=> Update Deadline.

NOTE  
The word Disconnected in the title bar and the  icon at the bottom of the 
window indicate when the BMC Batch Impact Manager Server is down. When the BMC Batch 
Impact Manager Server is down, you cannot use this window to track services.

NOTE  
The default refresh interval for refreshing the Business Services window is one minute. 
This default can be modified by changing the Refresh Business Services Window 
parameter under Tools => Options.
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■ Open the job editing form for the BMC Batch Impact Manager job of the service 
in browse mode by selecting the service and choosing Service => Properties.
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Part 5Analyzing and optimizing the 
production environment

This part presents the following topics:
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C h a p t e r 23
23  Introduction to analyzing and 
optimizing production

This chapter presents the following topics:

Analyzing and optimizing the system . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  251
Where to go from here. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  251

Analyzing and optimizing the system
After CONTROL-M job scheduling has been implemented, you can analyze the 
system for problems such as bottlenecks (tasks running over their deadlines), 
resource shortages, poor workload balancing, and so on. Through analysis, you can 
identify the root causes of problems, and determine the potential impact of 
implementing changes, such as adding applications or changing resources. 

Performing analyses can not only help you eliminate problems, they can help you 
optimize the system. The information provided in this part of the book deals with the 
task of analyzing and optimizing the system. 

Where to go from here
Several tools are available to help you analyze your production environment.

■ To generate reports about various aspects of the production environment, see 
Chapter 24, “Defining and generating reports.”.

■ To archive each day’s processing events and then review them as needed, see 
Chapter 25, “Viewing and playing back archived data.”
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■ To determine the likely impact of potential changes to the system (for example, 
adding or deleting applications or resources), see Chapter 26, “Planning 
production with CONTROL-M/Forecast.”
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C h a p t e r 24
24  Defining and generating reports

This chapter presents the following topics:

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  253
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Displaying and working with reports. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  258
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Using command line parameters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  264
Input arguments file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  265
Using the Report tab (optional) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  268
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CONTROL-M/Forecast report types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  273
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Introduction
The CONTROL-M Reporting facility enables you to define templates that you can use 
to generate reports that provide you with important information about your 
CONTROL-M installation. Beginning with CONTROL-M/EM version 6.2.01, the 
reporting facility uses the Crystal Report application to produce reports. Users must 
have Administrator privileges on a computer to generate reports on that computer.

Report files and report template files are saved locally as .rpt files.
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You can include variables in report templates, and then supply the values for the 
variables when the report is generated. The report will then vary depending to the 
values you supply. (You supply the dynamic values using pop-up dialogs if you are 
working online, or in an arguments file if you are generating the reports in batch.) 

Starting the CONTROL-M Reporting facility
Though you can generate reports in batch, it is much more common to work online, 
in the CONTROL-M Reporting facility window. 

To start the CONTROL-M Reporting facility

In Microsoft Windows, choose Start => Programs => CONTROL-M Enterprise Manager 
6.4.01 => Reporting Facility, and then log in.

The CONTROL-M Reporting facility window opens, displaying the Reporting 
Facility Start Page. (Figure 21 on page 255).

NOTE  
You can customize CONTROL-M Reporting facility defaults. For details, see Appendix A, 
“Customizing the interfaces.”
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Figure 21 Reporting Facility Start Page window

Changing CONTROL-M/EM environments for reporting

The CONTROL-M Reporting facility connects to one CONTROL-M/EM 
environment (database) at a time. However, many installations have multiple 
CONTROL-M/EM environments (for example, development and production). It 
might therefore be necessary to change the CONTROL-M Reporting facility 
configuration to point to a different CONTROL-M/EM environment. (Before 
connecting to a CONTROL-M/EM database, the CONTROL-M Reporting facility 
connects to a GUI Server and verifies authorization settings.)
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To change the CONTROL-M Reporting facility configuration to point to a 
different CONTROL-M/EM environment

1 In the CONTROL-M Reporting facility login screen that is connected to the 
CONTROL-M/EM database where you want to create reports, select the 
appropriate GUI Server.

The database connection properties are taken from the EM_install_dir\ini\mcs.ini 
file on the CONTROL-M/EM client computer. (The client computer should have a 
separate mcs.ini source file defined for each CONTROL-M/EM database.) 

2 Adjust the database connection properties for the particular CONTROL-M/EM, as 
follows:

A Without overwriting your source files, set the source file of the target 
CONTROL-M as the mcs.ini file (for example, you can copy and rename files 
when you switch them).

B If the environments have different emuser database passwords, run the cryptocli 
utility on the file to adjust the password.

C If the environments have different database server names, manually correct the 
name for the target CONTROL-M/EM.

NOTE  
If this GUI Server connects to a different Naming Service, you first must click the 
Advanced button and change the Naming Service host name and port. The other GUI 
Servers in the list of servers will then be displayed for that Naming Service.

NOTE  
When changing CONTROL-M/EM environments for the CONTROL-M Reporting 
facility, you must ensure that the appropriate mcs.ini file is in place.
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3 Adjust the database connection properties for the database client (this is a one-time 
step):

■ For Oracle E-Business Suite, adjust the tnsnames.ora file, located in the 
OracleInstallationFolder\network\Admin\folder, so that there is an additional 
entry for the other database to which you are connecting.

■ For Sybase 12.5 or earlier, use the OLE DB configuration manager by running 
sydaadm.exe, located in the SybaseInstallationFolder\OLEDB\ folder, to define an 
additional entry for the other database to which you are connecting.

■ For Sybase 15 or later, use the Sybase ASE Data Source Administrator by 
running sybdrvadm.exe, located in the SybaseInstallationFolder\DataAccess\bin\ 
folder, to define an additional entry for the other database to which you are 
connecting. 

■ For MS-SQL, adjust the data source definition, by choosing Adminitrative 
Tools=>Data Sources (ODBC), so that there is an additional entry for the other 
database to which you are connecting.

■ For PostgreSQL, adjust the data source definition, by choosing Adminitrative 
Tools=>Data Sources (ODBC), so that there is an additional entry for the other 
database to which you are connecting.

EXAMPLE  
Assume that the CONTROL-M Reporting facility currently points to the production 
CONTROL-M/EM, and you want it to point to the qa CONTROL-M/EM. Also assume the 
following files exist:

■ mcs.ini.prod   (source production version)
■ mcs.ini.qa       (source qa version)
■ mcs.ini           (active file, currently a copy of the production version)

To switch to the qa version

Copy the mcs.ini.qa file, and rename the copy mcs.ini, ensuring that it overwrites the 
existing mcs.ini file.
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Generating a report

To generate a report

1 In the Reporting Facility Start Page, in the Create Report from Template area, select a 
template.

2 If the report was defined with variables that require input values at the time of 
report generation, the Enter Parameter Values dialog box opens. In this case, do the 
following for each parameter listed in the Parameter Fields area:

A Select a parameter.

B Specify a value in the Discrete Value field, and click OK. 

A new report is generated from the template and displayed in the Report Preview 
Window.

Displaying and working with reports
When you generate a report, it is automatically displayed in the Report Preview 
window. You can also display any previously run report that has been saved.

To display a previously run report

In the Reporting Facility Start Page, select the report in the Open Existing Report list 
box. (To browse additional reports stored on your computer or network by clicking 
More Reports in the list box.)

The selected report is displayed in the Report Preview window, one page at a time. 
The Group Tree pane at the left displays the list of groups in the report.

NOTE  
An asterisk following the report name in the tab in the task bar indicates that the data has not 
been saved (that is, the report is new or has been refreshed).
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In the Report Preview window, you can do the following:

 

Defining templates and single-use reports
You define templates and single-use reports using the Report Wizard. The 
CONTROL-M Reporting facility supplies a fixed, predefined set of report types (for 
example, Alerts Report), and each template or report that you define must be of one 
of these predefined types. When defining templates and reports, consider the 
following: 

■ If you expect to run the report only once, you can create the report definition 
without defining a template.

■ If you expect to generate the report more than once, you can define a report 
template.

Task How to

refresh the data displayed in the report Click the Refresh button ( ), or choose 
Edit => Refresh Report Data 

toggle between showing and hiding 
the Group Tree

Click the toggle button ( ) or choose View => 
Group Tree

jump to the display for a particular 
group in the Report pane

Click its name in the Group tree.

navigate through report pages Click the First ( ), Back ( ), Next ( ), and Last 
( ) navigation buttons as needed. 

go to a specific report page Choose Edit => Go To. 

perform a text search Choose Edit => Find.

export the report  Choose File => Export. (Alternatively, you can use 
the emreportcli utility. For details, see “Generating 
and exporting reports in batch” on page 263.)

Note: Exported reports are saved locally, and can 
later be imported into other reporting applications 
or data manipulation tools. 

save your current report definition in a 
report template

Choose File => Save As Template.
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■ If you plan to use different source data criteria (for example, a different source 
CONTROL-M, or different filtering criteria) whenever you regenerate the report, 
you can

— define dynamic parameters that enable you to specify the desired sources at 
runtime, or 

— define a different report template for each data source (so that runtime input is 
not required).

■ When defining a report template, you can begin with an empty report template, or 
copy a similar report template and modify it as needed. 

To create or update a report template

1 In the CONTROL-M Reporting facility window, open the Template Manager by 
choosing Tools => Report Template Manager or clicking ( ).

2 Do one of the following:

■ To create a new report template

—  In the Report Template Manager toolbar, click  (New Template).

The New Template dialog box opens. The left pane displays several report 
categories representing different types of data environments (for example, 
Active or Definition environment). The right pane displays the report types 
available for a particular category. The report type display varies according 
to the selected category. 

For a brief description of available report types, see “Available report types” 
on page 270.

—  In the left pane of the New Template dialog box, select the appropriate 
category (select All Reports to display all report types in the right pane). 
Then, in the right pane, select the report type.

— Enter a name for the report (template) that you are creating and click OK.

■ To edit an existing template

— In the Report Template Manager, select the template and click  (Edit 
Template) in the toolbar.



Defining templates and single-use reports

Chapter 24    Defining and generating reports 261

The first panel of the Report Wizard (the General panel) is displayed.

3 Fill in (or modify) the fields of the Report Wizard panels. Most fields on most 
panels are self-explanatory. The following hints will help regarding specific panels 
and fields:

■ General panel

— In the description field, to move to the next line in the description area, press 
Ctrl + Enter. 

■ Data Source panel

— To add a mask to the selected source CONTROL-Ms, you should click the 
Mask button individually for each relevant CONTROL-M. You can specify * 
and ? as wildcards in the mask.

— Ensure that you specify the network from which the report data will be 
loaded.

— For the Data Source panel for the Active Links report only: To produce a 
Global Links report, click Produce Global Links Report. In this case, the 
CONTROL-M list areas appear twice rather than once. In the top list, select 
the source CONTROL-Ms; in the bottom list, select the target CONTROL-Ms.

■ Filter panel

— For each filtering field, select the field name, operator and value.

— If the value to be used for filtering on the field should be dynamically 
specified when the report is run, click Param. In this case, in the Value/Param 
Name field, specify the parameter name to be used at run time to prompt for a 
value. (If no previous Value/Param Name is set as the default, the Value/Param 
Name value automatically defaults to the Field Name (for example, Odate). 

In the Value/Param Name field, you can specify * and ? wildcards, the ! symbol 
for Not logic, and the , symbol for Or logic; in this case, ensure that you set 
the operator to Like.

NOTE  
 The LIKE and = operators work the same, except that

■ the = operator treats * and ? characters specified in the value as literals
■ the LIKE operator treats * and ? characters specified in the value as wildcards
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— For entries that you want to appear in the panel the next time you create a 
new report or template of this type, click Fix.

— For Alerts reports, you can use the Origin field to specify the alert type to 
include in the report (all alerts, only regular alerts, or only alerts originating 
from BMC Batch Impact Manager).

— For the Filter panel for the Links Definition report only: To produce a Global 
Links report, click the Produce Global Links Report checkbox.

— For the Filter panel for the Audit report only: In the Audit Type field, select 
the type of Audit data that should be retrieved, or select <All> if all Audit 
types should be included. In the Audit Operation field, select the type of Audit 
operation data that should be retrieved, or select <All> if all operations of the 
selected Audit type should be included. (The list displayed in the Audit 
Operation field depends on your selection in the Audit Type field. If Audit 
Type <All> is selected, the Audit Operation field is disabled.)

Example

Jobname LIKE A*,B*
Application LIKE !APPL*

Explanation: Retrieve all jobs whose jobname begins with A or B, but whose 
application names do not start with APPL. 

■ Fields panel

— After selecting fields to appear in the report, you can reposition fields by 
selecting a field and either dragging or clicking the up and down arrows.

■ Group By panel

— Use this panel to define the fields by which report rows will be grouped. The 
criteria you define are used to create the branches and sub-branches in the 
Group By navigation tree.

Do not confuse Group By criteria with the Sort criteria defined in the Sort 
panel. Data are first organized according to Group By criteria, and only then, 
within the group, are they sorted according to Sort criteria.

EXAMPLE  
To enable dynamic specification of the relevant job name at runtime, define the Job Name 
parameter in the report template with a variable (for example, Job Name Like MyJobs). At 
runtime, the user will supply a value (for example, J*) for the variable, and the report data will 
be retrieved for the corresponding jobs.
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To create a one-time report

1 In the Reporting Facility Start Page, choose File => New or click ( ). 

2 In the New Report dialog box, click Create Report Using the Report Wizard.

The New Template dialog box opens. The left pane displays several report 
categories representing different types of data environments (for example, Active 
or Definition environment). The right pane displays the report types available for a 
particular category. The report type display varies according to the selected 
category. For a brief description of available report types, see “Available report 
types” on page 270.

3 In the left pane of the New Template dialog box, select the appropriate category 
(select All Reports to display all report types in the right pane). Then, in the right 
pane, select the report type.

4 Fill in the fields of the Report Wizard panels. Most fields on most panels are 
self-explanatory. For hints on filling in the panels, see the hints in step 3 on 
page 261.

5 When you have finished defining the report, if you decide you want to save it as a 
template, click the appropriate field in the Summary panel and specify a name for 
the template.

Generating and exporting reports in batch
The emreportcli command line utility generates reports in a selected format. This 
utility runs only on Microsoft Windows in batch mode. 

TIP  
You can perform the following tasks using the buttons of the Report Template Manager 
toolbar:

■ Copy a template, using the Copy template button ( ).
■ Delete a template by selecting it and clicking the Delete template button ( ).

NOTE  
You must specify CONTROL-M/EM server login information when you invoke this utility.
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One of the following options can be used to activate the emreportcli utility:

■ parameters can be entered as command line parameters 
■ an input arguments file can be generated with XML specifications
■ report generation parameters can be entered in CONTROL-M/Desktop

Using command line parameters

The emreportcli utility can be activated by entering command line parameters as 
follows:

emreportcli {-u <user> -p <password> | -pf <password file>} -s <server 
host name> 

-template  <templateName> 

[-template_path <template path>]

-output_file_type EXCEL | EXCEL_DO | DOC | PDF | HTML |
XML | CSV | TABBED

-output_file_path <output file path> 

[-param <name>=<value>]…

Table 26 emreportcli parameters

Element Attribute Description

OutputFile The report output file. 

type Specifies the type of the output file, such as EXCEL, 
EXCEL_DO (for data only), PDF, DOC, HTML, TXT, or 
XML.

file path Specifies the full filename of the output file. 

Param Specifies the mane and value for each parameter in the 
form name=value. Wildcard can be used for text fields.

Template Specifies the name of the template.

path Specifies the folder in which the template file is located.
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Input arguments file

Input for the utility is an arguments file containing the XML specifications for the 
report to be generated, including all required parameters. The following sample XML 
arguments file is provided at  em_home\Data\Reporting\sample_args.xml. A list 
of required elements and values for the arguments is provided in the DTD file:  
em_home\Data\Reporting\emreportcli.dtd.

The emreportcli input arguments file parameters are described in Table 27.

Syntax

emreportcli {-u <user> -p <password> | -pf <password file>} -s 
<server host name> -arg <XML file name>
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Table 27 emreportcli utility input arguments file description 

Element Attribute Description

SourceFile The template used to generate the report.

templateName specifies the name of the template 

templatePath specifies the folder where the template file is located 
(Optional)

OutputFile  The report output file. 

type specifies the type of the output file, such as EXCEL, 
EXCEL_DO (for data only), PDF, DOC, HTML, TXT, or 
XML

filePath specifies the full filename of the output file (which will 
be overwritten if it previously existed) 

Note: The following dynamically resolved keys can be 
included when specifying the filepath attribute: {date}, 
{time}, and {counter}. 

For example

■ For filepath=D:\Test.doc (that is, no key), the 
output file is: D:\Test.doc.

■ For filepath=D:\Test-{date}.doc, the output file is 
D:\Test-May22, 2008.doc.

■ For filepath=D:\Test{counter}.doc, the first output 
file is D:\Test1.doc, and the next output file is 
D:\Test2.doc.

Parameters The parameter list. 

Parameter An individual parameter, whose name and value is 
specified. 

name name of the parameter as defined in the report template 
filter panel

value value of the report parameter (wildcard characters can 
be used for text fields when the field operator in the 
filter panel is set to "LIKE" for the fields)

EXAMPLE  
<!DOCTYPE ReportDefinitions SYSTEM "emreportcli.dtd">
<ReportDefinitions>
       <ReportDefinition>
              <SourceFile templateName="alerts3"/>
              <OutputFile type="PDF" filepath="D:\MyAlerts3.pdf"/>
              <Parameters>
                    <Parameter name="MY_PARAM" value="job*"/>
                    <Parameter name="Application" value="a*"/>
              </Parameters>
       </ReportDefinition>
</ReportDefinitions>
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With the input arguments file in the above example, the emreportcli generates a PDF 
report based on the “alerts3“ report template and saves it in the D:\ folder with the 
filename called MyAlerts3.pdf.

If the report template filter is defined as shown in Figure 22, the output of the report 
will contain all alerts with a 

■ CONTROL-M name of "ctm640" or that starts with "mvs"
■ Job Name that starts with "job"
■ Application name that starts with "a"

Figure 22 Report template filter definition

The last two field filter values are set dynamically from the XML arguments file.

To use the emreportcli report generation utility 

1 Open a command prompt window.

2 Enter the following command and press Enter. 

emreportcli [{(-U emUser -P emPass) | -pf passwordFilename}] 
-s emServer -arg xmlArgumentsFile

NOTE  
You can specify the user name and password on the command line, in a password file.



Using the Report tab (optional)

268 CONTROL-M User Guide

The parameters in this command are described in Table 28.

Using the Report tab (optional)

The following procedure loads the Report tab to CONTROL-M/Desktop, enabling 
the user to define report jobs for CONTROL-M. The emreportcli job parameters are 
displayed in the Report tab, which is displayed in the job editing form in 
CONTROL-M/Desktop and CONTROL-M/EM GUI.

Before you begin

Ensure that the CONTROL-M/Agent application CD is easily accessible through 
your network.

To import the Report tab

Perform this procedure on every computer that has CONTROL-M/Enterprise 
Manager client component(s) installed.

1 In CONTROL-M/Desktop, choose Tools => Import Applications Forms. A browse 
window is displayed.

2 Navigate to the Forms directory on the installation CD. Select the emreportcli .xml 
file and click Import.

3 Shut down the CONTROL-M/Enterprise Manager GUI, and then restart it. This 
enables the newly imported Report tab functionality.

Table 28 emreportcli report generation utility parameters 

Parameter Description

emUser CONTROL-M/Enterprise Manager user name.

emPass CONTROL-M/Enterprise Manager user password.

passwordFilename Flat file containing an unencrypted username and password in the 
following format: user=username password=password
Note: If both -U and -pf are specified, an error message is generated. If 
neither is specified, an online prompt is issued for the CONTROL-M/EM 
database owner name and password.

emServer Host name of the CONTROL-M/EM Server.
Note: To address a GUI Server when multiple GUI Servers exist, set this 
parameter to the logical name of the relevant GUI Server.

xmlArgumentsFile Full path and name of the input arguments file.
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Figure 23 emreportcli - Report tab

For more information about the parameters in the Report tab, see Table 27 on 
page 266 and Table 28 on page 268. For more information about the Job Editing 
form, see Chapter 4, “Defining how jobs should run.”

NOTE  
 In the File Path field in the General tab of the job editing form, the user must enter the EM bin 
folder location (for example: C:\Program Files\BMC Software\CONTROL-M EM 
6.4.01\Default\bin).

The File Name field in the General tab of the job editing form is mapped to the Template field 
in the Report tab. Changing either one of them will change the other.

A maximum of five parameters can be specified in the Report Parameters table.

Run this job on a computer running Microsoft Windows, which has CONTROL-M/Enterprise 
Manager (version 6.4.01 or higher) with the Reporting Facility installed on it.
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Available report types
Report types are categorized as follows:

■ Active — data for the report are taken from the Active environment
■ Definition — data for the report are taken from the Definition environment
■ General — included in this category are the Alerts report and Audit report
■ BIM — reports for sites operating BMC Batch Impact Manager
■ Forecast — reports for sites operating CONTROL-M/Forecast

For convenience, there is also an All category that lists all report types.

Available report types are described on the following pages, grouped by category.

Active report types

■ Active Jobs report — lists all jobs and job details determined by selection and 
display criteria. It also includes a count of the number of jobs contained in the 
report. Note that multiple jobs having the same name can be in the same or 
different scheduling (or group scheduling) tables.

■ Prerequisite Conditions report — lists conditions according to selection and 
display criteria. This report is also called the Conditions report. The report is 
similar to the information displayed when Tools => Prerequisite Conditions is 
accessed from CONTROL-M/EM or CONTROL-M/Desktop.

■ Control Resources report — lists control resources and their attributes according to 
selection and display criteria. The information in the report is similar to the 
information displayed when Tools => Control Resources is accessed from 
CONTROL-M/EM or CONTROL-M/Desktop.

NOTE  
■ Several sample report templates are provided with the CONTROL-M Reporting facility 

during installation. When you generate sample outputs using these templates, you might 
in some cases be prompted to supply input parameter values.

■ In addition to the reports described on the following pages, some reports (for example, the 
Forecast Analysis set of reports, including the Workload report and the Trend Analysis 
report) are available only if you purchased other BMC Software products, such as 
CONTROL-M/Forecast. (Only administrators can run CONTROL-M/Forecast reports). 
For details, see “CONTROL-M/Forecast report types” on page 273.



Definition report types

Chapter 24    Defining and generating reports 271

■ Quantitative Resources report — lists quantitative resources and their attributes 
according to selection and display criteria. The report is similar to the information 
displayed when Tools => Quantitative Resources is accessed from 
CONTROL-M/EM or CONTROL-M/Desktop.

■ Active Links report — shows the links (dependencies) defined between all jobs or 
between selected jobs, as determined by selection and display criteria. Global 
conditions are also included in this report. For example, you can list all the 
dependencies and global conditions that are defined in a specific data center, or 
only those defined between two groups.

■ Active Group Errors report — performs validity checks and lists those groups, 
applications, or scheduling tables that contain only one job. A group with only one 
job can be valid, but the list might reveal spelling errors in the job definition’s 
Group field. For example, assume a group named SALARY, which is made up of a 
number of jobs. A new job, JOB_X, is added to this group, but the user specified a 
group called SALARIES. This generates a new group named SALARIES with a 
single job, JOB_X.

■ Active Loop Errors report — performs validity checks on the current network and 
lists any job that contains matching IN and OUT conditions (with + sign).

■  Active Manual report — performs validity checks and lists the In conditions in 
each active job that do not also appear as added OUT conditions in another active 
job. Although such conditions normally reflect manual conditions, they can also 
reflect omitted Out conditions, or misspelled In or Out conditions.

Definition report types

■  Job Definitions report — lists all jobs and job details determined by selection and 
display criteria. It also includes a count of the number of jobs contained in the 
report. Note that in the case of multiple jobs, these can be from the same or 
different scheduling (or group scheduling) tables.

■ Table Definitions report — lists all tables and table details determined by selection 
and display criteria. 

■ Links Definition report — shows the links (dependencies) defined between all jobs 
or between selected jobs, as determined by selection and display criteria. Global 
conditions are also included in this report. For example, you can list all the 
dependencies and global conditions that are defined in a specific data center, or 
only those defined between two groups.

■ Definitions Group Errors report — performs validity checks and lists applications, 
groups, or scheduling tables that contains only one job.
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A group with only one job can be valid, but the list might reveal spelling errors in 
the job definition’s Group field. For example, assume a group named SALARY, 
which is made up of a number of jobs. A new job, JOB_X, is added to this group, 
but the user specified a group called SALARIES. This generates a new group 
named SALARIES with a single job JOB_X.

■ Definitions Loop Errors report — performs validity checks and lists any job (active 
and definition) that contains matching IN and OUT conditions (with + sign).

■ Manual Definitions report — performs validity checks and lists any IN condition 
that is not defined as an OUT condition of another job. Though manual conditions 
normally have no corresponding OUT conditions, the listed conditions might 
nevertheless reveal omissions and spelling errors.

General report types

■ Alerts report — lists alerts sent to the Alerts window.

■ Audit report — lists the results of auditing CONTROL-M/EM server for 
operations of a selected audit type. For example, changes in job and calendar 
definitions can be tracked. 

■ Workload Distribution report — for each day, for each CONTROL-M/Server, the 
report lists and includes the following counts from the day’s data: total number of 
jobs, their breakdown by task type, node ID and application type, and the number 
of executions. The current day’s figures are not included in the report.

■ Extreme Peak Usage report — for a user-specified period, the report provides 
(according to the user request) one of the following sets of figures:

— highest number of tasks and executions that occurred on a single day on a single 
CONTROL-M/Server during that period, and their breakdown by task type, 
node ID and application type.

— lowest number of tasks and executions that occurred on a single day on a single 
CONTROL-M/Server during that period, and their breakdown by task type, 
node ID and application type.

— the average number of tasks and executions to occur during that period, and 
their breakdown by task type, node ID and application type.

The report also includes summaries for the whole environment for the period, 
including of the number tasks and executions, by CONTROL-M/Server.



BMC Batch Impact Manager report types

Chapter 24    Defining and generating reports 273

BMC Batch Impact Manager report types

■ SLA Analysis report — for a specified service, for a specified period of time, this 
report displays the number of executions that ended as follows: ended on time, 
ended late, or did not complete execution.

■ History report — for a specified period of time, this report details which services 
executed, when they executed, and the execution completion status.

■ Detailed Business Service report — for a specific service execution, this report 
provides a summary that includes the service name, date, completion status and 
related job details.

■ Service–Jobs report — for a selected BIM service, this report lists its associated jobs 
in the Active environment. (This BIM report is an Active report type.)

■ Jobs–Service report — for a selected job, this report lists its associated BIM services 
in the Active environment. (This BIM report is an Active report type.)

CONTROL-M/Forecast report types

The following reports, which are useful for evaluating trends, are available in the 
Forecast Analysis section. These reports are available to administrators only.

■ Workload report — lists the total number and names of jobs that ran during a 
specific time frame. The output is produced in both graphic and table formats. 

■ Trend Analysis report — lists the number of jobs that started during a specific time 
period in history, such as the first week of every month, or the last day of every 
week. 

■ Jobs Execution report — lists the jobs with information, such as start time, end 
time, and average run time. You can group job execution information by time 
segment. 

Converting old reports
A menu option in the Start Page lets you migrate (convert) old report definitions—
from CONTROL-M/EM versions 6.0.xx and 6.1.xx to definitions supported by a 
CONTROL-M/EM 6.2.01 and later.
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To migrate old reports

1 In the CONTROL-M Reporting facility, select Tools = Convert/Import Old 
Reports.

2 In the Import Old Reports dialog box that is displayed, specify, or browse to and 
select, your old CONTROL-M/EM home directory (and click OK).

The display area lists your old reports, grouped by report type. You can expand or 
collapse the display.

3 Select or report types that you want imported, and click Import.

The selected reports are converted and migrated to your current CONTROL-M/EM.
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C h a p t e r 25
25  Viewing and playing back archived 
data

This chapter presents the following topics:

Selecting and displaying archived ViewPoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  276
Playing back archived events . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  277

The Active Net consists of the data, conditions, and resources of jobs that occur in the 
Active Jobs file of a data center during the current day. 

At the beginning of each day, CONTROL-M/EM automatically archives the previous 
day’s Active Net from each data center. These Archived Nets include the recording of 
job changes, which can be played back much like a video recording. 

The Archived ViewPoints and Playback features enable you to review the 
information stored in Archived Nets, as follows:

■ Archived ViewPoint provides a static display of the jobs at the end of a day.

■ Playback provides a simulation (much like a recording) of production 
environment events — the jobs that ran and their status changes, during a day.

This information can help you review, track, and analyze problems of previous days. 
For example, the system manager might use these features every morning to review 
the previous night’s events. 

Users must have authorization to use these features.

NOTE  
In this context, the term “day” refers to the period between runs of the New Day procedure on 
a CONTROL-M/Server. Each run begins a new day.
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Selecting and displaying archived ViewPoints

To Select and display archived ViewPoints

1 In the CONTROL-M/EM GUI, select File => Open Archived ViewPoint, which 
displays the Nets list.

2 Select the CONTROL-M server, and then select a Net from the Nets list, and click 
Next, which displays the list of available ViewPoints.

3 Select the ViewPoint to be displayed. 

4 To filter the jobs that will be displayed in the archived ViewPoint, click Dynamic 
Filter. For information on Dynamic Filtering, see “Defining dynamic filters” on 
page 206.

5 Click Finish., which displays the selected archived ViewPoint is displayed in the 
CONTROL-M/EM GUI. 

Many functions available for regular ViewPoints are available for archived 
ViewPoints.

NOTE  
In the Archived Net listings, the Start Time and End Time values are taken from the 
computer where the Gateway ran. Their date values can differ from the listed Date value —
for example, due to time zone or New Day procedure differences.

NOTE  
■ If the total number of Archived jobs in the GUI server exceeds the value specified in the 

LimitArchiveJobsInMem system parameter, the ViewPoint will not be displayed. For 
more information, see the CONTROL-M Administrator Guide.

■ Only one Archived Net can be opened at a time in the Archive ViewPoint window. 
However more than one ViewPoint showing information from the same Archived Net 
can be displayed at one time, using the View => View Selection and Neighborhood 
=> Open ViewPoint options.

■ SYSOUT and Log functions are available only if there is communication between 
CONTROL-M/EM and the respective CONTROL-M/Servers. For z/OS, the functions 
are only available for jobs running under CONTROL-M for z/OS version 6.2.00 or 
later. SYSOUT will be available for other CONTROL-M jobs in CONTROL-M 6.2.00 or 
later.
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Playing back archived events
The Playback feature provides a toolbar for playing back production events in the 
displayed archived ViewPoint. It enables you to review events from a specific time, 
second by second, or from event to event, at the speed you require. 

To use the Playback feature

1 If the archived ViewPoint is not displayed, select and display it. For instructions, 
see “To Select and display archived ViewPoints” on page 276.

2 In the CONTROL-M/EM GUI, click  or choose Tools => Playback, which adds 
the playback toolbar to the CONTROL-M/EM GUI window.

3 Select the playback speed by selecting the number of units and the unit type 
(number of units/step) in the Speed combo-box fields.

4 Click Play ( ).

To intervene in the playback, you can use the other buttons and the slide control. 
You can also enter a specific time in the Time Display, and click Go.

NOTE  
■ If the Alerts window opens during Playback, it displays alerts from the current 

production environment and not from the archive that is currently being played back. 
This ensures that the user is always notified when an alert occurs even while the user is 
using the Playback Facility.

■ Hold, Free, Delete, Undelete, and Zoom and Save changes are not displayed in 
playback because they are not saved in the playback recording. 

■ During playback, jobs not yet ordered to the Active Jobs file have the status Not in AJF. 
This status is relevant to archived jobs in Playback only.
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C h a p t e r 26
26  Planning production with 
CONTROL-M/Forecast

This chapter presents the following topics:

Introduction to CONTROL-M/Forecast. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  279
CONTROL-M/Forecast integration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  280

Introduction to CONTROL-M/Forecast
CONTROL-M/Forecast adds forecasting capabilities to the CONTROL-M suite, 
letting you estimate your scheduling environment behavior with respect to specific 
dates in the future. Both graphic and tabular representations of the forecast provide 
the future dates on which a given job or a scheduling table is predicted to be 
submitted. In addition, CONTROL-M/Forecast generates an estimate of the full 
production flow for a given future date, as an enterprise-wide view.

CONTROL-M/Forecast is provided as an add-on to a pre-installed 
CONTROL-M/Enterprise Manager implementation. The product is integrated as 
options to the CONTROL-M/EM GUI, maintaining the same look and feel.

CONTROL-M/Forecast bases its projections on the data center’s new day procedures 
and user dailies. CONTROL-M/Forecast analyzes scheduling tables, user daily jobs, 
calendars, job dependencies (in and out conditions), time execution windows, 
CONTROL-M time zone settings, resources and priorities in the CONTROL-M/EM 
database and, based on existing statistics, estimates how jobs will run on specific 
days.

For detailed information about CONTROL-M/Forecast, see the CONTROL-M 
Business Service Management Solution User Guide.
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CONTROL-M/Forecast integration
CONTROL-M/Forecast features are available directly within 
CONTROL-M/Desktop. Additional options, buttons, dialog boxes, and menu 
commands appear after CONTROL-M/Forecast is installed. Table 29 lists these 
options and their locations.

Additional capabilities and tools provided with CONTROL-M/Forecast include 

■ Schedule forecast from the job editing form, group editing form and Scheduling 
Table Manager in CONTROL-M/Desktop 

The graphical display of the dates on which scheduling definitions are predicted to 
be submitted can be used as a tool for validating new and existing scheduling 
definitions. Forecasts are available for jobs, scheduling groups, and scheduling 
tags.

■ Identify late critical batch services in the forecast, when used with BMC Batch 
Impact Manager.

■ Use What-If scenarios to forecast the effects of potential changes to the scheduling 
environment. 

■ Additional reports in CONTROL-M/EM

Historical reports can help you identify trends of your production environments. 
You can, for example, learn and understand why your enterprise has missed SLAs. 
These reports can help you identify and correct main bottlenecks before there is a 
negative impact on production. For information about forecast related reports see 
“CONTROL-M/Forecast report types” on page 273.

CONTROL-M/Forecast estimates rely on historical data, fine-tuned by the user. 

You can use the util utility to import and export history and forecast information. For 
details, see the description of the utility in the CONTROL-M Utility Guide.
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Table 29 Where to look for integrated features in CONTROL-M/Desktop

Feature Location

validating scheduling definitions 
graphically for a single job 

the Schedule Forecast dialog box (window?), 
accessed from one of the following

■ the Scheduling panel in the job editing form
■ the Scheduling Tags panel in the group 

editing form

Specify the scheduling criteria and click one of 
the following:

■ Forecast (in the job editing form)
■ Tag Forecast (in the group editing form)
■ Group Forecast (in the group editing form)

validating scheduling criteria graphically 
for multiple nodes

the Schedule Forecast dialog box (window?), 
accessed by selecting the nodes in a flow 
diagram 

Right-click one of the nodes and choose 
Forecast from the pop-up menu.

validating scheduling criteria graphically 
for jobs in a scheduling table

the Scheduling Manager window, accessed by 
selecting Tools => Scheduling Table Manager

Click Forecast.

exporting the scheduling criteria the Choose Export Type dialog box, accessed by 
clicking Export and specifying the necessary 
details.

generating a forecast the Load Forecast dialog box, accessed by 
selecting File => Load Forecast

displaying a Gantt chart of the forecast the Gantt view, accessed by choosing View => 
Gantt.

identifying potential problems in the job 
flow

the Forecast Summary window, accessed by 
choosing View => Dockable Windows => 
Forecast Summary

quickly identifying critical batch services 
that will be late

the Forecast Business Services window, 
accessed by choosing Tools => Forecast 
Business Services

forecasting the effects of potential changes 
to the scheduling environment

apply a What-If Scenario to a forecast, by 
choosing File => Open=>Scenario

Select the name of a pre-defined scenario and 
choose Actions => Run Forecast.

generating historical reports to identify 
trends of the production environment

See “CONTROL-M/Forecast report types” on 
page 273.

increasing forecast accuracy by refining 
statistics collection definitions

See Chapter 11, “Setting up definitions for 
periodic statistics collection.”
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For information about using these features, see the CONTROL-M Business Service 
Management Solution User Guide.
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Part 6Appendixes
This part presents the following topics:

Appendix A
Customizing the interfaces. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 285

Appendix B
Examples for defining jobs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 307
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A p p e n d i x A
A  Customizing the interfaces

This appendix presents the following topics:

Changing your password . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  285
Adjusting list displays. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  285

Modifying list displays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  286
Customizing default options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  289

Setting options for CONTROL-M/Desktop  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  289
Setting options for CONTROL-M/EM. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  297
Setting options for the CONTROL-M Reporting facility. . . . . . . . . . . . . . . . . . . .  304

Changing your password

To change your password for the CONTROL-M/EM GUI, CONTROL-M/Desktop or 
CONTROL-M Reporting facility window

While displaying the window, choose Tools => Change Password, and in the Change 
Password dialog box, fill in your current and new password details and click OK.

Password changes made in one application window (for example 
CONTROL-M/EM) automatically apply to the other application windows.

Adjusting list displays
Certain dialog boxes display lists of items (for example, lists of CONTROL-M 
definitions or lists of prerequisite conditions) from which you can make a selection. 
Many list displays contain an Item counter at the bottom that indicates the number of 
items appearing in the list.
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You can modify many list displays, and perform other tasks in list displays. Two 
pop-up menus enable the various modification and other tasks:

■ Column header pop-up menu
■ List display pop-up menu

To display the column header pop-up menu

Right-click in the header of the column in the list display. 

Figure 24 Column header pop-up menu for list displays

This menu is used for performing most modifications. Changes made are saved and 
re-displayed the next time the list is displayed.

To display the list display pop-up menu

Click anywhere in the list display except the column header.

Figure 25 List Display Pop-up Menu

Modifying list displays

The following modifications can be made to list displays:

■ Toggle the Item Counter on and off 
■ Sort the list according the values in a column
■ Remove a column from the list
■ Add fields to the list display
■ Resize a column’s width
■ Reorder columns

Toggling the item counter is performed from the list display pop-up menu. The other 
modifications are performed from the columns headers or the column header pop-up 
menu.
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To display or hide the item count in a list display

Click Item Count in the list display pop-up menu.

To sort the list according to the values in a column

Perform one of the following:

■ Right-click the column header. Select Sort Ascending or Sort Descending. 

-or-

■ Click the column header. 

The selected column initially sorts in ascending order (default). Once the column is 
already being used as the sort column, each click of the column header toggles 
between ascending and descending sort.

An alphabetic sort is performed, except the Last Update column is sorted by date. The 
date format is determined by the locale setting of the computer. For information 
about how to change the date format, see the manual of your operating system.

To add a field to the display

1 Right-click the column header. Select the Field Chooser option.

The Field Chooser menu is displayed with the appropriate fields.

NOTE  
Not all list displays can be modified, and not all modifications are possible in modifiable 
list displays. Furthermore, some modifications require Administrator permissions.
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2 Click and drag the field from the Field Chooser menu to the wanted location in the 
column header of the list.

To remove a field from the display

Perform one of the following:

■ Right-click the column header and select Remove This Column.

■ Right-click the column header and select the Field Chooser menu. Then drag the 
header from the list to the Field Chooser.

To rearrange the fields in the display

Click and drag (right or left) the column header of the field to be moved.

To resize a column in the display according to its best fit

Perform one of the following:

■ Right-click the column header of the column to be adjusted and select Best Fit.

■ Double-click the header’s right border.

The column width is adjusted to fit the longest value in the column.

Performing other tasks in the list display

You can perform the following tasks from the List Display pop-up menu, which is 
displayed by right-clicking anywhere in the list display (except the column header).

■ Save the contents of the list display to a CSV file
■ Print the contents of the list display

To save the contents of a list display to a CSV file

Select Export to File in the pop-up menu of the list display, and perform the save in 
the Export to File dialog box.

.csv files are comma-delimited and can be used in applications such as Microsoft 
Excel.

To print the contents of a list display

Select the Print option in the pop-up menu of the list display.
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Customizing default options
You can customize various default options for CONTROL-M/Desktop, 
CONTROL-M/EM, and the CONTROL-M Reporting facility.

To customize default options

1 Depending on the window you want to customize, in the CONTROL-M/EM GUI, 
the CONTROL-M/Desktop window, or the CONTROL-M Reporting Facility 
window, choose Tools => Options.

2 Select the appropriate panel, change the defaults, and click Ok.

Default options are described on the following pages.

Setting options for CONTROL-M/Desktop

This section presents tables with setting options for the following defaults:

■ General defaults
■ Workspace defaults
■ Flow diagram defaults
■ Diagnostic defaults
■ Confirmation defaults
■ Forecast defaults
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General defaults

Table 30 General settings (General panel)  (part 1 of 2)

Field/option Default to be set

Click Always check the 
validity of jobs

CONTROL-M/Desktop should automatically check the validity of 
parameter values as they are entered in the job editing form. 

Note: If set to No (that is, not clicked), perform validity checks on all jobs in 
a draft using the Tools => Validity Checks option. For more information, 
see Appendix D, “Checking job processing definition validity.”

List all templates Determine the type of templates displayed in the template list box in the job 
editing form. 

■ Leave the check box blank to display the list of job scheduling 
definition templates only (default).

■ Click the check box to display the list of both job scheduling definition 
templates and scheduling group templates (in the job editing form).

Note: You can use a scheduling group template to create jobs within the 
group scheduling table

Display Tool Tips Display a tool tip whenever CONTROL-M/Desktop is started.

{Counter} Default number of jobs to be created using the Mass Job Create and Find 
and Update facilities. For more information, see Chapter 10, “Creating and 
updating many jobs at once.”

Click Enable Undo, and in the 
Undo Size field, set the 
number of actions that can be 
undone or redone (Default: 
100).

Enable actions performed in the Job Editing form to be undone or redone. 

Display Time Synonym Normally, time parameters (examples: Time from, Time until, Shout Late 
time) allow you to specify times ranging from 00:00 through 23:59 hours. 
However, if you check this option, you can specify time periods ranging 
from New Day time until New Day-plus-23:59. Example: If New Day time 
is 7:00 AM, this option allows you to specify a range from 07:00 until 30:59. 

Note: The Time Synonym option exists in CONTROL-M/Desktop, 
CONTROL-M/EM and the CONTROL-M Reporting facility. Anytime you 
change this option in one of these windows, the option is automatically 
changed in the other windows.

Connection Mode How CONTROL-M/Desktop should connect to CONTROL-M/EM. Select 
one of the following:

■ Automatic Connection. CONTROL-M/Desktop opens and closes the 
connection as necessary depending on selected actions.

■ Manual Connection. CONTROL-M/Desktop maintains an open 
connection with the CONTROL-M/EM GUI Server until the user closes 
the connection.
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Workspace defaults

Resolve job’s Author field 
conflict

How to handle situations where the name of the user performing a Write to 
CONTROL-M/EM does not match the name of the Author. Select one of 
the following:

■ Change Automatically — check this value if the author should 
automatically be reset without prompting the user for confirmation.

■ Prompt Before Changing — check this value to have 
CONTROL-M/EM prompt the user for confirmation before changing 
authorship. Default.

For more information, see the Security chapter in the CONTROL-M 
Administrator Guide.

Default Start Day of the Week First day of the week for use in the Week Days field in the job editing form. 

Note: This is the default value used for all data centers. A Start Day of the 
Week can also be specified for each CONTROL-M using the CONTROL-M 
Definition window. The value in the CONTROL-M definition window 
overrides the default value specified in the Options dialog box. 

Write before upload (in local 
workspace)

Automatically updates the CONTROL-M/EM database before updating 
the CONTROL-M database when you perform an upload.

Table 31 Workspace settings (General – Workspace panel)

Field/option Default to be set

Open ‘Load Jobs’ dialog when 
opening a new workspace 

Open the Load Jobs dialog box when you start CONTROL-M/Desktop.

Default Workspace Default workspace when you start CONTROL-M/Desktop: Local or 
Online.

Local Workspace Background 
Online Workspace Background 
Forecast Workspace Background 

Color settings. 

Table 30 General settings (General panel)  (part 2 of 2)

Field/option Default to be set
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Flow diagram defaults

Flowdiagram – General panel

Flowdiagram – Nodes panel

Table 32 General flow diagram settings (Flowdiagram – General panel)

Field/option Default to be set

Graph Placement Placement of parent job node in the flow diagram (right, middle, left). 
Default: Parent in the Middle. 

Click Maximize Downward Flow Flow diagram should be displayed as much as possible in vertical 
alignment rather than in horizontal alignment.

Click Minimize Graph Width Flow diagram should accommodate the available screen space.

Start Zoom Level Default magnification percentage of nodes displayed in Flow Diagram 
view when viewing a new network.Valid values are 10 through 400.

Table 33 Flow diagram node settings (Flowdiagram - Nodes panel)

Field/option Default to be set

Node Title Information to be displayed in the title bar of the node. Default: MemName

Note: If JOB_NAME/MEMNAME is selected for:
■ z/OS jobs —Mem Name is displayed
■ other jobs — Job Name is displayed

First Field Information to be displayed in the first field of the node body. 
Default: CONTROL-M Name

Second Field Information to be displayed in the second field of the node body. 
Default: CONTROL-M Name

Wrap field text in node Information in the job node should wrap to the next line. If not selected, the 
fields are truncated if necessary.

Node shape Shape for nodes in the Flow Diagram. Select one of the following:

■ Rounded — displays nodes with rounded corners.
■ Rectangle — displays nodes with square corners.

Double Click on item to: Function to be performed if a node is double-clicked in the Flow Diagram. 
Select one of the following.

■ Expand-item — Expand or Collapse function. Expands the selected 
node to display levels lower than the current selected node, or collapses 
the selected node to hide all lower levels. Note: This option is not 
available when condition nodes are displayed.

■ StepInto-Item — Step In function. Changes the Flow Diagram to 
display nodes one level lower than the current selected node. For more 
information, see “Focusing on different level nodes (stepping in and 
stepping out)” on page 38.
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Flowdiagram – Links panel

Table 34 Flow diagram condition settings (Flowdiagram – Links panel)

Field/option Default to be set

Display Condition nodes Condition nodes should be displayed in the Flow Diagram.

Display Do-Conditions (as 
dotted links)

Conditions created using the Do Condition parameter should be displayed. 
The link is indicated with dotted lines.

Display Out Conditions with 
minus sign (as dotted links)

Out Conditions that get deleted should be displayed. The link is indicated 
with dotted lines.

Display Optional In 
Condition as

How optional In conditions (for example, two In conditions separated by an 
OR operator) will be displayed —with solid or dotted lines.

Add Out condition with 
minus sign when creating job 
dependency

Automatically create Out conditions to delete the In conditions that you 
automatically create by dragging between nodes in the 
CONTROL-M/Desktop flow diagram. 

Condition format Default condition format to be used when you create job dependencies by 
dragging between job nodes in the CONTROL-M/Desktop flow diagram.

Delete only IN cond Delete the In condition when Delete Dependency is selected from a 
condition line pop-up menu.

Delete IN, OUT conds Delete both the In condition and the Out condition when Delete 
Dependency is selected from a condition line pop-up menu.

Ask what to delete Display the Delete Dependency dialog box. Default.

Automatically inherit job’s 
conditions if deleted

By default, when you delete a job from the flow diagram, you effectively 
sever the connection between the deleted job’s predecessor and successor 
jobs (because the In condition required by the successor job is no longer 
created by the deleted job). However, by checking this option, you can 
ensure that CONTROL-M/Desktop maintains the connection. In this case, 
CONTROL-M/Desktop automatically 

■ removes the dependency between the deleted job and its successor (by 
removing the Out condition of the deleted job and the In condition of 
the successor job that created the dependency).

■ creates a dependency between the predecessor and successor jobs of the 
deleted job (by adding as an In condition in the successor the Out 
condition of the predecessor).

This option works only when you are working in a Local workspace, and 
only if you delete one job at a time. If you delete multiple jobs in a single 
delete action, the connection is lost regardless of the setting.
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Flowdiagram – Colors panel

Diagnostic defaults

The Diagnostics panel helps troubleshoot technical problems with 
CONTROL-M/Desktop by printing diagnostics at the selected severity levels into a 
log file. The log file should then be sent to BMC Software Customer Support. 

Table 35 Flow diagram color settings (Flowdiagram – Colors panel)

Field/option Default to be set

(background) Background color settings are found in the General-Workspace panel.

Group/Application Color for all high-level nodes in the hierarchy.

Connector Color for In/Out condition triangles.

Frames Color for frames of nodes in Flow Diagram view and in Net Overview.

Condition Nodes Color for condition nodes.

Dependency Color for links (unselected).

Selected link Color for a link that has been selected.

Focused Node Color of the currently focused node.

Node Title Color for the node title.

First Field Color for the first field displayed in the node.

Second Field Color for the second field displayed in the node.

NOTE  
Use this panel only when instructed by BMC Software Customer Support. Your technical 
support representative will notify you which fields to change.

NOTE  
The changes to the settings take effect immediately, except for changes made to the Cyclic Log 
File field(s). Changes to Cyclic Log File field settings take affect the next time the specified 
CONTROL-M/Desktop application files are run.

Table 36 Diagnostic settings (Diagnostic panel) (part 1 of 2)

Field/option Default to be set

Log File Name Full name and path of the log file to which diagnostics should be printed. For 
display purposes only.

Enable Diag Print diagnostics to a log file. Default: Selected.
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Use Minimum Diag Level Diagnostic Level. Print all diagnostics to the log at the selected diagnostic level 
or higher, even if diagnostic levels specified in the Diagnostic Levels fields (see 
below) are lower than the value specified here. Values can be selected from the 
list, or entered manually (keyword or numeric code). Default: 1 ERROR. Valid 
values are: 

0 SEVERE

1 ERROR

2 WARNING

3 (General)

4 INFO

5 DEBUG

6 FNC_ENTER

7 FNC_EXIT

Only severe issues (crashes).

Error messages (CORBA exceptions, errors that can cause the 
application to malfunction or crash at a later time). Default.

Warning messages (unexpected events that do not stop the 
application but might limit functionality.

General events. 

Information about the basic functionality of the application.

More detailed information including the steps of an event, 
parameters, etc.

Every entrance to a function/method.

Every exit from a function/method.

Cyclic Log File (When checked) Print diagnostics to a set of log files (instead of one). Default: 
Not checked.

Number of Files Maximum number of files to which diagnostics are printed. Valid values: 
1-300. Default: 1.

Number of Messages Per 
File

Maximum number of messages that can be written to each cyclic log file. Valid 
values: 200-10000. Default: 200.

CONTROL-M/Desktop overwrites the existing log files (starting with the first 
in the set) if more diagnostics are generated than fit in the defined number of 
cyclic log files.

Changes to these fields take affect the next time the specified 
CONTROL-M/Desktop application files are run (not immediately).

Diagnostic Levels Individual diagnostic level settings for each file or context (procedure). See the 
Use Minimum Diag Level field for valid values.

Contexts tab Generate diagnostics on a procedural basis, at the level specified next to each 
context (procedure). Procedures listed in the Contexts tab can span several files 
or sub-procedures. When you change the level of a procedure, 
CONTROL-M/Desktop automatically changes the level of any 
sub-procedures.

Files tab Generate diagnostics on a file basis at the level specified next to each file name. 

Save settings for next runs Save diagnostic settings as a default for future CONTROL-M/Desktop 
sessions. Otherwise, the settings take effect for this CONTROL-M/Desktop 
session only.

Table 36 Diagnostic settings (Diagnostic panel) (part 2 of 2)

Field/option Default to be set
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Confirmation defaults

The Confirmations panel determines which confirmation requests and warnings 
should be displayed for various job, table, and calendar actions before you complete 
an action. Confirmation options are divided into the following sections:

■ Job Confirmations
■ Table Confirmations
■ Calendar Confirmations
■ General Confirmations

To set confirmations

1 Select or deselect the general confirmations that you want displayed.

2 To reassign the originally provided default settings, click Restore Defaults.

Forecast defaults

NOTE  
The Forecast panel and its defaults settings are only available if the Forecast facility is 
installed.

Table 37 Forecast settings (Forecast panel)  (part 1 of 2)

Field/option Default to be set

Color Settings Color of job nodes in the Forecast flow diagram. You can select the color for 
executed jobs, non-executed jobs, and the display of the execution time.

Start Day of the Week Day of the week on which a business week starts in the Forecast multiple 
nodes calendar display.

Maximum Jobs per Forecast 
Action 

Maximum number of jobs to be included in the Forecast multiple nodes 
calendar display.

Display execution time Time reference to be used when displaying the execution time in the job 
node or Gantt chart: local time or the time according to the 
CONTROL-M/Server.

Business Service Critical Path The critical path consists of the jobs in the Business Service that have the 
most impact on the completion time of the service. The critical path is 
indicated in the flow diagram by special markings on the job nodes. If 
Forecast predicts that the Business Service will be delayed, the user can 
examine the jobs in the critical path to determine what factors are delaying 
the jobs. Options:

■ Show complete path – The entire critical path is indicated. 
■ Show until first gap – Only the part of the critical path that has the 

most direct impact on the completion time is indicated.
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Setting options for CONTROL-M/EM

This section presents tables with setting options for the following defaults:

■ Environment defaults
■ Flow diagram defaults
■ Alerts defaults
■ Reconnection defaults
■ Diagnostics defaults
■ Confirmation defaults

Show CONTROL-M New Day 
indicators in Gantt view

Display red vertical lines in the Gantt chart that indicate the beginning of 
the New Day for each CONTROL-M.

Automatic ‘Run Forecast' on 
scenario update

Automatically run a forecast when the What-If scenario is changed.

Show 'What-If Scenario 
Window' on new What-If

Automatically open the What-If Scenario window when a new What-If 
event is created.

Table 37 Forecast settings (Forecast panel)  (part 2 of 2)

Field/option Default to be set
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Environment defaults

Environment General panel

Table 38 General environment settings (Environment General panel) 

Field/option Default to be set

Auto Open Viewpoint ■ To display an empty CONTROL-M/Enterprise Manager window when 
you start a CONTROL-M/EM session, leave the field unchecked. 
(Default.)

■ To automatically display a viewpoint when you start your 
CONTROL-M/EM session, click the check-box and select one of the 
following options:

■ To have the same viewpoint always open automatically, click Select, 
and select the viewpoint.

■ To have the last-opened viewpoint from the previous session open 
automatically, click Last Viewpoint.

■ To have the Open Viewpoint dialog box automatically displayed, 
enabling selection of a viewpoint for the current session, click Display 
“Open ViewPoint” dialog.

Enable JEF Undo up to n 
actions 

To enable Undo (or Redo) in the job editing form, click the option and select 
the number of Undo/Redo operations that can be performed. Default: 100. 

(To perform an Undo or Redo, click Ctrl+Z or Ctrl+Y in the job editing form.)

Display Tool Tips Display a tool tip whenever CONTROL-M/EM is started.

Do not receive updates while 
editing jobs

If someone else updates a job processing definition while you are editing it, 
by default you receive the updates. By checking this option, will not receive 
such updates. BMC Software recommends that you do NOT check this box.

Click Sort Presets by name Sort filter presets by name (otherwise, they will be sorted by the last modified 
date/time value.)

Browse and select in Preset 
path

Default location for filter presets.
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Environment Display panel

Table 39 Environment Display panel default settings

Field/option Default to be set

Reload active net When selected, enables information from CONTROL-M to be updated 
automatically in the CONTROL-M/EM GUI.

(If this option is not selected, you must click Refresh in the CONTROL-M/EM 
window, in order to display the latest changes in the production environment.)

Rebuild Flowdiagram 
when reload active net for 
minimum n jobs

Minimum number (n) of job changes (reloads or removals) that causes the flow 
diagram to be rebuilt from beginning to end rather than updated when the user 
clicks Refresh.

(Normally, when Refresh is clicked, the existing flow diagram is updated — 
that is, jobs are reloaded or unloaded as necessary. But if there are too many 
changes, this process is slow, and it quicker and more efficient to rebuild the 
flow diagram from beginning to end.)

Default: This option is checked and n is 100 (if there are 100 or more job 
reloads/removals, the flow diagram is rebuilt.)

Arrange All every n 
seconds 

How often to automatically refresh the flow diagram.

Refresh Business Services 
Window 

For BMC Batch Impact Manager users: How often (in seconds) to automatically 
refresh the Business Services window.

Reload resources list every 
n seconds

Enables automatic update of the status of resources in the Active environment 
as displayed in the Prerequisite Conditions, Control Resources and Quantitative 
Resources windows. The automatic update occurs at intervals according to the 
number of seconds specified.

Display status colors in 
Tree View

Display the colors indicating job status in the Navigation Tree. 

Hide empty scheduling 
groups

Do not display a group scheduling table in the flow diagram if no jobs in the 
table are scheduled.

Display scheduling 
groups count in Status Bar

Display the scheduling group count, after the job count, in the status bar.

Display Time Synonym Normally, time parameters (examples: Time from, Time until, Shout Late time) 
allow you to specify times ranging from 00:00 through 23:59 hours. However, if 
you check this option, you can specify time periods ranging from New Day time 
until New Day-plus-23:59. Example: If New Day time is 7:00 AM, this option 
allows you to specify a range from 07:00 until 30:59. 

Note: The Time Synonym option exists in CONTROL-M/Desktop, 
CONTROL-M/EM and the CONTROL-M Reporting facility. Anytime you 
change this option in one of these windows, the option is automatically changed 
in the other windows.

Display n last Jobs Actions 
in Report

Maximum number of job actions to be displayed in the Job Action Report 
window. If more than the specified number of messages are issued, the oldest 
messages are removed from the window. n can be any number from 10 to 999. 
Default: 200
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Flow diagram defaults

Flowdiagram General panel

Flowdiagram Nodes panel

The options of the CONTROL-M/EM Flowdiagram Nodes panel are the same as for 
the same panel in CONTROL-M/Desktop. For details, see Table 33 on page 292.

Flowdiagram Links panel

Except for the options described below, the options of the CONTROL-M/EM 
Flowdiagram Links panel are found in the corresponding panel in 
CONTROL-M/Desktop. For details, see Table 34 on page 293.

Field/option Default to be set

Smooth display When selected, prevents flickering of the display during navigation in the 
flow diagram.

Note: Selecting this option slows navigation.

Enable tooltip in low zoom When selected, enables the node title to be displayed as a tool tip (when the 
mouse pointer remains on the node).

Note: This option is relevant only for zoom of 40% or lower. With a zoom 
50% or higher, node titles are visible in the node. 

Graph Placement Placement of parent job node in the flow diagram (right, middle, left). 
Default: Parent in the Middle. 

Click Maximize Downward 
Flow

Flow diagram should be displayed as much as possible in vertical 
alignment rather than in horizontal alignment.

Click Minimize Graph Width Flow diagram should accommodate the available screen space.

Display n nodes in pack Indicates the number of nodes to display in each stack in the Net Overview. 
Default: 10 (This is also the minimum value for this field).

Display n nodes in separator In high-level nodes, the number of jobs in the node are displayed in a 
Histogram in the bottom of the node. This option defines the number of 
jobs to count as a unit for each level of the Histogram. The default (and 
minimum) value is 10.

Start Zoom Level Default magnification percentage of nodes displayed in Flow Diagram 
view when viewing a new network.Valid values are 10 through 400.

Field/option Default to be set

Display links behind nodes When selected, displays job dependencies as lines between jobs in the flow 
diagram. These dependencies are determined by Do Cond statements and 
IN conditions defined in job processing definitions.

Show links between jobs When selected, displays connector lines for job dependencies. These line 
represent conditions that are set using the Out condition parameter.
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Flowdiagram Colors panel

Except for the options described below, the options of the CONTROL-M/EM 
Flowdiagram Colors panel are found in the corresponding panel in 
CONTROL-M/Desktop. For details, see Table 35 on page 294.

Alerts defaults

The Alerts panel contains several default communication settings for the Global 
Alerts Server (GAS). 

Field/option Default to be set

Set Color for all high-level nodes in the hierarchy.

Archived Background Background color for archived ViewPoints.

Table 40 Alerts panel  

Field/option Default to be set

Click Automatically 
connect to Global 
Alerts Server and 
select the 
server_name

CONTROL-M/EM should automatically connect to the selected Global Alerts Server 
when accessing the Alerts window.

(The server can be changed from the Alerts window using the Communication => 
Disconnect and Communication => Connect option. For details, see Chapter 20, 
“Monitoring and handling alerts.”)

New Alert 
Notification area 

How CONTROL-M/EM should handle notification when it receives a new alerts. 
Click the appropriate button:

■ None - Do not provide any special notification.

■ Flash Alerts window on task bar - Flash the Alerts window button on the 
Microsoft Windows task bar.

■ Bring Alerts window to front - Open the Alerts window.

Open into Local 
View area

In the Alerts window, if you select an alert and choose Actions => Open into 
Viewpoint, the job that prompted the alert and the jobs having a dependency 
relationship with that job, will be displayed in a Viewpoint.

You can set the following defaults regarding this ViewPoint and the jobs it displays:

■ Use radius of n nodes - The level of dependencies for which jobs should be 
selected and displayed in the ViewPoint.

■ ViewPoint Name name - The ViewPoint into which the jobs should be displayed. 

BMC Software recommends that you choose a viewpoint having a collection of 
containing all jobs. If you choose a viewpoint that does not have a collection of all jobs

■ nodes not included in the collection will not be displayed.
■ non-pin collections will probably have poor response time.
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Reconnection defaults

The Reconnection panel contains several default settings for reconnecting to an 
alternative server if the connection to the CONTROL-M/EM GUI server is lost. 

CONTROL-M/EM attempts to (re)connect to the first server in a user-defined list of 
alternate servers. If this fails, CONTROL-M/EM attempts to reconnect to the next 
server in the list, and this process continues until there is a successful reconnection or 
until there are no more servers in the list. 

After there is a successful reconnection, CONTROL-M/EM continues to function 
using that alternate server as its GUI server, even restoring ViewPoints if desired. If 
CONTROL-M/EM cannot connect to any server, a message is displayed indicating 
that CONTROL-M/EM will shut down.

In addition to enabling specification of alternative servers, this panel enables 
specification of a number of other defaults, including the intervals at which 
reconnection should be attempted and the maximum number of retries allowed.

NOTE  
Servers whose icons display in red have been manually added to the Alternate Servers list.

Table 41 Reconnection panel default settings  

Field/option Default to be set

Alternative Servers / Select 
Servers

List the alternative servers. Click the Select Servers button to add, delete, 
and change the order of, alternate servers. For details, see “To modify the 
alternative server list.”

Check Automatically 
reconnect

CONTROL-M/EM should try to reconnect automatically without user 
intervention. This is known as Automatic mode. 

(The user can monitor and intervene as necessary while the connection is 
being reestablished.)

Restore xxx viewpoints (If clicked) CONTROL-M/EM should open the selected ViewPoints during 
reconnect. Click and select appropriate value:

■ Last active ViewPoint — Only the ViewPoint that was last active 
should be opened.

■ All open ViewPoints— All ViewPoints that were open at the time of 
the disconnect should be opened.

Max reconnection retries nn Maximum number of reconnection attempts CONTROL-M/EM should 
make. Default: 5.

Wait nn seconds between 
reconnection attempts

Number of seconds CONTROL-M/EM should wait between reconnection 
attempts. Default: 5 seconds.
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To modify the alternative server list

1 In the Reconnection panel, click Select Servers.

The Alternative Server Selection dialog box is displayed, listing the available 
servers on the left and the servers already selected as alternate servers on the right.

2 Select the desired server(s), and click

■ Add — to designate them as alternate servers.
■ Remove — to remove them from the alternate server list.
■ Add New — to add a new server to the list of available servers. The Add New 

Server dialog box appears. Enter the name of the server and click OK.

3 Click OK.

The Alternative Server Selection dialog box closes.

Diagnostics defaults

The Diagnostics panel sets defaults for printing diagnostics at the desired severity 
levels into a log file. The log file can then be sent to BMC Software Technical Support 
to help you troubleshoot technical problems with CONTROL-M/EM. 

The options of the CONTROL-M/EM Diagnostics panel are the same as for the same 
panel in CONTROL-M/Desktop. For details, see Table 36 on page 294.

Confirmation defaults

The Confirmations panel determines which confirmation requests and warnings 
should be displayed for various actions. 

The process of setting CONTROL-M/EM confirmations is the same as the process for 
CONTROL-M/Desktop. For details, see “Confirmation defaults” on page 296.

NOTE  
Use this panel only when instructed by BMC Software Technical Support. Your technical 
support representative will notify you which fields to change.
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Setting options for the CONTROL-M Reporting facility

This section presents tables with setting options for the following defaults:

■ Environment defaults
■ Viewer defaults
■ Confirmation defaults

Environment defaults

The Environment panel contains several display default settings for the 
CONTROL-M Reporting facility Preview window.

Viewer defaults

The Viewer panel contains several display default settings for the CONTROL-M 
Reporting facility Preview window.

Table 42 Environment panel

Field/option Default to be set

Display Report Tabs Tabs for each open report (and the Start Page) are displayed in the task 
bar at the bottom of the screen (default).

(If not checked, tabs are not displayed, but you can toggle between 
open reports through the Window menu option.)

Use flat buttons Tab appearance:
■ when checked, tabs appear as separate areas on a flat bar.
■ when not checked (default), tabs are raised and distinct. 

Display Report Icons Display report icons ( ) in the report tabs in the taskbar.

Close Report on Double Click Double-clicking the report tab closes the report. (Depending on other 
options, a confirmation prompt might be displayed.)

Display full path in tooltips Full report path will be displayed in a tooltip when you pass the cursor 
over the tab.

Display Report Text to appear in the tab. Valid values:
■ Filename — name of the report file
■ Title — report title (might be abbreviated)

Table 43 Viewer Panel (part 1 of 2)

Field/option Default to be set

Display Border Display a border around the report.

Display Background 
Edge

Display a background edge between the frame and the top of the page of the 
report
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Confirmation defaults

The Confirmations panel determines which confirmation requests and warnings 
should be displayed for various actions. Confirmation options are divided into the 
following sections:

■ Report Confirmations
■ Template Confirmations
■ Other Confirmations

The process of setting CONTROL-M/EM confirmations is the same as the process for 
CONTROL-M/Desktop. For details, see “Confirmation defaults” on page 296.

Conceal Last Shown 
Fields if Truncated 
(Upon Generation)

Do not display a truncated rightmost field in the viewer (if the rightmost field 
would appear truncated, conceal it).

Zoom Factor: n% 

Fit Page Width

Fit Whole Page 

Default Zoom Level when viewing reports. Select any one of the following levels:
■ set a fixed percentage zoom
■ page width fills the screen (it might be necessary to scroll the length of the 

page)
■ full page is displayed in the screen

Table 43 Viewer Panel (part 2 of 2)

Field/option Default to be set
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A p p e n d i x B
B  Examples for defining jobs

This appendix presents the following topics:

Accessing the sample draft . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  307
Organizing the company’s accounting jobs — the Ex-Accounting application . . . .  308

Handling invoicing needs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  308
Handling payroll processing needs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  311

Organizing the airline company’s flight jobs — the Ex-Flights application . . . . . . .  313
Handling flight-related communication needs . . . . . . . . . . . . . . . . . . . . . . . . . . . .  313

Organizing the IT department maintenance jobs — the Ex-ITMaintenance 
application  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  315
Handling IT job backup needs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  315
Handling emergency situations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  318
Handling component shutdown needs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  321

This appendix describes the job processing definitions in a sample draft that comes 
with this product.

Accessing the sample draft
CONTROL-M/EM comes with several drafts that you can open in 
CONTROL-M/Desktop. Each draft is located in a subdirectory of the 
BMC Software\CONTROL-M EM 6.4.01\Default directory:

■ Demo.drf—located in the \Samples subdirectory
■ Control-M Server Utilities.drf—located in the \Samples subdirectory
■ EXAMPLES.drf—located in the \Samples\User Guide Examples subdirectory

This appendix examines the jobs in the EXAMPLES.drf draft. 
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When working with this draft, remember that although the jobs are organized into 
applications and groups, they represent only a small sample of the jobs one might 
expect to find in such applications, and the only purpose of these jobs is to highlight 
certain job definition tasks. 

Documentation (.txt) files located in the same subdirectory as the draft file describe 
the jobs in the draft. (The name and path of a job’s documentation file appear in the 
Doc File and Doc Path fields in the General tab of the job editing form.) 

To open the EXAMPLES draft

In CONTROL-M/Desktop, click File => Open, browse to
BMC Software\CONTROL-M EM 6.4.01\Default\Samples\User Guide Examples
and select EXAMPLES.drf.

BMC Software recommends that you choose the View => Hierarchy => 
Application/Group/Job hierarchy, when working with these examples.

Organizing the company’s accounting jobs — 
the Ex-Accounting application

The accounting requirements of the company collectively fall into an application 
called Ex-Accounting. These accounting requirements, in turn, fall into the following 
functional groups: Invoicing (Ex-Invoicing) and Payroll (Ex-Payroll).

■ Ex-Invoicing—contains invoice jobs
■ Ex-Payroll—contains payroll jobs

Handling invoicing needs

To handle its invoicing needs, the company must process several types of information 
on a daily basis. The company runs a set of batch jobs each day, each job responsible 
for a particular type of information. The following list indicates the types of 
information, and the jobs that process the information:

■ calculate the day’s revenues—CalcRevenue job
■ calculate the day’s expenses—CalcExpenses job
■ calculate the day’s profits—CalcProfits job
■ determine which customer invoices should be billed that day—DueInvoices job
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This appendix examines the job processing definitions that automate the processing 
of these jobs. (Because of the dependency relationship that exists among the first three 
job, those jobs are explained together.)

Defining jobs to calculate revenue, expenses and profits

The CalcRevenue, CalcExpenses, and CalcProfit jobs run daily. 

The CalcProfit job requires the revenue and expense information generated by the 
CalcRevenue and CalcExpenses jobs, and therefore can run only after these jobs end.

All three jobs generate a printout of the processing results, and therefore require an 
available printer.

Defining the job type and other general information about the jobs

For each of these batch jobs, the General tab defines the following information:

■ The Tasktype is Job.
■ The File Name and Path fields identify the file name and location of the batch job. 

These are required fields for the Job tasktype.

Defining the jobs so that they are scheduled daily

The jobs are scheduled every day. In the Scheduling tab, the following values are 
selected:

■ all values of the Month-Days area (done by clicking ALL)
■ all values of the Week-Days area (done by clicking ALL)
■ the relational connector is Or, but And would also work

Ensuring that CalcProfits runs only after CalcRevenue and CalcExpenses have 
ended successfully

CalcRevenue and CalcExpenses can run in any order but both of those jobs must end 
successfully before CalcProfits can run. The Conditions tabs of these jobs are filled in 
as follows:

■ Both CalcRevenue and CalcExpenses have no predecessor jobs and therefore have 
no In prerequisite conditions. 
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■ When each job, CalcRevenue and CalcExpenses, ends successfully, it adds an Out 
prerequisite condition (ExCalcRevenuOK and ExCalcExpensesOK, respectively). 
The date definition for these conditions is the keyword, ODAT, which ensures that 
the condition is added to the system with the original scheduling date of the job. 
The + symbol in the Effect column instructs CONTROL-M to add (rather than 
delete) the condition. 

■ To ensure CalcProfits runs only after both CalcRevenue and CalcExpenses have 
successfully ended, CalcProfits has ExCalcRevenuOK and ExCalcExpensesOK 
defined as In prerequisite conditions. To ensure that these In prerequisite 
conditions are only satisfied by Out prerequisite conditions from the same day, 
they are assigned a date value of ODAT, which resolves to the original scheduling 
date. To ensure that both conditions are satisfied, an AND relationship value is 
selected in the field above the In Conditions work area.

■ No job other than CalcProfits has CalcRevenue and CalcExpenses as predecessor 
jobs. To increase system efficiency, after CalcProfits ends successfully, it deletes the 
ExCalcRevenuOK and ExCalcExpensesOK prerequisite conditions from the 
system by defining them as Out prerequisite conditions with a - symbol in the 
Effect column (to instruct CONTROL-M to delete, rather than add, the conditions). 
To ensure that only the conditions from that date are deleted, the Out prerequisite 
conditions are defined with an ODAT date value.

■ In case another job has CalcProfits as a predecessor job, after CalcProfits ends 
successfully, it adds ExCalcProfitsOK as an Out prerequisite condition, with ODAT 
as the date reference, and a + symbol in the Effect column.

Ensuring that the printer required by each of the jobs is available before the 
job is submitted 

Each of these jobs prints out a report of the data it processes (revenues, expenses, or 
profits). To ensure that the printer required for printing the reports is available, the 
Resources tab in each of the jobs indicates that the job requires exclusive control of the 
printer (in this case, Printer1). The job is not submitted unless the printer is available.

Defining a job that prints invoices that become due

The DueInvoices batch job prints out the list of customers whose invoices have 
become due.

Defining the job type and other general information about the job

The General tab defines the following information:

■ The Tasktype is Job.
■ The File Name and Path fields identify the file name and location of the batch job. 

These are required fields for the Job tasktype.
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Defining the job so that it is scheduled daily

The job is scheduled every day. In the Scheduling tab, the following values are 
selected:

■ all values of the Month-Days area (done by clicking ALL)
■ all values of the Week-Days area (done by clicking ALL)
■ the relational connector is Or, but And would also work

Ensuring that the printer required by the job is available before job submission 

The job prints out a report of the due invoices. To ensure that the printer required for 
printing the report is available, the Resources tab indicates that the job requires 
exclusive control of the printer (in this case, Printer1). The job is not submitted unless 
the printer is available.

Handling payroll processing needs

The company runs a batch job (CalcSalaries) that calculates the salaries to be paid to 
employees for the month just ended. After these calculations are completed, the 
company can run a paycheck printing job to print the pay checks. (The sample draft 
does not contain the job processing definition for the check printing job, but does 
contain the salary calculating job, described in this appendix).

Defining a job to calculate salaries

This batch job calculates employees salaries for the month just ended.

■ It should run once a month, on the first day of each month. 

■ The job should only run after all employees have submitted their time sheets.

■ Because of the confidential nature of information being processed, the job should 
only run on a Accounting Node node group. 

■ The job must run by a certain time to ensure that there is time for a different job 
(not in the draft) to print the pay checks.
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Defining the job type and other general information about the job

The General tab defines the following information:

■ The Tasktype is Job.
■ The File Name and Path fields identify the file name and location of the batch job. 

These are required fields for the Job tasktype.

Defining the job so that it is scheduled on the first day of each month

The job is scheduled on the first day of every month. In the Scheduling tab, the 
following values are selected:

■ day 1 in the Month Days area
■ all months in the Months area (done by clicking ALL)

Ensuring confidentiality by running the job on a particular node ID

Because of the confidential nature of data being processed, the Execution tab specifies 
that the job should only run on the Accounting Node Node ID/Group, which 
identifies a computer that is reserved for Accounting processing and physically 
located in a restricted area.

Ensuring that the job runs in time for pay checks to be printed

The Execution tab specifies that the job can only be submitted between the hours of 
1:00 and 3:00 AM. This ensures that the pay check printing job which follows will 
have plenty of time to print the pay checks before they are needed.

Ensuring that the job is not submitted until all time sheets have been 
submitted

To ensure that the job is not submitted until all time sheets have been submitted, the 
Conditions tab contains the EX_TimeSheetSubmitted In prerequisite condition. 

This condition is actually a manual condition; that is, it is not added by another job, 
but is instead added manually by the authorized manager from accounting only after 
all time sheets have been submitted. (The manager adds the condition using the Why 
dialog box in CONTROL-M/EM.) 
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Ensuring that the jobs that depend on successful completion of this job can run 
after the jobs ends ok.

In case other jobs depend on this job, after the job ends successfully, it adds the 
Ex_CalcSalariesOK Out prerequisite condition. The date definition for this conditions 
is the keyword, ODAT, which ensures that the condition is added to the system with 
the original scheduling date of the job. The + symbol in the Effect column instructs 
CONTROL-M to add (rather than delete) the condition. 

In addition, this job shouts a message to the appropriate location indicating that the 
pay checks can now be printed. This action is defined in the PostProc tab.

Organizing the airline company’s flight jobs — 
the Ex-Flights application

The primary objective of this airline company is to keep its airline routes functioning 
according to schedule, its seats booked, and its airplanes flying. The IT jobs that help 
the company meet its goals fall collectively into an application called Ex-Flights. 
Though, in reality, jobs in this application would fall into several groups, for 
simplicity the sample draft contains one group (Ex-Communication, which contains 
communication jobs), and this group contains one job.

Handling flight-related communication needs

The airline company runs a number of communication jobs. The sample contains one 
job, UpdateFlightTimes, which updates flight departure and arrival times.

Defining a job that updates flight departure and arrival 
times

The UpdateFlightTimes job runs a program that distributes updated departure and 
arrival times to the airline company's travel agents and associated airport monitors 
and Internet sites. 

This batch job should run repeatedly throughout the day (at one minute intervals 
from the start of the previous iteration).
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Defining the job type and other general information about the job

The General tab defines the following:

■ The Tasktype is Job.
■ The File Name and Path fields identify the file name and location of the batch job. 

These are required fields for the Job tasktype.

Defining the job so that it is scheduled daily

The job is scheduled every day. In the Scheduling tab, the following values are 
selected:

■ all values of the Month-Days area (done by clicking ALL)
■ all values of the Week-Days area (done by clicking ALL)
■ the relational connector is Or, but And would also work

Ensuring that the job cycles through every minute (from the start of the 
previous iteration)

In the Execution tab, click Cyclic job, and define the cycle interval as every one 
minute from the start of the job.

Defining special handling if the job does not cycle through successfully

It is critical that the job run every minute, and if there is a problem, it is critical that 
notification be sent to the main monitor. The Steps tab contains the following 
definitions:

■ If the job status is NOTOK (On stmt = *, Codes = NOTOK) do the following:

— Stop the job (Do StopCyclic).
— Shout a very urgent message, “Flight Updates,” to the main monitor.

Providing notification that the job processed successfully

Whenever the job ends successfully, a success message with the job’s runtime is 
shouted to the main monitor. The Shout message, Flights updated and distributed at 
%%TIME, is defined with a regular urgency in the PostProc tab. (The %%TIME 
AutoEdit variable resolves to the jobs runtime.)
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Organizing the IT department maintenance 
jobs — the Ex-ITMaintenance application

The IT department runs a number of maintenance jobs of different types, that are 
collectively organized into the Ex-ITMaintenance application. Most of the jobs in the 
sample draft perform tasks that must be performed in extreme emergencies (fire, 
floods, tornado watch, and so on). The draft also contains a job for routine, 
non-emergency backups.

During an extreme emergency, it is imperative that emergency procedures be 
immediately implemented to get employees to safety, get the system backed up, and 
to shut down CONTROL-M components. The sequencing of these jobs is important, 
and this, in turn, affects the groupings of these jobs.

Jobs in this application fall into the following groups:

■ jobs to perform backup, in both non-emergency and emergency situations—
Ex-Backups

■ jobs to initiate emergency procedures in an extreme emergency—
Ex-EmergencyProc

■ job to shut down CONTROL-M components after the emergency procedures have 
been implemented—Ex-ComponentStopping

Handling IT job backup needs

The Ex-Backup group contains two jobs, one that performs a standard backup of 
company data under normal circumstances, and another that performs a full backup 
in an extreme emergency.

Defining a standard backup job

The Backup job executes an operating system command (“copy”) to back up certain 
files from a directory to one of two tape drives. It should be scheduled every day.

Defining an operating system command job, and other general information 
about the job

The General tab defines the following:

■ The Tasktype is Command.
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■ The Command field contains the Copy command to be executed. This is a required 
field for the Command tasktype.

■ File Name is an optional field for Command-type jobs. Any value specified in this 
field appears as the job name in the job node in the flow diagram. Instead of 
leaving this field blank, BMC Software recommends that you specify the name of 
the job in this field. In this example, the job name (Backup) has been placed in the 
field.

Defining the job so that it is scheduled daily

The job is scheduled every day. In the Scheduling tab, the following values are 
selected:

■ all values of the Month-Days area (done by clicking ALL)
■ all values of the Week-Days area (done by clicking ALL)
■ the relational connector is Or, but And would also work

Ensuring that required tape drives are available before job submission 

Depending on the files being backed-up, this job copies the files to one of two tape 
drives. To ensure that these tape drives are available, the Resources tab indicates that 
two tape drives are required (as Quantitative resources). The job is not submitted 
unless the drives are available and reserved for the job.

Defining an emergency backup job

The BackupAllSystems job is executed only in extreme emergencies. It is not 
scheduled to run but is instead manually forced when needed. Because this critical 
batch job can be very damaging to the company if misused, only the CIO can force it. 
The job requires a large number of tape drives, has no predecessor jobs, and must 
complete the emergency backups before other jobs can shut down all systems. Once 
submitted, this job the highest priority.

Defining the job type and other general information about the job

The General tab defines the following:

■ The Tasktype is Job.

■ The File Name and Path fields identify the file name and location of the batch job. 
These are required fields for the Job tasktype.

■ Because this jobs is intended only for an extreme emergency, the Chief Information 
Officer is identified as the author.
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Defining the job scheduling

As already noted, this job is not scheduled. Rather, it is manually forced if needed. 
Therefore, it has no parameters defined in the Scheduling tab.

Ensuring that the job is treated with the highest priority 

Because of the critical and urgent nature of this job, the Execution tab defines the jobs 
as critical, and assigns it the highest priority (99).

Ensuring that the job has the required tape drives available

BackUpAllSystems must back up all systems to tape. It requires 50 available tape 
drives before it run. These are defined as quantitative resources in the Resources tab. 

Ensuring that successor jobs can run

BackUpAllSystems is a predecessor job to at least one other job. To establish the 
dependency between this job and its successor jobs, the following prerequisite 
conditions are defined (either can be used by the successor jobs):

■ An appropriate Out prerequisite condition is defined in the Conditions tab. The 
date defined for this Out prerequisite condition is the keyword, ODAT, to ensure 
that the condition is added to the system with the working date the job was forced. 
The + symbol in the Effect column instructs CONTROL-M to add the condition. 

■ An additional prerequisite condition is defined in the Steps tab as follows:

— An On statement (stmt= *** codes=OK) is defined to instruct CONTROL-M that 
the accompanying Do statement is performed if the job ends OK.

— A Do statement adds a condition with a date value of ODAT, indicating that the 
job’s task has been completed. The + symbol in the parameter column indicates 
that the condition is added (rather than deleted). 

Shouting appropriate notification when the job ends

After this job has ended successfully (that is, completed the backups), it shouts a very 
urgent notification to the CIO indicating that the task is completed. This Shout action 
is defined in the job’s PostProc tab.

NOTE  
This condition could have alternatively been defined as Out prerequisite conditions in the 
Conditions tab.
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Handling emergency situations

In the event of an emergency procedure, several tasks must be performed as a 
prelude to complete shutdown of the entire system.

■ All users must log out and leave the office. The AllUsersLogOut job runs a 
program that instructs all employees to do this immediately.

■ All data centers must be informed that this data center can no longer function. The 
SetUpEmergencyGlobalCondition job performs this task by running a program 
that sends out a global condition to this effect.

■ An emergency backup of all systems must be performed. (This is performed by the 
BackupAllSystems job in the Ex-Backup group.)

Only after these tasks are completed can systems be stopped. The jobs that stop the 
systems belong to a different group in this application. 

To simplify defining dependencies for these predecessor and successor jobs, and to 
simplify dependency definition changes that might be needed in the future (such as 
adding an additional predecessor job), an intermediate job, ShutDownAllSystems, is 
defined in the Ex-EmergencyProcs group. ShutDownAllSystems is defined as the 
successor job to the above jobs, and the predecessor job to the jobs in the 
Ex-ComponentStopping group that shut down CONTROL-M/EM components. 

Defining jobs to initiate user logout and notify other data 
centers that this data center has an emergency shutdown

The AllUsersLogOut and SetUpEmergencyGlobalCondition batch jobs are not 
scheduled to run; they are irregular, emergency jobs. To execute, these jobs must be 
manually forced. If misused, these jobs can be exceedingly damaging to the company. 
Therefore, only the CEO or someone with similar permissions can actually force these 
jobs. And to ensure that the CEO does not erroneously do so, these jobs require 
confirmation before submission.

Once submitted, these jobs are more critical than any other jobs. They are therefore 
defined as critical jobs having the highest priority.

Defining the job type and other general information about the jobs

The General tab defines the following:

■ The Tasktype is Job.

■ The File Name and Path fields identify the file name and location of the batch job. 
These are required fields for the Job tasktype.
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■ Because of the potential for harm from these jobs if inappropriately run, the 
Author fields identify the following authors (only the person named in the Author 
field can automate these jobs by having the New Day Procedure run them):

— For the AllUsersLogOut job—the CEO
— For the SetUpEmergencyGlobalCondition job—the CIO

Defining the job scheduling

As already noted, these jobs are not scheduled. Rather, they are manually forced if 
needed. Therefore, they have no parameters defined in the Scheduling tab.

Ensuring that the jobs are treated with the highest priority 

Because of the critical and urgent nature of these jobs, the Execution tab defines these 
jobs as critical, and assigns them the highest priority (99).

Ensuring that these jobs are not accidentally run

Because of the potential for harm from these jobs if inappropriately run, these jobs 
require manual confirmation before they can execute. Manual confirmation is defined 
by checking the Wait for Confirmation box in the Execution tab.

Ensuring that successor jobs can run

These jobs are predecessor jobs to at least one other job. To establish the dependency 
between these jobs and their successor jobs, the following prerequisite conditions are 
defined for each job (either condition can be used by the successor jobs):

■ An appropriate Out prerequisite condition is defined in the Conditions tab of each 
of the jobs. The date defined for this Out prerequisite condition is the keyword, 
ODAT, to ensure that the condition is added to the system with the working date 
the job was forced. The + symbol in the Effect column instructs CONTROL-M to 
add the condition. 

■ An additional prerequisite condition is defined in the Steps tab as follows:

— An On statement (stmt= *** codes=OK) is defined to instruct CONTROL-M that 
the accompanying Do statement is performed if the job ends OK.

— A Do statement adds a condition with a date value of ODAT, indicating that the 
job’s task has been completed. The + symbol in the parameter column indicates 
that the condition is added (rather than deleted). 
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Implementing the purpose of the AllUsersLogOut job

The purpose of the AllUsersLogOut job is to notify all users to log out and go home. It 
does this by shouting a very urgent notification message to this effect to all users. This 
shout action is defined in the job’s PostProc tab.

Initiating the shut down of all systems

The ShutDownAllSystems batch job runs a program that (through the setting of an 
Out prerequisite condition) enables another set of jobs to shut down 
CONTROL-M/EM components. ShutDownAllSystems can only run after its 
predecessor jobs have ended successfully.

Defining the job type and other general information about the job

The General tab defines the following:

■ The Tasktype is Job.

■ The File Name and Path fields identify the file name and location of the batch job. 
These are required fields for the Job tasktype.

■ Because of the potential for harm from this job if inappropriately run, the CIO is 
defined as the Author. (Only the person named in the Author field can automate 
this job by having the New Day Procedure run it.)

Defining the job scheduling

This jobs is not scheduled. Rather, it is manually forced if needed. Therefore, it has no 
parameters defined in the Scheduling tab.

Ensuring that the job is treated with the highest priority 

Because of the critical and urgent nature of this jobs, the Execution tab defines it as 
critical, and assigns it the highest priority (99).

NOTE  
This condition could have alternatively been defined as Out prerequisite conditions in the 
Conditions tab.
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Ensuring that this job does not run until its predecessor jobs have ended

ShutDownAllSystems initiates system shut down. It must not run until:

■ all users have logged out (initiated by the AllUsersLogOut job)
■ all system files have been backed up (initiated by the BackUpAllSystems job)
■ all other data centers have been notified of the shut down (initiated by the 

SetUpEmergencyGlobalCondition job)

To ensure that it runs only after all its (above-mentioned) predecessor jobs have 
ended successfully, ShutDownAllSystems contains the following definitions:

■ its Conditions tab contains In prerequisite conditions that match the conditions 
defined in Do Condition statements in the predecessor jobs. These In prerequisite 
conditions are assigned a date value of ODAT.

■ the field above the In Conditions work area in the Conditions tab defines an AND 
relationship between the In prerequisite conditions.

Ensuring that successor jobs can run

This job is a predecessor job to most of the shut down jobs in the 
Ex-ComponentStopping group. To enable the successor jobs to run, after 
ShutDownAllSystems adds the following Out prerequisite conditions (with a date of 
ODAT and a + symbol in the Effects column) after it ends successfully:

■ ShutDownAllSystems-ENDED—this condition defines this jobs as a predecessor 
job for the remaining jobs in this table (this Out prerequisite condition is defined as 
an In prerequisite condition for those jobs).

■ EX_ShutDownAll—this condition serves as an indicator that this job ended for any 
other jobs that might need to know.

Handling component shutdown needs

The Ex-ComponentStopping group contains jobs that are used to shut down (stop) 
CONTROL-M components. Normally, shut down of components is not required. 
However, situations can arise that require component shutdown. These situations can 
range from extreme emergencies (as handled in this sample draft) to minor 
malfunctions, repairs, or maintenance.

Each job in this group shuts down a single component. With the exception of the job 
that shuts down the gateway, which must run last, the jobs in this group can run in 
any order or sequence.
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Defining jobs that stop the GAS, GCS, and GUI servers and 
CMS and BIM

These jobs should run only after ShutDownAllSystems (in the Ex-EmergencyProcs 
group) has ended successfully. As their names indicate

■ GASStopped—stops the Global Alerts Server.
■ GCSStopped—stops the Global Conditions Server.
■ GUIServerStopped—stops the GUI Server.
■ CMSStopped—stops the Configuration Management Server.
■ BIMStopped—stops the Batch Impact Manager Server.

Defining jobs that implement operating system commands, and other general 
information about the jobs

Each of these jobs issues an operating system shutdown command. For each of these 
jobs, the General tab defines the following:

■ The Tasktype is Command.

■ The Command field contains the following operating system Stop command to be 
executed: ctl -u emuser -p empass -C component -all -cmd stop, where
component is the relevant CONTROL-M component (GAS, GCS, and so on). This is 
a required field for the Command tasktype.

■ File Name is an optional field for Command-type jobs. Any value specified in this 
field appears as the job name in the job node in the flow diagram. Instead of 
leaving this field blank, BMC Software recommends that you specify the name of 
the job in this field (as has been done in these sample jobs).

Ensuring that these jobs will not run until their predecessor job has ended

Each of these jobs has ShutDownAllSystems-ENDED defined as an In prerequisite 
condition in its Conditions tab. (This condition is only added after 
ShutDownAllSystems has ended successfully.) The In prerequisite conditions are 
assigned a date value of ODAT.
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Ensuring that successor jobs can run

After each of these jobs ends successfully, it adds two Out prerequisite conditions (for 
example, EX_GCSStopped and EX_GCSStopped-ENDED), either of which can be 
used by successor jobs. The date definition for these conditions is the keyword, 
ODAT, which ensures that the condition is added to the system with the original 
scheduling date of the job. The + symbol in the Effect column instructs CONTROL-M 
to add (rather than delete) the condition. (The successor job, GatewayStopped, uses 
the name-ENDED condition.) 

Defining a job that stops the gateway

The GatewayStopped job stops the Gateway. It should only be run after the other 
components have been stopped.

Defining the job to implement an operating system command, and other 
general information about the job

Like its predecessor jobs, this job issues an operating system Stop command. The 
General tab defines the following:

■ The Tasktype is Command.

■ The Command field contains the following operating system Stop command to be 
executed: ctl -u emuser -p empass -C Gateway -all -cmd stop. This is a required field 
for the Command tasktype.

■ File Name is an optional field for Command-type jobs. Any value specified in this 
field appears as the job name in the job node in the flow diagram. Instead of 
leaving this field blank, BMC Software recommends that you specify the name of 
the job in this field (as has been done in this sample job).

Ensuring that this job will not run until all its predecessor jobs have ended

To ensure that it runs only after all its predecessor jobs have ended successfully, 
GatewayStopped contains the following definitions:

■ its Conditions tab contains In prerequisite conditions that match an Out 
prerequisite condition (the name-ENDED condition) defined in the Conditions tab 
of each of its predecessor jobs. These In prerequisite conditions are assigned a date 
value of ODAT.

■ the field above the In Conditions work area in the Conditions tab defines an AND 
relationship between the In prerequisite conditions.
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Ensuring that successor jobs can run

After GatewayStopped ends successfully, it adds the Out prerequisite condition 
EX_GatewayStopped (with a date of ODAT and a + in the Effects column) that can be 
used as an In prerequisite condition by other jobs.
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A p p e n d i x C
C  Formats, values and functions

This appendix presents the following topics:

Pattern-matching strings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  325
Using SQL wildcards  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  328

Valid functions for Template editor and condition formats . . . . . . . . . . . . . . . . . . . .  329

This chapter provides the following format rules, valid values, and functions:

■ Pattern matching strings — these can be used in fields that support wildcards.

■ Valid functions - these can be used in the Template editor (discussed in Chapter 9, 
“Setting up templates for standardized job definition”) and in Condition formats 
(discussed in “Defining a condition format” on page 110.) 

Pattern-matching strings
Fields used to select data (for example, in the Scheduling Table Manager window), 
accept pattern-matching strings, or expressions, as input. Using these strings, the user 
can select many different entities by specifying a relatively simple combination of 
characters and symbols.

Table 44 describes the symbols used to compose pattern-matching strings.

NOTE  
The use of complex expressions tends to reduce performance.
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Table 44 Symbols used to compose pattern-matching strings  (part 1 of 2)

Symbol Name Usage

* Asterisk wildcard Denotes any number of characters (including no 
characters). This can be inserted in place of a string.
Note: In filter criteria fields, if filtering is not needed, it is 
more efficient to leave the field blank than to use the "*" 
character.

? or . Question mark 
wildcard, or period

Denotes any single character. This can be inserted in 
place of any number of characters.

! Exclamation Denotes all possibilities that do not match the pattern 
that immediately follows the ! character. This can be 
specified to exclude the pattern immediately following 
the ! from the result. 
Where a pattern begins with !, the escape character 
backslash “\“ can be used to escape the ! and either 
include or exclude the pattern (required only where ! is 
the first character). For example, to include occurrences 
of “!wip”, use the pattern “\!wip”, whereas “!\!wip” 
excludes “!wip”.

Note: 
! must be the first character of the string, for example, in 
the expression (first!,!one) the exclamation is part of the 
string “first!”, but is used to exclude the string “one”.

■ ! is evaluated literally in collection and filter 
definition fields.

[ ] Brackets Denotes different possibilities for a single character. The 
brackets enclose a string of possible values. In addition, 
the following symbols can be used within the brackets:

■ – denotes a range of characters.
■ ^ used as the first character in the brackets to denote 

"not".

, or | Comma or pipe Used to separate pattern-matching strings, enabling the 
user to specify more than one string (the comma 
represents a Boolean OR).
Example
(host01, host02, host03)

Note: “,” is evaluated literally in collection and filter 
definition fields.

character Character Any character, other than one of the above, denotes the 
specific character. 
Note: In case-sensitive fields, CONTROL-M/Desktop 
differentiates between uppercase and lowercase 
characters (for example, “a” and “A” are regarded as two 
different characters).
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Table 45 lists examples of expressions used to select data centers. Specifying any one 
of them would include data center DALLAS.

^ Anchor (start) ■ Denotes "not" when used as the first character in 
brackets [ ].

■ Denotes the start of a word when not specified in 
brackets [ ].

$ Anchor (end) Denotes the end of a word.

\specialchar Escape character Denotes the literal value of the special character. The 
special characters are the symbols described in this table.

Examples
■ To specify \, type \\.
■ If you specify \. then "." has the meaning of period 

and not the same meaning as ?.
■ Use "\" to escape ! only where ! is the first character.

NOTE  
XML term files support the use of "," to separate values and "!" to exclude values.

TIP  
If you use special characters, such as asterisk, as a literal part of the object name (for example, 
glo*-job1_started), and when you filter you want to include only these objects (for example, 
you do not want to include glo-job1_started), specify \ before the special character in the 
filter prefix (for example, glo\*). Otherwise, objects without the special character (for 
example, glo-job1_started) will also be included. (Wherever possible, try to avoid defining 
object names with special characters as literals.)

Table 45 Examples of expressions  (part 1 of 2)

Pattern Includes...

DALLAS, NY, LA The three data centers DALLAS, NY, LA.

D*S All data centers whose name starts with D and ends with S.

D????S All data centers whose name starts with D, ends with S and consists of 
six characters.

D*ALL?S All data centers whose name starts with D and ends with five letters 
matching the pattern signified by ALL?S.

!NY All data centers except for NY.

LA,!NY,D*S Data centers LA and DALLAS, excluding NY.

DALLAS,TEXAS\* The data centers DALLAS and TEXAS*.

Table 44 Symbols used to compose pattern-matching strings  (part 2 of 2)

Symbol Name Usage
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Using SQL wildcards

The SQL wildcards

■ % denotes any or no character
■ _ denotes any one character

These wildcard characters, when used in ViewPoint collections and filter definitions, 
are evaluated as literal % and _ characters, (not as wildcards). 

D[ABC]* All data centers whose name starts with D and whose second letter is 
A, B or C.

D[A-E]???? All data centers whose name starts with D, whose second letter is in the 
range of A-E and whose name consists of six characters.

D[^B-Z]* All data centers whose name starts with D and whose second letter is 
not in the range of B-Z.

NY,D*S Data center NY and all data centers matching the pattern signified by 
D*S.

Table 45 Examples of expressions  (part 2 of 2)

Pattern Includes...
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Valid functions for Template editor and 
condition formats

This table lists valid functions for use in the Template editor and condition formats 
(including the assign function in Find and Update).

Table 46 Valid functions — Template editor and condition formats

Function Description

{Field Name} Name of a field in the job or group processing definition. Use the name 
of the field exactly as it appears in the From source list in the Insert 
Function dialog box. For example, the Mem Name of this job is {Mem 
Name}.

Note for conditions and condition formats:

Where you specify both a FromJob (predecessor job) field name and 
a ToJob (successor job) field name, the format is

■ For the FromJob: {fieldname} 
■ For the ToJob: {ToJob[fieldname]} 

For example, to indicate the Mem Name of the FromJob and ToJob, 
specify
{Mem Name}-{ToJob[Mem Name]}.

{Counter} Incremental number to be inserted in the value (for example, This job is 
Job # {Counter}).

{+ | -{numerical field| function},quantity to add or subtract}

Indicates an amount to increment or decrement a number in the 
condition name format. This function can be used to reference a 
previous or subsequent job (for example, Job#{-{Counter},1}-ENDED).

{Substr position.length,{fieldname | function}}

Substring from a specified field or function.

position Offset of the substring within the field/function 
(zero-based)

length Number of characters

fieldname Name of the field

function Name of the function

For example, to indicate the first two characters of Mem Name, specify 
{Substr 0.2,{Mem Name}}.
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A p p e n d i x D
D  Checking job processing definition 
validity

This appendix presents the following topic:

Checking the validity of job processing definitions . . . . . . . . . . . . . . . . . . . . . . . . . . .  331

Checking the validity of job processing 
definitions

Though generally not recommended, you can change the default so that the validity 
of job processing definitions that you define in your local workspace is not checked. 
For example, you might want to create a template (see Chapter 9, “Setting up 
templates for standardized job definition”) or perform a mass job create (see 
Chapter 10, “Creating and updating many jobs at once”) that will not pass validity 
checks until you later manually add more details. (To change the default setting of 
the automatic validity checker, use the General options panel of 
CONTROL-M/Desktop, which you can access by choosing Tools => Options.)

If you changed the default, you should perform the validity checks (as described in 
this section) before writing, uploading or ordering the jobs, or you might corrupt 
your database. (And when you are ready, ensure that you set the default back to 
automatic validity checking.) 

NOTE  
By default, the validity of job processing definitions is automatically checked when you save 
the definitions, and this procedure is not necessary. Use this procedure only if you changed 
the default so that the job processing definition validity is not automatically checked.
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To check the validity of the jobs in a draft

In CONTROL-M/Desktop, open the draft and choose Tools => Validity Checks.

CONTROL-M/Desktop checks the validity of all job processing definitions in the 
draft and displays the errors in the Validity Checks Error Messages dialog box.

To correct the errors found during a validity check

Use one of the following methods to correct errors found during a validity check:

■ Double-click the job name in the Validity Checks Error Messages dialog box to 
open the Job Editing form for the job. Make the necessary corrections and then 
click OK to save the changes to the job processing definition.

■ If many jobs have the same error(s), use the Find and Update facility to make the 
corrections. For more information, see “Finding and updating many entities at 
once” on page 148.
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managing 137–140
overview of 133

changing
passwords 285
workspaces 42

changing password 46
CMSStopped job 322
collapsing the display 39
colors

of high-level nodes 35
of title bar 34

Communication Status dialog box 201
communication, between components 199
conditions

changing default format 110
defining prerequisite jobs 82

conditions See also global conditions
connecting

automatically reconnecting 199
CONTROL-M/Desktop to a different GUI Server 27
modes of 290
to a different Naming Service 256

control resources
overview of 175

CONTROL-M IOABLCAL utility 134
CONTROL-M New Day indicators 297
Control-M Server Utilities.drf file 61
CONTROL-M/Desktop

adjusting the display 37
arranging the flow diagram display 41
connecting to a different GUI Server 27



334 CONTROL-M User Guide

A   B   C   D   E   F   G   H   I   J   K   L   M   N   O   P   Q   R   S   T   U   V   W   X   Y   Z

customizing 285
filtering jobs 40
loading jobs 42
starting 26

CONTROL-M/EM
adjusting the display 37
customizing 285
starting 27

CONTROL-M/Server time 296
conventions, documentation 18
converting old reports 273
Copy Tags option disabled 109
copying scheduling tags 109
Critical Path 296
cryptocli utility 256
Crystal Reports application, use of 253
CSV file, exporting 45
ctmcontb utility job 61
ctmcreate utility job 61
ctmdefine utility job 62
ctmkilljob utility job 62
ctmloadset utility job 62
ctmorder utility job 62
CTMRPLN utility 134
ctmudly

sample job 62
ctmvar_delete utility job 62
ctmvar_set utility job 62
customer support 3
customizing the GUIs 285
cyclic jobs, defining 73

D
data source definition for MS-SQL 257
data source definition for PostgreSQL 257
date range for job ordering 71
definition mode 42
deleted jobs

managing 127–??
deleting

calendars 139
global condition 185
job dependencies 110
prerequisite conditions 235
quantitative resource 179
scheduling tables 115
templates 145
variables 62

dependencies. See job dependencies
dependency names, displaying 38
Diagnostics panel 294
Display execution time 296
displaying

dependency names in a node 38
job processing definition 39

nodes 39
DO action parameters 91
documentation information 17, 18
downloading

calendars 138
scheduling tables 170

draft file of sample jobs 61
dynamically filtering ViewPoint display 206

E
ecactltb utility job 62
ecaqrtab utility job 62
ecaqrtab_add utility job 62
ecaqrtab_list utility job 62
electronic documentation 17
emergency

backup, sample scenario 316
notification job 318
situations, handling 318

emreportcli report utility 263
emreportcli.dtd file 265
end of job shout messages 96
errors

See also messages
Active Group Errors report 271
Active Loop Errors report 271
Definitions Group Errors report 271
Definitions Loop Errors report 272
displaying during job intervention 234
NOTOK job status 104
setting diagnostic defaults 294

events, playing back archived 277
exceptions

See also alerts
monitoring 204

excluding. See filtering
expanding the display 39
exporting

alerts list to CSV file 218
batch reports 263
job list to CSV file 45
reports in Report Preview window 259

F
file

FileWatch.xml 268
File Watcher

panel 268
files

.rpt report and template 253
Control-M Server Utilities.drf 61
CSV file, exporting 45
emreportcli.dtd 265
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log file 294
mcs.ini 256
sql.ini 257
template XML files 145
tnsnames.ora 257

FileWatch.xml
import 268

filtering
jobs in CONTROL-M/Desktop 40
pattern-matching symbols available for 325
SQL wildcards available for 328
ViewPoint display 205

finding jobs 43
flow diagram

arranging the display in CONTROL-M/Desktop 41
changing formats 37
defining dependencies 42
format 37
job dependency indicators 36
navigating 43
printing 45
understanding 33

focusing on node levels 38
forecasts

overview of 279
forms

FileWatch.xml 268

G
Gantt chart 37, 296
Gantt chart format 32
Gantt view 297
GAS. See Global Alerts Server
GASStopped job 322
gateway, stopping 323
GCSStopped job 322
Global Alerts Server (GAS)

connecting to 216
setting defaults 301
stopping 322

global conditions
defining 184
examples 186
in Active Links report 271
in Link Definition report 271
overview of 183
SetUpEmergencyGlobalCondition job 318
unexpected results warning 185

GUIServerStopped job 322

H
Help, online 17
hiding nodes 39

hierarchy view 40
historical data. See archiving data

I
icons, described 33
import

FileWatch.xml 268
initialization (ini) files. See files

J
JCL

editing 232
viewing 224

job dependencies
across CONTROL-Ms 183
defining prerequisite conditions 234
defining with flow diagram 109
detecting loops in conditions 83
recognizing 36

Job History window 119
job list view 40
job node colors 34
job versions

managing 126–??
jobs

See also job dependencies
See also scheduling jobs
allocating resources for 83
comparing 123–??
defining postprocessing actions 87
defining predecessor 44
defining prerequisite conditions 82
defining successor 44
defining variables for 84
displaying action messages 234
issuing end of job messages 96
load balancing 77
manual intervention 230
restarting z/OS 233
sample jobs 307
samples file 61
SYSOUT handling 98
utility to create in Active Jobs file 61
utility to terminate 62
validating changed job definitions 331
z/OS conditional processing 94

Jobs Execution report 273

L
list format 37
load balancing, running jobs on specific nodes 77
loading jobs, CONTROL-M/Desktop 42
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local time 296
locked

calendars 139
scheduling tables 115
tables during upload 26

log file, creating with Diagnostics panel 294
loopdetecttool utility 83

M
main pane 32
managing job versions 119
mcs.ini file 256
messages

See also errors
issuing at end of job 96
writing to log file 294

migrating old reports 273
monitoring

alerts 215
exceptions 204
using BMC Batch Impact Manager 243

MS-SQL, adjusting data source definition 257

N
Naming Service host name and port 256
navigating flow diagram 43
navigation tree pane 32
Net Overview pane 32
network neighborhood 44
New Day procedure, scheduling jobs with 173
nodes in flow diagram

hiding 39
icons 33
level focusing 38

notifications in scheduling groups, defining 103

O
online Help 17
Oracle, adjusting tnsnames.ora 257

P
pane repositioning 37
panel

File Watcher 268
password changing 46
passwords, changing 285
pattern-matching symbols 325
playing back archived events 277
PostgreSQL, adjusting data source definition 257
predecessor jobs 44

predicting scheduling needs. See forecasts
Prefix text box, special characters warning 185
prerequisite conditions

defining 82
utility to process table of 61

printing
diagnostics 294
flow diagram 45
lists of alerts 218

problems. See troubleshooting
product support 3

Q
quantitative resources

See also resources
defining 179
overview of 175

Quantitative Resources table utilities 62

R
recognizing job dependencies 36
related documentation 17
releasing

control resources 177
reports

batch 263
BMC Batch Impact Manager 273
changing Reporting facility password 285
converting old 273
creating one-time 263
CTMRPLN calendar utility 134
generating 258
Job Action Report 234
Jobs Execution 273
overview of 253
starting Reporting facility 254
templates for 259
Trend Analysis 273
types of 270
Workload 273

repositioning panes 37
rescheduling jobs manually 236
resources

allocating job 83
defining quantitative 179
defining requirements for 175
listing jobs and tables that use 178
Quantitative Resources table utilities 62

retroactively scheduling jobs 73

S
sample jobs file 61
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scheduling groups
copying tags between groups 109
creating and editing 99–105
defining variables in 103
finding 149
managing 118–121

scheduling jobs
defining criteria for 64–73
defining post-processing actions 104
manually 168
manually rescheduling 236
using calendars 133
with New Day procedure 173

scheduling needs, predicting. See forecasts
scheduling tables

automation criteria 174
creating and editing 106–108
managing 114–118

script
editing a job’s 232
viewing a job’s 224

selection mode 42
shout messages at end of job 96
shutting down all systems, sample scenario 320
special characters

in filtering and pattern-matching 325
Prefix text box warning 185

SQL wildcards for filtering 328
sql.ini file for Sybase 257
starting

CONTROL-M/Desktop 26
CONTROL-M/EM 27

stepping in and out in flow diagram 38
stopping

BIM 322
Configuration Management Server 322
cyclic jobs 91
gateway 323
Global Alerts Server 322
Global Conditions Server 322
GUI server 322

successor jobs 44
support, customer 3
Sybase, adjusting sql.ini file 257
symbols in filtering and pattern-matching 325
syntax statement conventions 18
SYSDATA, archiving 99
SYSOUT handling 98

T
technical support 3
Template editor, functions 329
templates

for job definition 141–145
for reports 259

functions in Template editor 329
temporarily filtering ViewPoint display 206
terminating jobs, utility for 62
title bar color indicators 34
tnsnames.ora file for Oracle 257
tree icons 33
Trend Analysis report 273
troubleshooting

Copy Tags option disabled 109
job order changes ignored 170
locked calendars 139
locked scheduling tables 115
locked tables during upload 26
no jobs displayed in ViewPoint 212
nodes not displayed in ViewPoint 219
performance and general global conditions 185
tables removed from user daily 117
unexpected results with global conditions 185
using Diagnostics panel 294
z/OS scheduling table not assigned to user daily 116

U
unlocking

calendars 139
scheduling tables 115
tables during upload 26

uploading
calendars 138
scheduling tables 166

user dailies
assigning a scheduling table to 174
defined 173
ordering jobs with ctmudly 62
scheduling with New Day procedure 173
table removed when uploading 117

util utility 280
utilities

cryptocli 256
CTMRPLN 134
emreportcli 263
list of CONTROL-M/Server 61
loopdetecttool 83
util 280

V
validating changed job definitions 331
variables

defining and using for job processing 84
in report templates 254
in scheduling groups 103
utility to delete 62
utility to set 62

ViewPoints
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defining 210
displaying archived data 276
displaying on start up 298
dynamically filtering display 206
filtering 205
opening an alert in 218
overview of 204
properties when displaying jobs 227
setting color of archived 301
ViewPoint wizard 213

W
What-If scenario 297
wildcards in filtering and pattern-matching 325
wizard, ViewPoint 213
Workload report 273
workspaces

changing 42
overview of 50
setting defaults for 291
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